[TRADOS 2007] How can I just ignore some tags at the beginning / end of a translation unit?
Thread poster: nicomigo
nicomigo
Germany
Oct 13, 2010

Good day,

My question is the following: how can I just ignore some tags so that they just don't appear in the translation units that I am seeing?

For instance, when translating an excel file in Trados I have always this tag showing up at the beginning of a cell "< cf font="Calibri" size="11" >" and would just like it to be ignored, as well as the end tag of the cell "< /cf >". Which means that I would like to translate only the content of the cells, because these tags will remain the same anyway. This is very disturbing because I have to go through every single one of these tags and copy them each time. I don't know exactly, but should these tags be considered as External / Internal / Placeholders? I really have a loooot of data to process and I just can't imagine copying these tags for all eternity...

Any idea / solution? Should I change the tag settings file and if yes, how? Should I change some other part of the settings, where could I had these tags so that they are constantly ignored?

Thank you in advance, this would really help!

[Edited at 2010-10-13 21:28 GMT]


Direct link Reply with quote
 
Adam Łobatiuk  Identity Verified
Poland
Local time: 02:46
Member (2009)
English to Polish
+ ...
What tags? Oct 13, 2010

I'm afraid the examples you gave are not displayed here - try adding spaces after < and before >. However, in my experience, cells in TTX files are between < cell > < /cell > tags, which are already external and do not appear in open segments, so you might want to keep those tags.

You could try selecting "Copy source on no match" in Workbench - Options - Translation Memory Options - General, under Switches. That should save you some time.


Direct link Reply with quote
 
nicomigo
Germany
TOPIC STARTER
The tags are visible / my problem remains Oct 13, 2010

I updated my post, you can now see the tags that are currently causing the issue.

The < cell > tags are excluded from the translation units and this is fine. I really need to get rid of these other tags, which are by the way unnecessary and only for font and size. Copy source is not an option, as I also have a TM with pretranslated texts from Wordfast and I also need to make a big translate to fuzzy with it (or to use the "translation" function from the workbench). Wordfast recognizes the tags properly. Unfortunately, I don't have a Wordfast licence and my TM is really big... so I need to do it with Trados and Trados is not seeing these tags as external to the TU. I really need to get these tags out of all my TUs and I don't know how to do.

There should be some settings that can influence it in the workbench... but I don't know which ones.

I would also ask if this is possible - for instance - to "externalize" some specific characters with the workbench. For instance, let's say that I would like the character $ or £ (or any other kind of special character that I could specify myself) to stay exactly the same or even to "cut" a translation unit in to parts.

[Edited at 2010-10-13 21:51 GMT]


Direct link Reply with quote
 
Adam Łobatiuk  Identity Verified
Poland
Local time: 02:46
Member (2009)
English to Polish
+ ...
Settings Oct 14, 2010

You can adjust some settings using the Filter settings application in Trados/Filters in your SDL Trados item of the Start menu. You could also edit the Excel xml files in C:\Users\All Users\SDL International\Filters\ if you want to dig deeper, but I'm not sure it's a good idea.

If special characters are changed and it is not what you want, it probably has to do with substitutions that you can change in Workbench: File - Setup - Substitutions. Frankly, I don't remember Trados ever changing currency symbols. To set a character as a segment boundary, you need to go to File - Setup - Segmentation rules in Workbench.

Now back to the font tags. It seems that they are necessary, because Callibri 11 is not the default font setting in Excel. If they get in your way, however, you could copy whole columns to Word, set the style to Normal, translate in Word, paste back to Excel and apply the original font. There may be some issues with line breaks within celss, but you can fix them manually.

Hope that helps.


Direct link Reply with quote
 
nicomigo
Germany
TOPIC STARTER
Thank you, but... Oct 14, 2010

Thank you, but I tried unsuccessfully many of the solutions that you propose. Let's see one by one.

Adam Łobatiuk wrote:

You can adjust some settings using the Filter settings application in Trados/Filters in your SDL Trados item of the Start menu. You could also edit the Excel xml files in C:\Users\All Users\SDL International\Filters\ if you want to dig deeper, but I'm not sure it's a good idea.


For instance, in the file Excel_1_0_0_0.xml, I found the following:

< FilterDefinition >
< Guid >TRADOS Excel Filter 0.1.0.0< /Guid >
< FileTypeName >Microsoft Excel 2000-2003< /FileTypeName >
< FileFilterRegExp >*.xls;*.xlt< /FileFilterRegExp >

//// this is the kind of file I have, *.xls. so I guesse this should be the right files

< QuickTags >
< QuickTag Command="Bold" >
< StartTag >< /StartTag >
< EndTag >< /EndTag >
< /QuickTag >

I tried adding a QuickTag value with the < cf font.... > but it still doesn't seem to be working as external, I just can't find it in the workbench even if I reimport the file.

In the filters from the start menu, and since I also know pretty well regular expressions, I also tried to add the tags in the external section. No success. By the way, which fleavour (scintilla, perl...?) is in use for regular expressions in trados?

Also, I heard about this "t4win.win"? I just don't understand how it is working and I don't find the infos over the Internet... could it be of any help in this case?


If special characters are changed and it is not what you want, it probably has to do with substitutions that you can change in Workbench: File - Setup - Substitutions. Frankly, I don't remember Trados ever changing currency symbols. To set a character as a segment boundary, you need to go to File - Setup - Segmentation rules in Workbench.


The point is not to change currency symbols but to give characters that should be skipped?

In the section that you mention, substitution for instance, there is a text on the bottom: "Other substitutions" - None. Well, I would like to add my own characters, but it's just not an option, there is no checkbox to tick and nothing else to do there...


Now back to the font tags. It seems that they are necessary, because Callibri 11 is not the default font setting in Excel. If they get in your way, however, you could copy whole columns to Word, set the style to Normal, translate in Word, paste back to Excel and apply the original font. There may be some issues with line breaks within celss, but you can fix them manually.


These font tags are default in my version of Excel. If I just bypass the tags (I tested it in one file) then it still works (I can save the ttx as excel again, no problem). Yet, in order to bypasse the files, it's pretty time consumming in the long run... and I can not do any fuzzy, it will always block even if I made the selection for the lowest settings considering tags, which means it doesnt give me an error message if I validate a translation unit. "There may be some issues with line breaks within celss, but you can fix them manually." -> I tried that in a txt file for instance. Well, to do that manually in very big files is a real pain!...

Thank you for your help anyway! Many some other people can help further in this, I am really stuck at the moment, the workarounds take really too long in any case... I need to get rid of these tags and I will anyway need this kind of possibility later for other files, I am sure.

[Edited at 2010-10-14 09:36 GMT]

[Edited at 2010-10-14 09:36 GMT]

[Edited at 2010-10-14 09:37 GMT]


Direct link Reply with quote
 

Daniel Grau  Identity Verified
Argentina
English to Spanish
Do_not_translate? Oct 14, 2010

What if you were to do a global replacement of those tags to the "Do_Not_Translate" style? Afterwards, you would just change them back to "t4winInternal".

Daniel


Direct link Reply with quote
 
nicomigo
Germany
TOPIC STARTER
Please explain me Oct 14, 2010

Daniel Grau wrote:

What if you were to do a global replacement of those tags to the "Do_Not_Translate" style? Afterwards, you would just change them back to "t4winInternal".

Daniel


Thank you for your answer. Excuse me but what is / where can I find this "Do_Not_Translate" style? Where can I find it and how do I use this "t4winInternal"? (as in a big post above that is waiting for validation, I mentioned this as something I heard and didn't understand at all)


Direct link Reply with quote
 
Adam Łobatiuk  Identity Verified
Poland
Local time: 02:46
Member (2009)
English to Polish
+ ...
A few points Oct 14, 2010

Quicktags in the filter definition files apply to buttons on the Tag Editor toolbar - you can quickly apply bold formatting for example. I don't think you should change those or add anything there.

There is some confusion in this thread about styles. tw4winInternal/External and Do_Not_Translate are used when you translate in Word, not in Tag Editor, which uses tags, not styles.

To skip characters or words, you can try adding them to File - Setup - Substitutions - Variable list (select the Variables checkbox first). See Help in the dialog for more.

When it comes to regular expressions in Trados, I'm always at a loss, sorry. Sometimes they are MS Word-like, sometimes like in Unix...

Segmentation rules - I've never had to change them much, so I'm not sure. Please check the Help in the dialog.

To work with many line breaks from Excel: in Word, they will be treated as soft line breaks (you find them with ^l in Word). Once you are done translating in Word, clean up the file and replace all instances of ^l with a unique symbol or string, like &&& or whatever. When you have pasted the content back to Excel, replace the symbol or string with an invisible character that you enter with ALT-010. The cursor might blink, but nothing visible will be entered. This should do the job, but you might have some problems with particularly long strings in cells.


Direct link Reply with quote
 
nicomigo
Germany
TOPIC STARTER
Substitutions / Tag settings Oct 14, 2010

* Substitution is just not working at all, even after I tried a reorganize of the TM or after creating a complete new one...

* About the settings files for excel, there are many parameters in there after the QuickTags, I don't know which ones could be of use in my case?

[Edited at 2010-10-14 16:28 GMT]

[Edited at 2010-10-14 16:29 GMT]


Direct link Reply with quote
 


To report site rules violations or get help, contact a site moderator:


You can also contact site staff by submitting a support request »

[TRADOS 2007] How can I just ignore some tags at the beginning / end of a translation unit?

Advanced search







LSP.expert
You’re a freelance translator? LSP.expert helps you manage your daily translation jobs. It’s easy, fast and secure.

How about you start tracking translation jobs and sending invoices in minutes? You can also manage your clients and generate reports about your business activities. So you always keep a clear view on your planning, AND you get a free 30 day trial period!

More info »
Protemos translation business management system
Create your account in minutes, and start working! 3-month trial for agencies, and free for freelancers!

The system lets you keep client/vendor database, with contacts and rates, manage projects and assign jobs to vendors, issue invoices, track payments, store and manage project files, generate business reports on turnover profit per client/manager etc.

More info »



Forums
  • All of ProZ.com
  • Term search
  • Jobs
  • Forums
  • Multiple search