"Exclude comments" for PPT doesn't work in Trados Studio 2009
Thread poster: Julien Griffon

Julien Griffon
France
Local time: 18:05
English to French
+ ...
Oct 15, 2010

Hi,

The title says it all...

I have several Word/Excel/PowerPoint files to analyse for a client who doesn't want the PPT notes to be translated.

I've been trying to use the "Exclude notes" parameter but it doesn't change the word count and the comments appear when I open the file for translation. It's the first time I use this feature, so I'm not sure how it works, but I'm sure there's something wrong here.

There are around 35 PPT files, so I don't want to process them manually if I can avoid it.

Thanks for your help,
Julien


Direct link Reply with quote
 

SDL Community  Identity Verified
United Kingdom
Local time: 18:05
English
Exclude comments parameter? Oct 16, 2010

Hi Julien,

The place to include, or not, comments is in the Filetypes. For ppt files it's under Hyperlink and Comments and you check or uncheck Include Comments for Translation. For PPTX it's under Optional Content, where you check Comments if you want to include them for translation.

These options can be set in two places. First in Tools-Options where all new Projects or files you open for translation without creating a Project will adopt the settings you select. Then under Project Settings where you can affect only files within that particular Project.

If you change the settings to include comments, or exclude them when they were included before, then you need to run the analysis again to see the difference. You also need to note where you change them because if you make the change under Tools-Options for an existing project then they will not be changed at all. Perhaps this is what you are doing?

Regards

Paul


Direct link Reply with quote
 

Katalin Horváth McClure  Identity Verified
United States
Local time: 12:05
Member (2002)
English to Hungarian
+ ...
The question is about the Notes, not the Comments, and I have the same problem with Trados 2007 Oct 17, 2010

I thought the Notes can be excluded using the "Slide order" option, where one of the options is "No Notes", others are "After Each Slide" (this is the default, I think), and some others.
Now, this is for Trados 2007, not Studio, and I am not sure about the exact names of the parameters. I would check them, but as it turns out, I am having trouble doing the exact same thing on my system, so here is a question to SDL Support:

I have SDL Trados 2007 Freelance, and I am trying to do the same thing as the original poster: exclude the Notes from the PPT file.
I tried using the Filter Setting tool (available in the Trados->Filters submenu), but it does not work correctly, it gives me an error message, saying:

Microsoft .NET Framework

Unhandled exception has occured in your application. If you cllick Continue, the application will ignore this error and attempt to continue. If you click Quit, the application will close immediately.

Value was either too large or too small for an Int32.


If I open up the Details, this is what is there:

See the end of this message for details on invoking
just-in-time (JIT) debugging instead of this dialog box.

************** Exception Text **************
System.OverflowException: Value was either too large or too small for an Int32.
at System.Convert.ToInt32(UInt64 value)
at System.UInt64.System.IConvertible.ToInt32(IFormatProvider provider)
at System.Convert.ToInt32(Object value)
at TRADOSFilterSettings.JVM.GetTotalRAM()
at TRADOSFilterSettings.JVM.InitLists()
at TRADOSFilterSettings.Navigation.Navigation_Load(Object sender, EventArgs e)
at System.Windows.Forms.Form.OnLoad(EventArgs e)
at System.Windows.Forms.Form.OnCreateControl()
at System.Windows.Forms.Control.CreateControl(Boolean fIgnoreVisible)
at System.Windows.Forms.Control.CreateControl()
at System.Windows.Forms.Control.WmShowWindow(Message& m)
at System.Windows.Forms.Control.WndProc(Message& m)
at System.Windows.Forms.ScrollableControl.WndProc(Message& m)
at System.Windows.Forms.ContainerControl.WndProc(Message& m)
at System.Windows.Forms.Form.WmShowWindow(Message& m)
at System.Windows.Forms.Form.WndProc(Message& m)
at System.Windows.Forms.Control.ControlNativeWindow.OnMessage(Message& m)
at System.Windows.Forms.Control.ControlNativeWindow.WndProc(Message& m)
at System.Windows.Forms.NativeWindow.Callback(IntPtr hWnd, Int32 msg, IntPtr wparam, IntPtr lparam)


************** Loaded Assemblies **************
mscorlib
Assembly Version: 2.0.0.0
Win32 Version: 2.0.50727.4206 (VistaSP2GDR.050727-4200)
CodeBase: file:///C:/Windows/Microsoft.NET/Framework/v2.0.50727/mscorlib.dll
----------------------------------------
TRADOSFilterSettings
Assembly Version: 1.0.0.0
Win32 Version: 1.0.0.0
CodeBase: file:///C:/Program%20Files/SDL%20International/T2007_FL/TT/TradosFilterSettings.exe
----------------------------------------
System.Windows.Forms
Assembly Version: 2.0.0.0
Win32 Version: 2.0.50727.4016 (NetFxQFE.050727-4000)
CodeBase: file:///C:/Windows/assembly/GAC_MSIL/System.Windows.Forms/2.0.0.0__b77a5c561934e089/System.Windows.Forms.dll
----------------------------------------
System
Assembly Version: 2.0.0.0
Win32 Version: 2.0.50727.4205 (VistaSP2GDR.050727-4200)
CodeBase: file:///C:/Windows/assembly/GAC_MSIL/System/2.0.0.0__b77a5c561934e089/System.dll
----------------------------------------
System.Drawing
Assembly Version: 2.0.0.0
Win32 Version: 2.0.50727.4016 (NetFxQFE.050727-4000)
CodeBase: file:///C:/Windows/assembly/GAC_MSIL/System.Drawing/2.0.0.0__b03f5f7f11d50a3a/System.Drawing.dll
----------------------------------------
Accessibility
Assembly Version: 2.0.0.0
Win32 Version: 2.0.50727.4016 (NetFxQFE.050727-4000)
CodeBase: file:///C:/Windows/assembly/GAC_MSIL/Accessibility/2.0.0.0__b03f5f7f11d50a3a/Accessibility.dll
----------------------------------------
System.Xml
Assembly Version: 2.0.0.0
Win32 Version: 2.0.50727.4016 (NetFxQFE.050727-4000)
CodeBase: file:///C:/Windows/assembly/GAC_MSIL/System.Xml/2.0.0.0__b77a5c561934e089/System.Xml.dll
----------------------------------------
Sdl.Interop.s42gdf
Assembly Version: 1.0.0.0
Win32 Version: 1.0.0.0
CodeBase: file:///C:/Windows/assembly/GAC/Sdl.Interop.s42gdf/1.0.0.0__4316ebe69d6f1d49/Sdl.Interop.s42gdf.dll
----------------------------------------
System.Management
Assembly Version: 2.0.0.0
Win32 Version: 2.0.50727.4016 (NetFxQFE.050727-4000)
CodeBase: file:///C:/Windows/assembly/GAC_MSIL/System.Management/2.0.0.0__b03f5f7f11d50a3a/System.Management.dll
----------------------------------------

************** JIT Debugging **************
To enable just-in-time (JIT) debugging, the .config file for this
application or computer (machine.config) must have the
jitDebugging value set in the system.windows.forms section.
The application must also be compiled with debugging
enabled.

For example:





When JIT debugging is enabled, any unhandled exception
will be sent to the JIT debugger registered on the computer
rather than be handled by this dialog box.


If I click Continue, the tool comes up with its Window, but the pull-down selection lists for the individual parameters are empty, so I cannot change any settings.

Any idea?
Katalin


Direct link Reply with quote
 

Julien Griffon
France
Local time: 18:05
English to French
+ ...
TOPIC STARTER
PowerPoint OK, Excel went down Oct 17, 2010

SDL Support wrote:

Hi Julien,

The place to include, or not, comments is in the Filetypes. For ppt files it's under Hyperlink and Comments and you check or uncheck Include Comments for Translation. For PPTX it's under Optional Content, where you check Comments if you want to include them for translation.

These options can be set in two places. First in Tools-Options where all new Projects or files you open for translation without creating a Project will adopt the settings you select. Then under Project Settings where you can affect only files within that particular Project.

If you change the settings to include comments, or exclude them when they were included before, then you need to run the analysis again to see the difference. You also need to note where you change them because if you make the change under Tools-Options for an existing project then they will not be changed at all. Perhaps this is what you are doing?

Regards

Paul


Thank you Paul,

The Project Settings path is the one I was using and that didn't change anything to the count.

Now, I tried creating a new project after making the change you mention in Tools-Options and it worked fine for the PowerPoint files. However, I have an error with the single Excel 2003 file in the project (that wasn't there before):


Une exception a été levée par la cible d'un appel.

System.Reflection.TargetInvocationException, mscorlib, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089

mscorlib


System.Runtime.InteropServices.COMException, mscorlib, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089
-2146827284
C:\Program Files\Microsoft Office\OFFICE11\1036\xlmain11.chm
Microsoft Office Excel




SDL Trados Studio
9.1.0.0
9.1.2229.0
Microsoft® Windows Vista™ Professionnel
Service Pack 2
1036
1252
###\Julien
2.0.50727.4206
###
True
3143172 MB




Any idea what I should do to make it work?
Julien


Direct link Reply with quote
 

SDL Community  Identity Verified
United Kingdom
Local time: 18:05
English
Send me the file Oct 17, 2010

Hi Julien,

I think if you removed the files in your Project and added them again so they were prepared with the amended settings then this would work too. Glad you resolved that problem though.

On the excel file. Can you send it to me - pfilkin@sdl.com - and I can take a look?

Regards

Paul


Direct link Reply with quote
 

Julien Griffon
France
Local time: 18:05
English to French
+ ...
TOPIC STARTER
NDA forbids Oct 17, 2010

SDL Support wrote:
On the excel file. Can you send it to me - pfilkin@sdl.com - and I can take a look?

Regards

Paul


I'm afraid I can't do that due to the non disclosure agreement with my client...

Don't you have an idea based on the error message alone?


Direct link Reply with quote
 

Julien Griffon
France
Local time: 18:05
English to French
+ ...
TOPIC STARTER
Problem solved Oct 18, 2010

Problem solved thanks to Paul.

I just had to install Office SP3.


Direct link Reply with quote
 


To report site rules violations or get help, contact a site moderator:


You can also contact site staff by submitting a support request »

"Exclude comments" for PPT doesn't work in Trados Studio 2009

Advanced search







Across v6.3
Translation Toolkit and Sales Potential under One Roof

Apart from features that enable you to translate more efficiently, the new Across Translator Edition v6.3 comprises your crossMarket membership. The new online network for Across users assists you in exploring new sales potential and generating revenue.

More info »
Wordfast Pro
Translation Memory Software for Any Platform

Exclusive discount for ProZ.com users! Save over 13% when purchasing Wordfast Pro through ProZ.com. Wordfast is the world's #1 provider of platform-independent Translation Memory software. Consistently ranked the most user-friendly and highest value

More info »



Forums
  • All of ProZ.com
  • Term search
  • Jobs
  • Forums
  • Multiple search