Studio 2009 - Term recognition for several termbases
Thread poster: Kjersti Farrier

Kjersti Farrier  Identity Verified
United Kingdom
Local time: 04:21
English to Norwegian (Bokmal)
+ ...
Oct 15, 2010

Hi

I have recently installed SP 3 for Studio and Multiterm, although I don't think it is relevant to my issue...

This is the first time I am using more than one Termbase in one project, hence I cannot say whether this has anything to do with the version of SP, although I do not believe so.

So... my issue is quite simple.
I have two termbases - I can see them both in term recognition whenever there are matches in my segments. However for some reason, and I cannot find a way to resolve it (!), only the termbase which is listed first in the project options will show the target translations, not the other one. This is really annoying, because I cannot use autotype for the other termbase because of it. I have to click on each source entry in the window and then View term details to see the translation in the base.

Does anyone know how to resolve this? Your help is much appreciated.

Regards,
Kjersti


Direct link Reply with quote
 

Evgeny Pushkarev  Identity Verified
Russian Federation
Local time: 08:21
Member (2011)
English to Russian
+ ...
import terminology data Oct 15, 2010

Hello,
You may export terminology data from one termbase into XML file and then import it into another one. Or alternatively create new termbase and import data from both of them.


Direct link Reply with quote
 

Jerzy Czopik  Identity Verified
Germany
Local time: 05:21
Member (2003)
Polish to German
+ ...
Could you please change the order or the termbases? Oct 15, 2010

Simply make the second one the first one (select it, press "Use as standard") and check, if now that one will be working and the other one not. Please post the result here.

Direct link Reply with quote
 

Kjersti Farrier  Identity Verified
United Kingdom
Local time: 04:21
English to Norwegian (Bokmal)
+ ...
TOPIC STARTER
Same issue no matter which order I set Oct 15, 2010

The one that is set as Default will be the one showing also the suggested translation. In other words at least both termbases are fully working.

Direct link Reply with quote
 
WS Stallard
English to German
+ ...
Help I have the same thing Oct 23, 2010

Help I have the same thing--did anybody find a resolution?

Direct link Reply with quote
 

Kjersti Farrier  Identity Verified
United Kingdom
Local time: 04:21
English to Norwegian (Bokmal)
+ ...
TOPIC STARTER
No real solution no... Oct 23, 2010

There does not seem to be any real solution to see both termbases translation suggestions. I'm just working with them both, using my own one as the main one, obviously the terms are highlighted in the source texts no matter which termbase the terms are found in - I tend to just save the terms in my termbase as I work, that way any repetitve terms will become usable with autosuggest. But it is rather tedious, because surely you should be able to use them both simultaniously. I think if you could though it would cause trouble whenever you add terms - adding terms is a bit tricky anyway because you have to make sure that "your" termbase (the one you wish to add terms to) is "active" in the termbase viewer...

As some suggested though the one true solution is to join the terms into one termbase.
I think an improvement/change has to be made to Trados to make it suitable for multiple termbase usage.

All the best,
Kjersti


Direct link Reply with quote
 

Emma Goldsmith  Identity Verified
Spain
Local time: 05:21
Member (2010)
Spanish to English
Drag window edge Oct 23, 2010

I have occasionally had the problem of not seeing the target terms at all when using one termbase. I solved this by dragging the lefthand side of termbase window with the mouse to enlarge the window. The target terms appear. Then when you resize the window to its original size, the target terms remain visible.
It sounds crazy, I know, but it worked for me


Direct link Reply with quote
 

Kjersti Farrier  Identity Verified
United Kingdom
Local time: 04:21
English to Norwegian (Bokmal)
+ ...
TOPIC STARTER
Thanks for you input, Emma Oct 23, 2010

However, the terms and suggested translations for the main termbase do show up, as well as the terms from the second termbase, although not the suggested translations from the second termbase.

Direct link Reply with quote
 

Emma Goldsmith  Identity Verified
Spain
Local time: 05:21
Member (2010)
Spanish to English
Sorry to insist, Kjersti Oct 23, 2010

but did you actually try to drag the edge of the term recognition window? I know it sounds ridiculous, but sometimes my target entries don't appear at all (as you are reporting). One solution is to do as you suggest
Kjersti Farrier wrote:

I have to click on each source entry in the window and then View term details to see the translation in the base.



and the other solution is to stretch the window and then resize it again.


Direct link Reply with quote
 

Kjersti Farrier  Identity Verified
United Kingdom
Local time: 04:21
English to Norwegian (Bokmal)
+ ...
TOPIC STARTER
I tried Oct 23, 2010

Hi Emma,
Rest assured that I tried - the "problem" is really annoying and I would love to have it fixed. So I'll try anything. But nothing more, nor less show up when I try to do as you suggest. I have sometimes that terms don't show up at all, or there are other issues - I tend to just shut Trados down then and it all resolves itself once open again.
The issue here is pretty constant though.

Perhaps you can try it? Have you got another termbase or can create one? To duplicate it you just need two termbases, one source file with terms that are in both termbases or at least in the secondary termbase. The best thing is to have the term in both actually, then you can see exactly what I mean..

An example is given here, just imagine this all being the text in the Term Recognition window:

MT - NO-NO
- patient
- withdrawal
- medication

Generell Termbase
- withdrawal
--- seponering
- anti-smoking
--- røykeslutt
- medication
--- virkestoff
--- medikasjon

MT - NO-NO is my second termbase, Generell Termbase is my main one - by saying that I mean that in Project Settings | Termbases, Generell Termbase is set to be the default one.
If I change the order of them, making MT... the default one, then Term Recognition will show the following:

MT - NO-NO
- patient
--- pasient
- withdrawal
--- abstinens
- medication
--- medikasjon

Generell Termbase
- withdrawal
- anti-smoking
- medication

I had to change the look a bit as Proz did not reflect the spaces I used to separate source term and suggested translation. The top line is the name of the termbase. The term behind one "-" is the term and the word behind the 3 "---" is the suggested translation.
My termbases are in 100 % working order, and the goes for their functionality in Trados.
Apart from obviously this annoying "glitch"...
Thank you for your persitence, however

[Edited at 2010-10-23 15:36 GMT]


Direct link Reply with quote
 

Emma Goldsmith  Identity Verified
Spain
Local time: 05:21
Member (2010)
Spanish to English
Oh well, it was worth a try! Oct 23, 2010

Hi Kjersti, sorry I went on about dragging the window and sorry it didn't work for you

Well, I have created a 2nd termbase with a couple of identical entries from my regular TB, and I can't reproduce your problem I'm afraid.

Right now I have this in the term recognition window:

informe final (name of newly created TB)
final report
historia clínica (name of regular Tb)
medical record
historia clínica (name of newly created TB)
medical record

Interestingly, the entries are listed in the order they appear in the source segment, and not listed by TB, as in your example.
(I'd like to paste this as a screenshot, but I don't know how to do that in this forum, sorry.)

I hope someone else can help you out on this one. Enjoy the rest of the weekend!


Direct link Reply with quote
 

Kjersti Farrier  Identity Verified
United Kingdom
Local time: 04:21
English to Norwegian (Bokmal)
+ ...
TOPIC STARTER
Aaaaargh - there must be something with the settings then Oct 23, 2010

Emma Goldsmith wrote:


Hi Kjersti, sorry I went on about dragging the window and sorry it didn't work for you

Well, I have created a 2nd termbase with a couple of identical entries from my regular TB, and I can't reproduce your problem I'm afraid.

Right now I have this in the term recognition window:

informe final (name of newly created TB)
final report
historia clínica (name of regular Tb)
medical record
historia clínica (name of newly created TB)
medical record

Interestingly, the entries are listed in the order they appear in the source segment, and not listed by TB, as in your example.
(I'd like to paste this as a screenshot, but I don't know how to do that in this forum, sorry.)

I hope someone else can help you out on this one. Enjoy the rest of the weekend!


This means there is something wrong/different with my settings in Trados or in the termbase then! Thank you for doing this test!
The order you have just means you've got the option "Search all termbases in parallel and group results by term" selected in Search Settings (under Termbase).
I wish I had some more time to play around with settings to try to fix this, but no such luck...
Thank you so much again though, this proves that there is some hope...

Kjersti


Direct link Reply with quote
 

Kjersti Farrier  Identity Verified
United Kingdom
Local time: 04:21
English to Norwegian (Bokmal)
+ ...
TOPIC STARTER
Could be an issue with the termbases after all Oct 23, 2010

I just created another termbase with a few terms in it. Added it to my project and HURRAH! - both term and suggested translation shows, but only for my own one and the new one I created... Now I am curious what could possibly be wrong with the second termbase... further testing needed by the looks of it.
I will update the forum once I've got a solution


Direct link Reply with quote
 

Kjersti Farrier  Identity Verified
United Kingdom
Local time: 04:21
English to Norwegian (Bokmal)
+ ...
TOPIC STARTER
Solution! Well, reason for problem anyway... Oct 23, 2010

I believe that the issue which I am experiencing (as well as WS Stallard) is due to language pairs. One of my termbases is in Norwegian-US English, whilst the other one in in Norwegian-UK English - it can only do one of the language pairs at a time. When I created a 2nd one (NO-US) I could see both termbases with this language pair.

WS Stallard, is this your situation too perhaps??


Direct link Reply with quote
 


To report site rules violations or get help, contact a site moderator:


You can also contact site staff by submitting a support request »

Studio 2009 - Term recognition for several termbases

Advanced search







SDL MultiTerm 2017
Guarantee a unified, consistent and high-quality translation with terminology software by the industry leaders.

SDL MultiTerm 2017 allows translators to create one central location to store and manage multilingual terminology, and with SDL MultiTerm Extract 2017 you can automatically create term lists from your existing documentation to save time.

More info »
memoQ translator pro
Kilgray's memoQ is the world's fastest developing integrated localization & translation environment rendering you more productive and efficient.

With our advanced file filters, unlimited language and advanced file support, memoQ translator pro has been designed for translators and reviewers who work on their own, with other translators or in team-based translation projects.

More info »



Forums
  • All of ProZ.com
  • Term search
  • Jobs
  • Forums
  • Multiple search