International Translation Day 2017

Join ProZ.com/TV for a FREE event on September 26-27th celebrating International Translation Day! 50+ hours of content, Chat, Live Q&A & more. Join 1,000's of linguists from around the globe as ProZ.com/TV celebrates International Translation Day.

Click for Full Participation

TRADOS Studio SP3 changing fonts in target
Thread poster: Nick Quaintmere

Nick Quaintmere  Identity Verified
Germany
Local time: 13:54
German to English
Nov 9, 2010

I recall having this problem before in an earlier version of Studio but it got fixed. But now this annoying problem is back. Here is an example of what happens:

The source text is set in Arial, but the segment has some formatting (different coloured texts, or italics or bold)

The target text sets itself automatically to Times New Roman.

This is irritating as hell, because the only way to get the target text to be in Arial is to insert the source and overtype.

I have tried changing the settings in the Options for the language pair to make Arial the default, but this does nothing (and is not a good solution anyway, as texts sometimes need to be in other fonts).

I have set the tag settings in the menu bar set to "Full Tag Text", but these tags also seem to have disappeared since SP3.

Trados has no possibility for changing fonts in segments and now not even the tags are available!

Anyone got any ideas?


Direct link Reply with quote
 

Jerzy Czopik  Identity Verified
Germany
Local time: 13:54
Member (2003)
Polish to German
+ ...
This is you who's changing font, most probably Nov 9, 2010

Please change the view from formatted text to just tags and plain text - go to Tools, Options and chose Editor. There change this setting and then check, if your target segment does all tags inserted in the right order. If yes, then I will have to believe the impossible and admit, that Studio indeed does change fonts, but if not, then it was you...

Best regards
Jerzy


Direct link Reply with quote
 

Nick Quaintmere  Identity Verified
Germany
Local time: 13:54
German to English
TOPIC STARTER
Tags are back! Nov 9, 2010

Thanks Jerzy, that at least has returned my tags. I still have to insert them all manually, however, and I don't understand why Trados should change the entire font when only the attribute font colour is changed.

To put this more clearly. The whole document is Arial. There are no variations in font or font size.

A couple of segments have red text. Now that my tags are back I can see that the standard text in each segment where this occurs has the tag and the coloured text has the tag . What I don't understand is why, if I don't manually insert the Arial tag, the font changes to Times New Roman. Where is Trados getting this information from?

This happens when there are any format variations within a segment (bold, italic, font size). But if the font is not changing, only the attribute, why is Trados suddenly inserting a different font? It should retain the font information and allow me to insert formatting (bold, italic, etc) as required, or the appropriate tags where there are no Trados commands for this.

Like I said, this problem seemed to have been fixed before and now it has returned. It can't be me that is changing the font because there is no option in Trados to change the font!


Direct link Reply with quote
 

Jerzy Czopik  Identity Verified
Germany
Local time: 13:54
Member (2003)
Polish to German
+ ...
Difference between local style and global style Nov 9, 2010

It does not really matter which font has been used locally - as soon this differs from the style font changes will occur when no tags are inserted.
Or you will really work with only tagged view, then you will see no formatting and no font changes. This obviously will not set you free from inserting tags.


Direct link Reply with quote
 

Nick Quaintmere  Identity Verified
Germany
Local time: 13:54
German to English
TOPIC STARTER
Still baffled Nov 9, 2010

Jerzy Czopik wrote:

It does not really matter which font has been used locally - as soon this differs from the style font changes will occur when no tags are inserted.
Or you will really work with only tagged view, then you will see no formatting and no font changes. This obviously will not set you free from inserting tags.


Unfortunately, none of that made any sense to me. And it certainly does not explain why Trados is changing the entire font to Times when I don't manually insert a tag. Let me repeat: this only occurs in segments where there are variations in formatting within the segment. In all other segments the tags are blended out.

There are no variations in font in the entire document, just a few words coloured red. The font (Arial 10 pt) remains the same in all segments.

I just find it extremely curious...


Direct link Reply with quote
 

Jerzy Czopik  Identity Verified
Germany
Local time: 13:54
Member (2003)
Polish to German
+ ...
Display all content (View - Toolbars - Display filter) and full tag text Nov 9, 2010

Read what do tags say. If you find font change tags to Arial, then the core font in document has been Times.
But if you really set Studio to "show all tags, but NO formatting", there will be NO font change at all.
At least for languages I was able to see.


Direct link Reply with quote
 

Nick Quaintmere  Identity Verified
Germany
Local time: 13:54
German to English
TOPIC STARTER
Core font Nov 9, 2010

I think you must be right about the core font. That seems to be the only explanation.

But it still seems irritating that a core font that is not used anywhere in the document should be insert because Trados loses track of what's going on.

Ponownie serdeczne dzienki za pomoc


Direct link Reply with quote
 

Jerzy Czopik  Identity Verified
Germany
Local time: 13:54
Member (2003)
Polish to German
+ ...
Not really Nov 9, 2010

Nick Quaintmere wrote:

I think you must be right about the core font. That seems to be the only explanation.

But it still seems irritating that a core font that is not used anywhere in the document should be insert because Trados loses track of what's going on.

Ponownie serdeczne dzienki za pomoc


Please look at the way documents are tagged.
Any CAT tool can copy only what the user decided to use in Word.
If the user did not set the core font to Arial, but left everything formatted in Times but then applied manual formatting with Arial, then tags have been created, which do change the formatting from core (standard, normal) to user formatting. As any paragraph would use TNR if not stated differently in local formatting those tags are necessary.
Now, in order to make translation easier, Trados is trying to keep as many tags out of the segments as possible. In that case, when you forget to insert the font change tag Trados will use the core font.
This is really not a Trados specific problem, but just a result of how formatting is applied - and this applies to all CAT tools. As different CATs have different philosophy of what shall be shown to the user, the behaviour is different. While tools shwoing showing just tagged text will not show any formatting at all, Studio is trying to create as precise WYSIWYG view as possible - with all the consequences you now encounter. I for one do not use this WYSIWYG feature at all, as it is pure nonsense in my eyes - SDLXLIFF and Studio use tagged format, so I go and look at tags and deal with them. And I do that gladly, because that way I have a clear and precise view and quite exact information on the text formatting.
Not that complicated as it may sound and look at the first glance


Direct link Reply with quote
 

Sami Khamou  Identity Verified
Local time: 07:54
Member (2002)
English to Arabic
+ ...
Valuable Tips Nov 29, 2012

Jerzy Czopik wrote:

Please change the view from formatted text to just tags and plain text - go to Tools, Options and chose Editor. There change this setting and then check, if your target segment does all tags inserted in the right order. If yes, then I will have to believe the impossible and admit, that Studio indeed does change fonts, but if not, then it was you...

Best regards
Jerzy


Hi Jerzy,

Thank you for this valuable tip.

I just finished a large English/Arabic translation job using SDL Trados 2009. All the text attribute were changed. I had to make adjustments on the target Word file.

Today, I tried your tip as a test. Everything looked fine on the Trados file translated into Arabic. The full tags were there. I looked at the Trados print preview all the font attributes were intact. But, when I saved the target file, I got a plain text with no Bold, Italic or different sizes.

Sorting out this problem will save me a lot of time wasted on adjusting the text after saving the Target file into Word.

What did I do wrong?

Kind regards,

Sami Khamou


Direct link Reply with quote
 

Bernadette Regnier
Canada
Local time: 08:54
English to French
+ ...
Thanks Nov 30, 2012

Thanks Jerzy. Your help is much appreciated.

Bernadette


Direct link Reply with quote
 

SEA-words  Identity Verified
English to Italian
+ ...
CTRL + comma Dec 1, 2012

I just wanted to remind you that you can select the source styles and apply them in the target segments by clicking CTRL + comma. You'll get a list of the formatting used in the source.

Direct link Reply with quote
 

François Duperrier  Identity Verified
Spain
Local time: 13:54
English to French
+ ...
Same problem Feb 12, 2013

I sometimes have the same problem in segments with no tag at all...

Studio simply changes the font from Arial to Times New Roman.
And in the clean file too.

"Ctrl + comma" allows me to fix the problem (thanks Girino), but I still don't understand...


Direct link Reply with quote
 
Gareth Cole
United Kingdom
Agree - use Ctrl + "," Nov 5, 2014

Thanks to SEA-words - most useful tip. Select the text in the target field that has the "wrong" font/formatting, then press Ctrl+, (Ctrl key and comma key together). Then you get a little popup list with the styles used in the source, simply select the one you want and press Enter. Bingo!

Direct link Reply with quote
 

Inga Jokubauske  Identity Verified
United Kingdom
Local time: 12:54
Member (2011)
English to Lithuanian
+ ...
Thank you! Jun 10, 2015

SEA-words wrote:

I just wanted to remind you that you can select the source styles and apply them in the target segments by clicking CTRL + comma. You'll get a list of the formatting used in the source.


Thanks for the tip! This is saving so much time!


Direct link Reply with quote
 


To report site rules violations or get help, contact a site moderator:


You can also contact site staff by submitting a support request »

TRADOS Studio SP3 changing fonts in target

Advanced search







PDF Translation - the Easy Way
TransPDF converts your PDFs to XLIFF ready for professional translation.

TransPDF converts your PDFs to XLIFF ready for professional translation. It also puts your translations back into the PDF to make new PDFs. Quicker and more accurate than hand-editing PDF. Includes free use of Infix PDF Editor with your translated PDFs.

More info »
TM-Town
Manage your TMs and Terms ... and boost your translation business

Are you ready for something fresh in the industry? TM-Town is a unique new site for you -- the freelance translator -- to store, manage and share translation memories (TMs) and glossaries...and potentially meet new clients on the basis of your prior work.

More info »



Forums
  • All of ProZ.com
  • Term search
  • Jobs
  • Forums
  • Multiple search