Trados Studio 2009 SP3 - Unexpected exception when initializing view part Messages
Thread poster: xxxCibeles
xxxCibeles

Local time: 21:11
German to Spanish
+ ...
Nov 23, 2010

Dear Forum:

I have Trados Studio 2009 Freelance SP3 and until now everything worked fine (except Multiterm 2009, but this is not so important for me at the moment).

I am translating a big sdlxliff file in Trados Studio and after a while when I try to change to the next segment I get following error message:

Unexpected exception when initializing view part Messages.
Object refence not set to an instance of an object

I have no idea why, as the last days I could translate this file without problems.

What could it be wrong?

Thank you in advance for your help

Clara Morales

Duisburg


Direct link Reply with quote
 

Jerzy Czopik  Identity Verified
Germany
Local time: 21:11
Member (2003)
Polish to German
+ ...
Please delete the settings files Nov 23, 2010

Please close Studio, delete the following files and restart the program:
C:\Users\user_name\AppData\Roaming\SDL\SDL Trados Studio\9.1.0.0\BaseSettings.xml
C:\Users\user_name\AppData\Roaming\SDL\SDL Trados Studio\9.1.0.0\UserSettings.xml
(for Vista and Win 7), in WinXP look in the Apllication Data folder under Documents and settings, your user account.


Direct link Reply with quote
 
xxxCibeles

Local time: 21:11
German to Spanish
+ ...
TOPIC STARTER
Problem solutioned Nov 23, 2010

Jerzy, you have saved me again, your hint was the solution.

I have deleted the files and the error message does not appear any more.

Thank you very much

Clara


Direct link Reply with quote
 

Michael Watson  Identity Verified
United Kingdom
Local time: 20:11
Member (2006)
German to English
+ ...
Success, Thanks Jerzy! May 20, 2011

Thanks very much! I owe you a beer should we ever meet up!

Definitely works.

The only drawback is some user settings are lost as well so I had to reset some of my settings in Studio do get back to my original setup. This would have been trivial if I could have remembered how I made them.

Still this was a minor irritation compared with the major irritation of the original problem.

Presumably there are one or two lines in the deleted files which cause the problem. I suppose the ideal solution would be to know which lines they were and delete them rather than the actual files...


Direct link Reply with quote
 

Jana Uhlik  Identity Verified
Belize
Local time: 13:11
Member (2003)
English to German
Looked for SDL help first, should have looked for your reply or asked you right away. May 28, 2011

Jerzy, Your solution was on the spot and fixed the problem in seconds. It could have saved me a lot of time and grief if I had looked for your replies FIRST instead of groping through senseless SDL help attempts ...

THANKS! And yes, I owe you a beer, too.


Direct link Reply with quote
 

Wouter Jongejan
France
Local time: 21:11
French to Dutch
Please help me! Aug 18, 2011

Today I got the same error as already mentioned above. However, after having deleted the basesetttings, plugincache and usersettings files, the problems persists. (I'm using Vista). So I can't save any new lines and in the Editor mode of SDL appears a blue box on the screen, hiding (partly) the source text.
Any suggestions?
Thanks


Direct link Reply with quote
 

Pablo Mones  Identity Verified
Uruguay
Local time: 16:11
Member (2008)
English to Spanish
Same problem - no solution Aug 27, 2011

Dear colleagues:

I have the same problem. Studio works fine, but I can't start Multiterm. I deleted the files as Jerzy suggested, and the problem continued. I also uninstalled and reinstalled the program, but nothing seems to work (I work with XP).

Does anybody have a solution?

Thank you in advance.

Pablo Mones


Direct link Reply with quote
 
Elena Sosno  Identity Verified
Australia
Local time: 05:11
English to Russian
+ ...
thank you Apr 4, 2012

Jerzy, thank you very much! The same problem suddenly arose this morning and I was able to solve it in five minutes thanks to your advice.

Direct link Reply with quote
 

Brigitte Mayer ATT Advanced Technical Translation GmbH
Austria
Local time: 21:11
Member (2011)
English to German
+ ...
thanks god for jerzey Apr 23, 2012

i was absolutely dispaired, the problem occurred suddelny and did not disappear after restart, reinstallation, repair...i have a help-ticket-system, but the supplier was unable to help...and this enlightenment! what a happy day, THANK YOU

Direct link Reply with quote
 

Peter Ward  Identity Verified
United Kingdom
Local time: 20:11
Member (2008)
German to English
Fixed in a jiffy Sep 25, 2012

This problem has been giving me grief on my (XP) system for some time - thanks for the solution!

Direct link Reply with quote
 

Ana Fernández Ramos  Identity Verified
Spain
Local time: 21:11
Member
English to Spanish
+ ...
If you were not able to solve this deleting the files Jerzy says... Nov 14, 2012

Dear all,

In my case, like in Pablo's and Wouter's, deleting the xml files in C:\Users\user_name\AppData\Roaming\SDL\SDL Trados Studio\9.1.0.0\ would not work (no idea why), so I panicked and kept searching for more "S.O.S." questions and answers about similar topics and someone suggested performing a "Windows System Restore" of your computer to a previous date when you know that your PC was still working fine.

I restored the system to two days before the day when SDL Trados started giving me problems, and now it works perfectly again!

I hope it helps more people too. But thank you for your quick and expert answers, Jerzy!


Direct link Reply with quote
 

Akke Wagenaar  Identity Verified
Senegal
Local time: 19:11
Member (2011)
English to Dutch
+ ...
Had the same problem - this solution worked Oct 22, 2013

I had the same problem but then after Multiterm crashed and then antivirus told me to delete a virus it had all of a sudden detected. Unfortunately I said: yes, to move the virus to the vault (AVG) and after that Studio gave me the problem. I found this solution quickly (luckily because I have a deadline) and it works. But indeed, it takes a long time to reset back all my old settings...

Direct link Reply with quote
 

Laura Bennett  Identity Verified
United Kingdom
Local time: 20:11
Member (2011)
Italian to English
+ ...
Hasn't worked for me May 13, 2015

This problem has recently started occurring and I have found and deleted the files recommended by Jerzy but to no avail. I'm still getting the error message in the middle of a document and am unable to save segments. Any help gratefully received!

Direct link Reply with quote
 


To report site rules violations or get help, contact a site moderator:


You can also contact site staff by submitting a support request »

Trados Studio 2009 SP3 - Unexpected exception when initializing view part Messages

Advanced search







Protemos translation business management system
Create your account in minutes, and start working! 3-month trial for agencies, and free for freelancers!

The system lets you keep client/vendor database, with contacts and rates, manage projects and assign jobs to vendors, issue invoices, track payments, store and manage project files, generate business reports on turnover profit per client/manager etc.

More info »
WordFinder
The words you want Anywhere, Anytime

WordFinder is the market's fastest and easiest way of finding the right word, term, translation or synonym in one or more dictionaries. In our assortment you can choose among more than 120 dictionaries in 15 languages from leading publishers.

More info »



Forums
  • All of ProZ.com
  • Term search
  • Jobs
  • Forums
  • Multiple search