Trados Studio SP3 - Problem opening project file
Thread poster: Nick Quaintmere

Nick Quaintmere  Identity Verified
Germany
Local time: 15:53
German to English
Dec 3, 2010

This one's classic. I try to open a file that has been added to a project and I get the error message:

"Object reference is not set to an instance of an object"

What on earth is that supposed to mean?

And if the file have been prepared in Studio, why can't Studio open it? It makes no sense to me.

The full error message is:

SDLErrorDetails time="03.12.2010 10:39:41"
ErrorMessage: Object reference not set to an instance of an object.
Exception
Type: System.NullReferenceException, mscorlib, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089
HelpLink
Source: Sdl.Desktop.Platform
StackTrace: ![CDATA[ at Sdl.Desktop.Platform.AbstractViewWithParts.Control_ShowingViewPart(IViewWithParts view, IViewPartReference viewPartReference)
at Sdl.Desktop.Platform.WinForms.DockingViewContentControl.OnShowingViewPart(IViewPartReference viewPartReference)
at Sdl.Desktop.Platform.WinForms.DockingViewContentControl.EnsureTabbedViewPartControl(UltraTab tab)
at Sdl.Desktop.Platform.WinForms.DockingViewContentControl.ShowViewPart(IViewPartReference viewPartReference)
at Sdl.Desktop.Platform.AbstractViewWithParts.ShowViewPart(IViewPartReference viewPartReference)
at Sdl.TranslationStudio.Editor.EditorService.set_ActiveDocument(IDocument value)
at Sdl.TranslationStudio.Editor.EditorService.OpenImpl(IDocumentDescriptor descriptor, IAbstractEditor editor, IEditorConfiguration configuration)
at Sdl.TranslationStudio.Editor.EditorService.Open(IDocumentDescriptor descriptor)
at Sdl.TranslationStudio.Editor.EditorService.OpenTranslatableFile(ITranslatableFile translatableFile)
at Sdl.TranslationStudio.Common.Files.FileUtil.OpenTranslatableFile(IEditorService service, ITranslatableFile f, Nullable`1 workflowStage)
at Sdl.TranslationStudio.Common.Files.FileListControl.List_DefaultAction(Object sender, EventArgs e)
at Sdl.Desktop.Common.DataList.OnDefaultAction(EventArgs e)
at Sdl.Desktop.Common.DataList.BodyControl.OnDoubleClick(EventArgs e)
at System.Windows.Forms.Control.WmMouseUp(Message& m, MouseButtons button, Int32 clicks)
at System.Windows.Forms.Control.WndProc(Message& m)
at System.Windows.Forms.ScrollableControl.WndProc(Message& m)
at System.Windows.Forms.ContainerControl.WndProc(Message& m)
at System.Windows.Forms.UserControl.WndProc(Message& m)
at System.Windows.Forms.Control.ControlNativeWindow.OnMessage(Message& m)
at System.Windows.Forms.Control.ControlNativeWindow.WndProc(Message& m)
at System.Windows.Forms.NativeWindow.Callback(IntPtr hWnd, Int32 msg, IntPtr wparam, IntPtr lparam)]]

Environment
ProductName: SDL Trados Studio
ProductVersion: 9.1.0.0
EntryAssemblyFileVersion: 9.1.2229.0
OperatingSystem: Microsoft Windows 7 Home Premium
ServicePack: NULL
OperatingSystemLanguage: 1031
CodePage: 1252
LoggedOnUser: XXXXXXXXXXX
DotNetFrameWork: XXXXXXXXX
ComputerName: XXXXXXXXXXX
ConnectedToNetwork: True
PhysicalMemory: 4052588 MB

All updates have been applied and C++ has been updated.

PS: The file I am trying to open is a TTX file based on an INX.

[Edited at 2010-12-03 09:53 GMT]

[Edited at 2010-12-03 09:54 GMT]


 

Nick Quaintmere  Identity Verified
Germany
Local time: 15:53
German to English
TOPIC STARTER
Restarting solved it Dec 3, 2010

Interestingly enough, restarting Trados solved the problem. But that doesn't explain why it happened in the first, however. You should be able to add files to a project without having to restart the program.

 

Kerstin Mohnberg  Identity Verified
Local time: 14:53
Member (Jan 2018)
English to German
Installation glitch? Dec 3, 2010

How are you trying to open the file?
Are you opening it from the Files view?
Have you just added the file to an existing project?
If so, you are probably in the Source-language view (Source language selected in the drop-down list on the left).
Make sure you switch to your Target Language first and then open the file.

"Object reference is not set to an instance of an object" is a generic error message.
The error log actually looks like there might be a problem with your installation. Have you tried reinstalling?

[Edited at 2010-12-03 12:08 GMT]


 

Nick Quaintmere  Identity Verified
Germany
Local time: 15:53
German to English
TOPIC STARTER
Source/Target language Dec 3, 2010

I've fallen into that source/target language problem before - so, no, it wasn't that. But even if it had been, the file should have opened.

What is it in the error log that indicates a duff installation (out of interest)? I'm loathe to reinstall software, if I don't have to. Especially bearing in mind it means redoing all the hotfixes and repairs and possibly losing all my settings.


 


To report site rules violations or get help, contact a site moderator:


You can also contact site staff by submitting a support request »

Trados Studio SP3 - Problem opening project file

Advanced search







Wordfast Pro
Translation Memory Software for Any Platform

Exclusive discount for ProZ.com users! Save over 13% when purchasing Wordfast Pro through ProZ.com. Wordfast is the world's #1 provider of platform-independent Translation Memory software. Consistently ranked the most user-friendly and highest value

More info »
BaccS – Business Accounting Software
Modern desktop project management for freelance translators

BaccS makes it easy for translators to manage their projects, schedule tasks, create invoices, and view highly customizable reports. User-friendly, ProZ.com integration, community-driven development – a few reasons BaccS is trusted by translators!

More info »



Forums
  • All of ProZ.com
  • Term search
  • Jobs
  • Forums
  • Multiple search