How to assign the correct file type in Trados Studio 2009 when creating a new project
Thread poster: Franz Bissinger
Franz Bissinger
Germany
Local time: 02:45
Dec 8, 2010

Hello colleagues,

I'm just starting with Trados Studio 2009 and have a problem to select or assign the right file type settings to a set of XML files added to the sample project (I'm using a real project originally done in Trados 2007).

As far as I see I successfully created a new sdlfiletype file by importing the relevant data from the original INI file (Trados DTD settings file), however, whenever trying to add the XML files to the new project the file type "XML - Any XML" is automatically being assigned to my XMLs. I searched for a good while how to change that assignement manually, but without success.

Beside that I tried to change the name of the base XML element in one of my XML files and was hoping either to get my new settings file automatically selected or to get a dialog asking for the right settings file (as in TagEditor 2007) - so far again without success.

I'm hoping somebody around here is able to give me a clue.

Thanks a lot in advance.

Best
Franz

[Bearbeitet am 2010-12-08 16:54 GMT]

[Bearbeitet am 2010-12-08 16:57 GMT]


Direct link Reply with quote
 

Stanislav Pokorny  Identity Verified
Czech Republic
Local time: 02:45
English to Czech
+ ...
Very complex Dec 8, 2010

Hello Franz,
as you probably know, Studio uses the "SDLFILETYPE" files to process document structure information. You can try to use your old INI file to create a new filetype in Studio, but I would start with the XMLs from scratch.

The process is quite complex though and is worth a training (I've been lucky to have obtained one from the SDL Support team).

Basically, I proceed as follows:
1. I create the XPath parser rule //* and set this as untranslatable
2. Then I create the XPath parser rules for the individual translatable tags, e.g. //translatabletag and set them as paragraphs and as "always translatable".
3. For the file to be recognized correctly, it is necessary to set the root element in the File Detection: I use the "Any of the following root elements" field to specify the root element.

I hope this helps at least a little...

[Upraveno: 2010-12-08 17:29 GMT]


Direct link Reply with quote
 
Mariusz Lasota
Local time: 02:45
English to Polish
How to assign type when creating a project in Studio 2009 Feb 24, 2011

I have a properly created file type definition and detection settings. The thing is it works fine when a single file is opened but not when several files are added to a project. Please help because this is driving me mad. In a project, the listed file type is always ANY XML (GenericXML.sdlfiletype) no matter what I do! Is there a way to force Studio to assign the proper file type to files (all 200 of them)?

Direct link Reply with quote
 

SDL Community  Identity Verified
United Kingdom
Local time: 02:45
English
Project Templates Feb 24, 2011

Hi Mariusz,

The thing that springs to mind for me is that your default Project Template is different to the filetypes being used for the Open Document approach. Or perhaps you are setting your Project up based on a special template you created, or even referencing another project first.

You can check the default template by going to File – Setup – Project Templates. Then edit the default and check that your new filetype is in there.

Perhaps this will shed some light on your problem?

Regards

Paul


Direct link Reply with quote
 
Mariusz Lasota
Local time: 02:45
English to Polish
A million thanks Feb 24, 2011


You can check the default template by going to File – Setup – Project Templates. Then edit the default and check that your new filetype is in there.

Perhaps this will shed some light on your problem?

Regards

Paul


Paul, a million thanks to you for your help. It worked! I could see that my file type definition was was mysteriously missing when creating a project although it was available in main Studio options. I didn't even realise that type definitions are stored in project templates. My guess is that it didn't get stored there because project template was created before file type was defined and available so it didn't get copied to the template. Now I understand and it feels good.

Even though it's -15°C and snowing over here the sun is shining for me and it is a great day. Thanks again.
Mariusz


Direct link Reply with quote
 

Stanislav Pokorny  Identity Verified
Czech Republic
Local time: 02:45
English to Czech
+ ...
This has worked Feb 24, 2011

SDL Support wrote:
You can check the default template by going to File – Setup – Project Templates. Then edit the default and check that your new filetype is in there.
Paul


This advice of Paul's has worked beautifully for me.


Direct link Reply with quote
 


To report site rules violations or get help, contact a site moderator:


You can also contact site staff by submitting a support request »

How to assign the correct file type in Trados Studio 2009 when creating a new project

Advanced search







WordFinder
The words you want Anywhere, Anytime

WordFinder is the market's fastest and easiest way of finding the right word, term, translation or synonym in one or more dictionaries. In our assortment you can choose among more than 120 dictionaries in 15 languages from leading publishers.

More info »
Protemos translation business management system
Create your account in minutes, and start working! 3-month trial for agencies, and free for freelancers!

The system lets you keep client/vendor database, with contacts and rates, manage projects and assign jobs to vendors, issue invoices, track payments, store and manage project files, generate business reports on turnover profit per client/manager etc.

More info »



Forums
  • All of ProZ.com
  • Term search
  • Jobs
  • Forums
  • Multiple search