SDL Trados 2009 - batch change translation status
Thread poster: welle
welle
Local time: 08:00
Dec 19, 2010

Dear colleagues,

just wondering if you know if it is possible to batch change the translation status of segments. The only possibility I found is to manually mark in the Editor all segments I want to change, than perform the change (untranslated->translated, blocked/unblocked, etc.). This may be very time consuming if the number of segments is high and if the segments are not adjacent. This is the case in my actual project where I need to block all translated segments (not adjacient). Across have the following option: change status of segments marked with status X in status Y. Anything comparable in Trados 2009? Or any work around?

Thank you for your time.
W.


Direct link Reply with quote
 

Jerzy Czopik  Identity Verified
Germany
Local time: 08:00
Member (2003)
Polish to German
+ ...
Batch applying reviewed and signed off status possible Dec 19, 2010

However there is no batch apply of the "translated status".
To apply reviewed status open the file in review modus, for sign-off open in sign-off modus.


Direct link Reply with quote
 

István Hirsch  Identity Verified
Local time: 08:00
English to Hungarian
Workaround Dec 20, 2010

If there is no „built-in” solution, I would try this on a backup copy. I hope you can lock almost all translated segments, at least segments which contain at least one space. Do every filtering „In Target”. (Editor View)

1. In the filter display window, select "Unconfirmed segments" - OK.
2. Press Ctrl+H and Replace every space with ß (if it is not in the text).
3. Display „All segments" Containing: space (just press the spacebar) - OK.
4. Click on the last line on the target side of the filtered text. Then go to the first line, hold down Shift and left-click on the first line in the column of numbers (in front of the source segment). All the filtered text should go brown.
5. Press Ctrl+L (Lock segment).
6. In the filter display, select „All segments” (do not forget to delete the invisible space from the „Containing” window) - OK, then Replace every ß with space.

This will lock target segments which have more than one word. If you wish to transform one-word segments (no space), too, perform the same procedure using one (or more) frequently occurring letter instead of a space.

The process above will not automatically update the TM, so, if everything is OK, save and close the file, go to Translation Memory View, open the TM and update it at Project/Batch Tasks.


Direct link Reply with quote
 
welle
Local time: 08:00
TOPIC STARTER
yes, but... Dec 22, 2010

Thank you very much for your suggestion. This does not work if I select let say 1000 segments, 999 are locked, but one is unlocked. Changing status is not possible. I have a huge file with some segments which are locked and some which are not. Unlocking the whole file seems to be unpossible (except by changing any single segment or groups of adiacient segments with the same status). That seems to me a very negative point!

Direct link Reply with quote
 

István Hirsch  Identity Verified
Local time: 08:00
English to Hungarian
Another workaround Dec 22, 2010

Of course, I cannot see the problem in its entire complexity, still there is a workaround if you wish to change the status of not adjacent segments from locked to unlocked in a batch process. It is based on the fact that a replacement operation will change all target segments except the locked ones. If, as in the above workaround, all spaces are replaced with, let’s say, ß, only locked segments will still have spaces after the replacement, so it is possible to separate them by filtering. When they have been filtered (you have only locked segments on the target side), their status can be changed from locked to unlocked in a batch process, like before (step 4 and 5).
This worked on a five-sentence sample text, where two segments were locked, the others unlocked.


Direct link Reply with quote
 
welle
Local time: 08:00
TOPIC STARTER
My final workaround Jan 5, 2011

I'd like to share with you my final workaround for this problem. Maybe it is not the best one, but it works fine and is very fast.

Core problem: a huge SDLXLIFF file with some segments locked. The locked segments are not adiacent. With my installation (XP, SDL TRADOS 2009 SP 3) I was not able to unlock ALL segments at once (beacuse selecting all segments will mean having both locked and unlocked segments selected->the unclock function ist disabled).

My solution: make I backup copy of the SDLXLIFF file, open it with a normal text editor (I use Notepad+). Search and replace all strings

locked="true"

with an empty space. Save it and reopen the file in Trados. All segments are unlocked.

Welle


Direct link Reply with quote
 
FarkasAndras
Local time: 08:00
English to Hungarian
+ ...
Well done Jan 5, 2011

It takes some cojones to mess around in the SDXLIFF, well done. I will keep in mind that SDLXLIFF is a text format, so all sorts of tricks are possible.

On a side note, SDL really should have done a better job with functionality around segment statuses. I was shocked to see that you can't order segments by status. I kept right-clicking at the status column and looking at he top of the column but I couldn't find the option... Other tools that follow the same two-column editor layout seem to have that option, and of course it could come in very handy if you wanted to work on locked/unlocked/translated/untranslated segments or do some operation on one of these groups. It would improve the much-touted review workflow quite significantly.
The group selection is also pretty horrendous in Studio. Maybe in Studio 2011, I guess...

Of course your particular problem would have been fixed if SDL just thought to allow "unlock" on mixed groups, which is a no-brainer, really, but that what we really need is more general functionality in this area.


Direct link Reply with quote
 

István Hirsch  Identity Verified
Local time: 08:00
English to Hungarian
Fine idea Jan 5, 2011

Sometimes I tried to make changes on SDLXLIFF in Notepad, but then always tried to save the file with „Save as” option and could not open it as SDLXLIFF in Studio any more (in Studio, I got the text file as it is seen in Notepad). What came to me as a surprise is that it is possible to save the changes performed in Notepad and reopen the file in Studio without problems, if after performing the necessary changes in Notepad, "Save" option is used.

A similar procedure will be useful in creating other workarounds. Just an example: you can change the source text of SDLXLIFF files, which seems impossible in any other way.


Direct link Reply with quote
 


To report site rules violations or get help, contact a site moderator:


You can also contact site staff by submitting a support request »

SDL Trados 2009 - batch change translation status

Advanced search







LSP.expert
You’re a freelance translator? LSP.expert helps you manage your daily translation jobs. It’s easy, fast and secure.

How about you start tracking translation jobs and sending invoices in minutes? You can also manage your clients and generate reports about your business activities. So you always keep a clear view on your planning, AND you get a free 30 day trial period!

More info »
Wordfast Pro
Translation Memory Software for Any Platform

Exclusive discount for ProZ.com users! Save over 13% when purchasing Wordfast Pro through ProZ.com. Wordfast is the world's #1 provider of platform-independent Translation Memory software. Consistently ranked the most user-friendly and highest value

More info »



Forums
  • All of ProZ.com
  • Term search
  • Jobs
  • Forums
  • Multiple search