Google Translate Plug-in disabled in Trados 2009 SP3
Thread poster: Remy Blaettler

Remy Blaettler
Local time: 22:10
German to English
+ ...
Jan 7, 2011

Hey
I've tried to use the Automatic Google Translate Feature, but it was not available in the Translation Memories Dropdown List.

So I checked under Tools -> Plugins -> Show System Plugins and it was not checked (I think I might have unchecked it a while ago while trying to solve another problem).

Now, the issue is, if I check it and close the window with OK it is unchecked again the next time I open the window or start Trados.

What I'm I missing?


Direct link Reply with quote
 

SDL Community  Identity Verified
United Kingdom
Local time: 22:10
English
Have you tried selecting it for a Project or Translation? Jan 7, 2011

Hi Remy,

Apologies if this is stating the obvious, but your description leaves me a little unsure of what you have tried.

When you open a document for translation, or create a new Project, did you select Google as a Translation memory source? It should appear in one of these two scenarios.

Open Document


Create a Project


Regards

Paul


Direct link Reply with quote
 

Remy Blaettler
Local time: 22:10
German to English
+ ...
TOPIC STARTER
Plug-in not selected Jan 7, 2011

Image and video hosting by TinyPic

The problem is that I cannot even select the Plug-in. If I select it, it will be unselected after I close the window.


Direct link Reply with quote
 

SDL Community  Identity Verified
United Kingdom
Local time: 22:10
English
Manually edited plugincache.xml Jan 10, 2011

Hi Remy,

It took a little while to figure out what you (or someone) have done here because this does not happen on it's own. Normally, the plugincache.xml file is empty, like this;

<?xml version="1.0" encoding="utf-8"?>
</PluginCache>

However, if you do this;

<?xml version="1.0" encoding="utf-8"?>
<PluginCache>
<PluginState
pluginId=
"Sdl.LanguagePlatform.MTConnectors.Google" enabled="False" />
<PluginState pluginId="Sdl.LanguagePlatform.MTConnectors.LanguageWeaver" enabled="False" />
</PluginCache>


Then you will get the effect you have achieved.

The reason checking these boxes back had no effect when you restarted is because these are both system plugins and you are not supposed to be able to edit them. Any custom plugins you have, such as the MyMemory Plugin will work like this but not system plugins.

So, the resolution to your problem is either to replace the words "False" with "True" in your plugincache.xml or simply delete the plugincache.xml altogether and it will be recreated with the default settings. Make sure Studio is not running when you make either of these changes.

It would be good to hear from you whether you (or someone else) caused this problem in the first place by editing this file because we really cannot see how this could happen on it's own. We do know that some companies prefer to have these features disabled to prevent users from making use of these Machine Translation plugins so maybe you are undoing what was supposed to be an intentional act? It is better to remove these from appearing at all if this is what is required however, so your situation is quite an interesting one.

Regards

Paul


[Edited at 2011-01-10 12:54 GMT]


Direct link Reply with quote
 

Remy Blaettler
Local time: 22:10
German to English
+ ...
TOPIC STARTER
Never heard of plugincache.xml Jan 10, 2011

Hey Paul
Thanks for the quick update. This did solve the problem.

For anyone else running into this issue:
The file plugincache.xml is located under
C:\Users\\AppData\Roaming\SDL\SDL Trados Studio\9.1.0.0

Now, I never edited this file manually. Never even heard if it before. I remember that I played around with the plugin settings in Trados itself. I just check with an SP2 installation that we still have and there the plugin dialog looks different:

Image and video hosting by TinyPic

So I guess in SP2 I was able to change the google plugin and in SP3 I couldn't "unchange" now.


Direct link Reply with quote
 

Daniela Mochny
Local time: 18:10
English to Portuguese
+ ...
Help on the same Subject - Google Translate Plug-in Nov 8, 2012

Hello, I was unable to find the file plugincache.xml to activate Google Translate Plug-in.
The path C:\Users\\AppData\Roaming\SDL\SDL Trados Studio\9.1.0.0 does not show on my computer.
I see C:\Users\\AppData\ ... and the only folder shown there is named "LocalLow".
Where should I find this "plugincache.xml"?
My version is SDL Trados Studio SP3 - 9.1.2269.4

My best wishes,
Daniela


Direct link Reply with quote
 

Remy Blaettler
Local time: 22:10
German to English
+ ...
TOPIC STARTER
SDL Directory Nov 8, 2012

Can you see C:\Users\YOURNAME\AppData\Roaming\SDL

Direct link Reply with quote
 


To report site rules violations or get help, contact a site moderator:


You can also contact site staff by submitting a support request »

Google Translate Plug-in disabled in Trados 2009 SP3

Advanced search







SDL Trados Studio 2017 Freelance
The leading translation software used by over 250,000 translators.

SDL Trados Studio 2017 helps translators increase translation productivity whilst ensuring quality. Combining translation memory, terminology management and machine translation in one simple and easy-to-use environment.

More info »
PerfectIt consistency checker
Faster Checking, Greater Accuracy

PerfectIt helps deliver error-free documents. It improves consistency, ensures quality and helps to enforce style guides. It’s a powerful tool for pro users, and comes with the assurance of a 30-day money back guarantee.

More info »



Forums
  • All of ProZ.com
  • Term search
  • Jobs
  • Forums
  • Multiple search