Pages in topic:   [1 2] >
Skipping (ignore) red text in Trados 2007
Thread poster: Alexa Dubreuil

Alexa Dubreuil  Identity Verified
United Kingdom
Local time: 11:41
Member (2004)
English to French
+ ...
Jan 19, 2011

Hello

I am working on a 300-page report and part of the text (in red) doesn't need to be translated so I'm trying to work out how to tell Trados to ignore this red text - regardless of the font type, font size, and other formatting (italic, bold, normal).

So far I have looked into both of these but nothing seems to be working:
-File > Setup > Non-Translatable text
-Setting > Non-translatable paragraphs

The first issue is that this red text comes either as italic, bold, normal, font 8, font 9, Trebuchet, Arial, etc., which means several style combinations.

The second issue is that this text appears throughout the documents so it's not like I can just select it, delete it for the translation, and then reincorporate it when I'm done translating the report. Basically, the report alternates between text in black (to be translated) and text in red (no translation required). The text is red is about 66,000 words...

I know how to apply the tw4winExternal style to tell Trados to ignore text but applying this distorts the actual text style (unless I'm not doing it properly) and it would take me too long to correct it afterwards.

Any ideas or suggestions?

Thanks for your help and advice.

PS: I work with Word 2007, Windows XP and SDL Trados 2007. My report is a .doc file.

[Edited at 2011-01-19 15:54 GMT]


Direct link Reply with quote
 

Chris Dawe  Identity Verified
United Kingdom
Local time: 11:41
Portuguese to English
+ ...
Manually skip them.... Jan 19, 2011

Can you not just manually ignore those Source segments, or is that only a workaround?

Direct link Reply with quote
 

Soonthon LUPKITARO(Ph.D.)  Identity Verified
Thailand
Local time: 17:41
Member (2004)
English to Thai
+ ...
Hidden text Jan 19, 2011

I guess your source texts are in *.doc format. Search all red texts and replace all into hidden fonts. You may need to seek texts with same format (right click on the red words), and change all to hidden fonts. Next translate with TagEditor (Trados 2007) or Studio (Trados 2009) to ignore all hidden texts.

Soonthon Lupkitaro


Direct link Reply with quote
 

Alexa Dubreuil  Identity Verified
United Kingdom
Local time: 11:41
Member (2004)
English to French
+ ...
TOPIC STARTER
This is what I'd like to avoid Jan 19, 2011

Chris Dawe wrote:

Can you not just manually ignore those Source segments, or is that only a workaround?


I'm afraid not. Manually ignoring those Source segments won't be an option, for several reasons:
-it would include the red text in the Trados analysis (which I use thoughout the translation process to work out how much text I still need to translate)
-it would cause chaos when I open the file and process it using CTRL+* (not sure how "Traduire jusqu'à analogie" is called in the English version of Trados), in order to spot segments that I need to amend (for instance).
-it simply wouldn't save me any time and would generate more work than if I was to delete the entire text and paste it back at the very end.

I know it's not an easy one...


Direct link Reply with quote
 

Michael Joseph Wdowiak Beijer  Identity Verified
United Kingdom
Local time: 11:41
Member (2009)
Dutch to English
+ ...
finding and replacing all RED text with HIDDEN text Jan 19, 2011

In Word 2010 -> Ctrl H

Under Replace:

(1) Find what: (click in box and select) "Format" -> "Font" ; in Font colour, select: RED (most likely the client used standard bright red)

(2) Replace with: (click in box and select) "Format" -> "Font" ; Under "Effects" click once on "Hidden" (so that it is black, not greyed out, or unselected)

Basically, what you are doing is finding and replacing all RED text with HIDDEN text. After this the red text will not show up in Trados 2007 (or memoQ).

Once you are finished translating, remember to make all of the red visible again.

Michael



[Edited at 2011-01-19 15:59 GMT]


Direct link Reply with quote
 

Alexa Dubreuil  Identity Verified
United Kingdom
Local time: 11:41
Member (2004)
English to French
+ ...
TOPIC STARTER
Good idea but Trados still processes the hidden text Jan 19, 2011

Soonthon LUPKITARO(Ph.D.) wrote:

I guess your source texts are in *.doc format. Search all red texts and replace all into hidden fonts. You may need to seek texts with same format (right click on the red words), and change all to hidden fonts. Next translate with TagEditor (Trados 2007) or Studio (Trados 2009) to ignore all hidden texts.

Soonthon Lupkitaro


Thank you for your suggestion. I have just applied the "hidden" formatting to the red text but Trados doesn't skip it.


Direct link Reply with quote
 

Alexa Dubreuil  Identity Verified
United Kingdom
Local time: 11:41
Member (2004)
English to French
+ ...
TOPIC STARTER
Hidden text Jan 19, 2011

Michael J.W. Beijer wrote:

Basically, what you are doing is finding and replacing all RED text with HIDDEN text. After this the red text will not show up in Trados 2007 (or memoQ).



[Edited at 2011-01-19 15:44 GMT]


Hello Michael
I think this is the same suggestion as Soonthon's. Unfortunately, I've just tried it and Trados does recognise the hidden text.


Direct link Reply with quote
 

Jerzy Czopik  Identity Verified
Germany
Local time: 12:41
Member (2003)
Polish to German
+ ...
Trados does skip hidden text Jan 19, 2011

Alexa Dubreuil wrote:

Soonthon LUPKITARO(Ph.D.) wrote:

I guess your source texts are in *.doc format. Search all red texts and replace all into hidden fonts. You may need to seek texts with same format (right click on the red words), and change all to hidden fonts. Next translate with TagEditor (Trados 2007) or Studio (Trados 2009) to ignore all hidden texts.

Soonthon Lupkitaro


Thank you for your suggestion. I have just applied the "hidden" formatting to the red text but Trados doesn't skip it.


Did you recreate the TTX file? Are you sure the text in question is properly formatted as "hidden"? Trados would not skip hidden text, if it is for example an index entry, but "just" hidden Text in Word 2003 will be left out. However, TagEditor will indeed process hidden text in Word 2007. So if you use docx, save it as doc instead.


Direct link Reply with quote
 

Alexa Dubreuil  Identity Verified
United Kingdom
Local time: 11:41
Member (2004)
English to French
+ ...
TOPIC STARTER
I'm not using a TTX file Jan 19, 2011

Jerzy Czopik wrote:

Did you recreate the TTX file? Are you sure the text in question is properly formatted as "hidden"? Trados would not skip hidden text, if it is for example an index entry, but "just" hidden Text in Word 2003 will be left out. However, TagEditor will indeed process hidden text in Word 2007. So if you use docx, save it as doc instead.


I am using Word 2007 and I am translating the report using Workbench 8 (SDLTrados 2007) and my document is a .DOC file.

To hide the text I did: Format" -> "Font" ; Under "Effects" clicked once on "Hidden"

Trados is processing this hidden text (it's not showing the actual text but the segments appear to be empty unless you choose to show the hidden text).


Direct link Reply with quote
 

Michael Joseph Wdowiak Beijer  Identity Verified
United Kingdom
Local time: 11:41
Member (2009)
Dutch to English
+ ...
@Alexa Jan 19, 2011

As far as I know, Trados does not process hidden text.
Although you can reveal it by using Show hidden text in Word, it doesn't show up in Workbench segments. Or at least it didn't when I just made a brief test .doc

Michael


Direct link Reply with quote
 

Jerzy Czopik  Identity Verified
Germany
Local time: 12:41
Member (2003)
Polish to German
+ ...
This will not work Jan 19, 2011

For this case (TBH I do not really understand, why so many people still go that frustrating way and use Word as CAT) you have to use a non-translatable style.
This will make the whole a bit more complicated, as you need to format the red text in a different style and then reformat it back, but this will at least work in Word 2007 and 2003.
Format the red text as t4wininternal or another style you will define in the translation memory as non-translatable. Please refer to Workbench help on non-translatable styles and to Word help how to apply a style to text.
The better and easier option would be saving the text you have as Word 2003 and opening it in TagEditor.


Direct link Reply with quote
 

Alexa Dubreuil  Identity Verified
United Kingdom
Local time: 11:41
Member (2004)
English to French
+ ...
TOPIC STARTER
This is odd Michael, Jan 19, 2011

Michael J.W. Beijer wrote:
Although you can reveal it by using Show hidden text in Word, it doesn't show up in Workbench segments


This is strange because I aslo did a small test and Trados did open segments with the hidden text in it - the text itself wasn't visible (ie empty segments) but this means that Trados did not ignore the hidden text.


Direct link Reply with quote
 

Alexa Dubreuil  Identity Verified
United Kingdom
Local time: 11:41
Member (2004)
English to French
+ ...
TOPIC STARTER
Tag Editor involves other issues and sources of frustration... Jan 19, 2011

Jerzy, I haven't tried opening my file in Tag Editor and I don't think I will because I would then face another issue: using my two spell-checking tools! They don't work in Tag Editor.

Also this report is so massive (300 pages) that I do need to see the text in context. Tag Editor is so not user-friendly... I also need to access footnotes and make changes to the hypertext links they include - this is not easy in Tag Editor (I've tried in the past).

I've also already referred to the Workbench help and it's not that helpful! This is why I posted on this forum, in order to get suggestions from fellow users.

Anyway, based on all your answers, it seems like there is no easy way to tell Trados "just skip the red text"... apart from applying the hidden effect to the text, saving the document and opening it in Tag Editor. Unfortunately this is not going to work for me.

Thanks anyway.


Direct link Reply with quote
 

Jerzy Czopik  Identity Verified
Germany
Local time: 12:41
Member (2003)
Polish to German
+ ...
Use the tw4wininternal style Jan 19, 2011

Instead of making text hidden use the search&replace dialog to format the red text with this style. This will include reformatting the text afterwards, but should bring you the desired effect.
In regard of TagEditor I just do not share your opinion, having been using TagEditor for several years on different Word and other files. But this is indeed personal prefference. Now I would neither use Word not TagEditor, but Studio, making use of the most modern technology. But finally it is your work and your decision


Direct link Reply with quote
 

Alexa Dubreuil  Identity Verified
United Kingdom
Local time: 11:41
Member (2004)
English to French
+ ...
TOPIC STARTER
Thank you Jan 19, 2011

Jerzy, thank you for your useful comments.

Using the search and replace option was what I had in mind (searching for red text and replacing it with a tw4winExternal style in a red formatting).

It's just a shame that Trados messes with the formatting when it does the cleanup. Even if I adjust the parameters of the tw4winExternal style to make it look as close to the main red text as possible (Trebuchet, 8, normal, red), it reverts to Courrier grey after the cleanup, so there is re-formatting involved indeed.

But as you say this would have the desired effect ie skipping the segments. I'm just not sure how much time it would actually save compared to just deleting the red text and reincorporating it manually once the translation is finished!

I fully agree about Tag Editor: it's really a matter of preference. I use it for PowerPoint and Excel but for Word I prefer seeing the document I'm working in. Plus I always find it difficult to amend the hypertext links or tags if need be (even if I remove the protection). And there is the spell-checking issue - the built-in spell-checking tool in Tag Editor is not very good and the 2 programmes that I normally use (Antidote and ProLexis) are integrated in MS Word.

With Tag Editor, the text's formatting and layout are better protected but at the same time the application is less flexible. You can't get everything I guess...

I had intended to use Studio 2009, which I own but I find it difficult to adapt to it, especially when it comes to managing TMs (converting, exporting etc.). Also, some clients don't always mention that they want the 'unclean' files as well as the 'cleaned' files and from what I remember, when you use Studio, you can't supply such files.

Oh well...

Thanks again to everyone for helping.

[Edited at 2011-01-19 19:22 GMT]


Direct link Reply with quote
 
Pages in topic:   [1 2] >


To report site rules violations or get help, contact a site moderator:


You can also contact site staff by submitting a support request »

Skipping (ignore) red text in Trados 2007

Advanced search







WordFinder
The words you want Anywhere, Anytime

WordFinder is the market's fastest and easiest way of finding the right word, term, translation or synonym in one or more dictionaries. In our assortment you can choose among more than 120 dictionaries in 15 languages from leading publishers.

More info »
Anycount & Translation Office 3000
Translation Office 3000

Translation Office 3000 is an advanced accounting tool for freelance translators and small agencies. TO3000 easily and seamlessly integrates with the business life of professional freelance translators.

More info »



Forums
  • All of ProZ.com
  • Term search
  • Jobs
  • Forums
  • Multiple search