Auto-insert problem Studio 2009
Thread poster: Angela Dickson

Angela Dickson  Identity Verified
United Kingdom
Local time: 18:04
French to English
+ ...
Jan 26, 2011

Hello all,

I'm having a strange problem with numbers in Studio 2009. I have a fairly straightforward table that is full of French numbers, in most cases in the format 0,001 (or similar - most to 3 decimal places) and many surrounded with brackets and/or followed directly by asterisks. Studio recognises these as numbers; there is a blue "placeable" line under them in the source segment.

These have all been auto-propagated/auto-inserted correctly (with decimal comma changed appropriately to decimal point) as 100% matches, but when I navigate to each segment in order to confirm it, the decimal point disappears from the target segment. This means that instead of just straightforwardly confirming everything, I have to work on each segment to insert the decimal point, which is driving me mad.

I have been trying to find the relevant settings for auto-localisation of numbers but it seems I can only change the settings for dates, times and measurements. These are just numbers.

Full details: Windows Vista Business
SDL Trados 2009 SP3 9.1.2229.0
Translating a Word doc (.docx)

many thanks in advance for any suggestions!


Direct link Reply with quote
 

Emma Goldsmith  Identity Verified
Spain
Local time: 19:04
Member (2010)
Spanish to English
confirming a segment Jan 26, 2011

I don't know how to solve your problem with the disappearing decimal points, but if the auto-propagation is working well as you say, then you don't have to confirm each segment if you have enabled "confirm segment after auto-propagating an exact match" in options>editor>auto-propagation.
Just an idea.


Direct link Reply with quote
 

Angela Dickson  Identity Verified
United Kingdom
Local time: 18:04
French to English
+ ...
TOPIC STARTER
sticking plaster Jan 26, 2011

Emma Goldsmith wrote:

I don't know how to solve your problem with the disappearing decimal points, but if the auto-propagation is working well as you say, then you don't have to confirm each segment if you have enabled "confirm segment after auto-propagating an exact match" in options>editor>auto-propagation.
Just an idea.


Thanks Emma. I could do that, but I'd prefer to leave that option as it is - I like to know what has been auto-propagated, so I am prompted to check whether it might be appropriate to change it. I'd rather solve the problem rather than resort to this workaround.

It occurs to me that I'm using 2 translation memories for this job, and there might be conflicting settings. I'll check that...


Direct link Reply with quote
 

Jerzy Czopik  Identity Verified
Germany
Local time: 19:04
Member (2003)
Polish to German
+ ...
Change the AutoPropagate Prompt User setting to "Always" Jan 26, 2011

Then you will always know what is propagated. In conjunction with Emmas suggestion you will then have an optimal behaviour for AutoPropagate in my opinion.
In this configuration I not only see, what will be how auto propagated, but can decide whether it shall be auto propagated ot not.

As for the number problem:
why not use display filter for it?
^\d+$ will display all numbers like 10, 1, 2589 and so on
^\d+\,\d+$ will display all numbers with comma, like 10,1555 and so on
^\(\d+\)$ will display numbers in brackets (100) and so on
^\(\d+\,\d+\)$ will display numbers with comma in brackets (1,22)
^\d+\,\d+\*$ will dsplay numbers with comma, followed by an asterisk

When you display one of the number forms you can then select all displayed segments by clicking in the first segment number, press shift and click in the last segment number. Then copy source to target. Using Search and Replace change the notation from French to English (ie search for , and replace with .). The S&R works now ONLY for shown segments.
This way you can deal with pretty much amounts of number only segments very quickly.


Direct link Reply with quote
 

Angela Dickson  Identity Verified
United Kingdom
Local time: 18:04
French to English
+ ...
TOPIC STARTER
Thanks Jan 26, 2011

Thanks very much, Jerzy, I'll look into that. For this job, as there is no repeated content apart from the numbers in these tables, I've temporarily implemented Emma's idea.

Direct link Reply with quote
 

Sanych_Msk  Identity Verified
Russian Federation
Local time: 20:04
Member (2010)
English to Russian
Similar problems Jan 27, 2011

I encountered two similar problems. May be someone will give me a good advice. My experience with Trados (Studio 2009 Freelance) is two months only, and every week I discover something interesting ...

(1)
I am now translating a text (English to Russian, ca. 25,000 words), that consists of paragraphs numbered: 15.1., 15.2. and so on up to “fifteen [point] two hundred something [point]”. It is supposed, that in the Russian target text the paragraph numbers should look exactly the same.

My Trados:

(a) properly split the text into segments by sentences, but (!) split each paragraph number as a separate segment:
Instead of
15.1. Here the story begins ...
we have:
| 15.1.
| Here the story begins ...

(b) tries to “translate” paragraph numbers as numbers with decimal point - English to Russian (European ?) style:
| 15.1. | 15,1. | [with decimal comma instead of decimal point]

Is it possible to “tell” Trados that such occasions (numbers) should be copied “source to target” without any amendments ? (So far, I did it manually, 200 paragraph numbers, one by one. May I use some batch mode ?)

Is it possible to mark those segments as properly translated (for statistics) without adding all those “15.1.”, “15.2.”, etc. to Translation Memory ?

(2)
The text spoken about contains a lot of complicated mathematical formulae. The client took away all unnecessary formatting of the source text and substituted those formulae by some dummy characters like this:
@@@ (1) [formula No. 1]
@@@ (2) [formula No. 2]
etc.
It is supposed, that after I finish my translation job (leaving lines for formulae as they are) another person will take care to input all formulae (using Search “@@@” command to find proper places fast), symbols, subscripts, superscripts, proper formatting, etc.

My Trados also tries to “translate” those lines. After I confirm the first line as“@@@ (1)”, it is added to the Translation Memory. On the line “@@@ (2)” Trados helpfully suggests to translate it as “@@@ (1)” (as good, but less than 100% matching). After I edit the target text as “@@@ (2)” and several paragraphs later come across formula No.3 or “@@@ (3)” Trados prompts me to translate it as “@@@ (1)” or “@@@ (2)” and so on.

So, I have the same two questions:

Is it possible to “tell” Trados that such occasions should be copied “source to target” without any amendments ? Is it possible to mark those segments as properly translated without adding their contents to Translation Memory ?



[Edited at 2011-01-27 03:52 GMT]

[Edited at 2011-01-27 03:54 GMT]


Direct link Reply with quote
 

Dr. Matthias Schauen  Identity Verified
Germany
Local time: 19:04
Member
English to German
Problem still occurs Sep 25, 2011

Hi, I have the same problem Angela described in the first post with
Studio 2009 Freelance SP3 9.1.2297.8,
translating a DOCX file,
Windows 7.
I will try the workarounds described here, but this apparent bug is still around!


Direct link Reply with quote
 

Jerzy Czopik  Identity Verified
Germany
Local time: 19:04
Member (2003)
Polish to German
+ ...
Try Display filter Sep 25, 2011

@Sanych_Msk: did you try to show only such segments? For example did you try to show segments like "15.1" and then copied all the segments to target and set their status to translated?
Takes a minute or so and all such and similar segments, where there is no text to translate are done.

@Dr. Matthias Schauen: try display filter and the auto propagation settings described here. Dealing with number is then really fast and easy.


Direct link Reply with quote
 


To report site rules violations or get help, contact a site moderator:


You can also contact site staff by submitting a support request »

Auto-insert problem Studio 2009

Advanced search







memoQ translator pro
Kilgray's memoQ is the world's fastest developing integrated localization & translation environment rendering you more productive and efficient.

With our advanced file filters, unlimited language and advanced file support, memoQ translator pro has been designed for translators and reviewers who work on their own, with other translators or in team-based translation projects.

More info »
Wordfast Pro
Translation Memory Software for Any Platform

Exclusive discount for ProZ.com users! Save over 13% when purchasing Wordfast Pro through ProZ.com. Wordfast is the world's #1 provider of platform-independent Translation Memory software. Consistently ranked the most user-friendly and highest value

More info »



Forums
  • All of ProZ.com
  • Term search
  • Jobs
  • Forums
  • Multiple search