Do SDL XLIFF files remain in software tree structure
Thread poster: Rosemary Vandertop

Rosemary Vandertop  Identity Verified
United Kingdom
Local time: 22:35
Dutch to English
Feb 1, 2011

How do I remove the SDL XLIFF files, project files and Files Types that Trados Studio adds to the software file structure (in this case hundreds of files....) Manually that would take 10 days, surely there's a quick way.

Direct link Reply with quote
 

Jerzy Czopik  Identity Verified
Germany
Local time: 23:35
Member (2003)
Polish to German
+ ...
Which software structure do you mean? Feb 1, 2011

And why would you like to destroy your own work?

Direct link Reply with quote
 

Rosemary Vandertop  Identity Verified
United Kingdom
Local time: 22:35
Dutch to English
TOPIC STARTER
Do SDL XLIFF files remain in software tree structure Feb 1, 2011

I have an assignment to translate hundreds of files of web/software content. I am not allowed to change the (complicated) file structure, so when I used to import the main folder into Trados Studio 2007 I could translate and save as target with exactly the same name (would overwrite the original, as requested by the client) and without changing the file structure. However, with Studio 2009, first of all Trados won't import all the files (file names too long because the path is too deep) and then proceeds by creating XLIFF files, project files and file type files for each file I translate, all in the path and structure of the documents the client asked me not to change. All these Studio 2009 files would have to be removed from the structure, but surely not manually, that could take days, even weeks.

[Edited at 2011-02-01 16:36 GMT]


Direct link Reply with quote
 

Jerzy Czopik  Identity Verified
Germany
Local time: 23:35
Member (2003)
Polish to German
+ ...
Make your life easier Feb 1, 2011

Create a folder not so deep in your file structure, ie D:\Job_20110201\
Place the folder tree from the customer there.
Create a project in Studio. Add the files from folder (not indivudually).
After the folder structure (or tree) has been read in Studio press the button looking like duplcated folder symbol, This will show you all files in a flat strtucture in the window of project creation wizard. Now select all the files there and chose "Merge files". Give a meningful name to the merged file and process that one.
When you're done use "Finalize" batch to get the main TM updated and the files stored as target in the same tree structure as previously, with obviously exactly the same names.
This way Studio will create JUST TWO SDLXLIFF files for this project.


Direct link Reply with quote
 

Rosemary Vandertop  Identity Verified
United Kingdom
Local time: 22:35
Dutch to English
TOPIC STARTER
Error message Feb 1, 2011

I moved the folder up to the highest level on my computer (My Documents) but still get this error message:
---------------------------
Error
---------------------------
Failed to add 'C:\Documents and Settings\Owner\My Documents\CUBIGO_Translations_EN\Shared-WPF-SL Applications\RBD\Cubigo\software\Shared-WPF-SL\Applications\CubigoAlarmClock\Cultures\Translation.nl.resx.ttx' to the project.



Adding this file to the project would result in a path that is too long. Consider changing the project's local data folder or changing the project folder structure.



Click OK to continue adding the remaining files or Cancel to stop the process.
---------------------------
OK Cancel
---------------------------

Obviously I can't change the structure

[Edited at 2011-02-01 18:08 GMT]


Direct link Reply with quote
 

Jerzy Czopik  Identity Verified
Germany
Local time: 23:35
Member (2003)
Polish to German
+ ...
Why do you not follow a clear advice? Feb 1, 2011

The Documents and settings folder is quite deep in the folder structure of your system.
BThis is NOT the "highest level".
So please place the project folder on a HDD directly in root folder like this:
d:\CUBIGO_Translations_EN\Shared-WPF-SL Applications\RBD\Cubigo\software\Shared-WPF-SL\Applications\CubigoAlarmClock\Cultures\
This will make the path much shorter.

[Edited at 2011-02-01 18:10 GMT]


Direct link Reply with quote
 

Rosemary Vandertop  Identity Verified
United Kingdom
Local time: 22:35
Dutch to English
TOPIC STARTER
Misunderstanding Feb 1, 2011

Sorry, it's ignorance I'm afraid, not that I know better at all. That 'job' folder you suggested, where would I place it?

Direct link Reply with quote
 

Jerzy Czopik  Identity Verified
Germany
Local time: 23:35
Member (2003)
Polish to German
+ ...
In the root folder of your hard drive Feb 1, 2011

Documents and settings is a system subfolder on your drive C:
If you have just this one drive in your system, place the job folder on C:
not in any subfolder there but in the root.
Just go to My Computer. OPen the hdd C:, click on File - New- Folder and create a folder "JOB". Then place the customer structure there inside. This should really work - I already have had error messages regarding the path length when trying to use My documents for training.
The "My documents" folder is placed by Microsoft on your system in Windows Explorer so, that it SEEMS to be the highest level, but it isn't - here is MS cheating us.


Direct link Reply with quote
 

Rosemary Vandertop  Identity Verified
United Kingdom
Local time: 22:35
Dutch to English
TOPIC STARTER
I think I've got it! Feb 1, 2011

Thank you Jerzy, it works. Forgive me for being so obtuse...

Direct link Reply with quote
 

Jerzy Czopik  Identity Verified
Germany
Local time: 23:35
Member (2003)
Polish to German
+ ...
No problem Feb 1, 2011

Now please really try to make your life easier.
As soon your project will be created you cannot merge the files anymore.
So in the step where you add the folder press the symbol looking like double-folder.
This will show you all files in the project, you can now select them all and merge.
Studio will merge the files just for translation, but after you're done it will recreate exactly the same folder and name structure as before.
Just try this - it will give you really only advantages, and you will love this option.


Direct link Reply with quote
 

Rosemary Vandertop  Identity Verified
United Kingdom
Local time: 22:35
Dutch to English
TOPIC STARTER
path too long Feb 6, 2011

With the main folder directly on the C-drive it now says half-way through the project that I cannot open the files in Studio 2009 because the path is too long.....

Direct link Reply with quote
 

Jerzy Czopik  Identity Verified
Germany
Local time: 23:35
Member (2003)
Polish to German
+ ...
You will have to flatten the folder structure Feb 7, 2011

Talk to the customer, as it really looks like they made the file structure too complicated.

Direct link Reply with quote
 


To report site rules violations or get help, contact a site moderator:


You can also contact site staff by submitting a support request »

Do SDL XLIFF files remain in software tree structure

Advanced search







WordFinder
The words you want Anywhere, Anytime

WordFinder is the market's fastest and easiest way of finding the right word, term, translation or synonym in one or more dictionaries. In our assortment you can choose among more than 120 dictionaries in 15 languages from leading publishers.

More info »
Wordfast Pro
Translation Memory Software for Any Platform

Exclusive discount for ProZ.com users! Save over 13% when purchasing Wordfast Pro through ProZ.com. Wordfast is the world's #1 provider of platform-independent Translation Memory software. Consistently ranked the most user-friendly and highest value

More info »



Forums
  • All of ProZ.com
  • Term search
  • Jobs
  • Forums
  • Multiple search