Pages in topic:   [1 2] >
Failed to save target content: Length cannot be less than zero. Parameter name: length
Thread poster: Scott Saylor

Scott Saylor  Identity Verified
Local time: 19:13
Japanese to English
Feb 20, 2011

Failed to save target content: Length cannot be less than zero. Parameter name: length

Can anyone tell me where this error comes from and how to fix it?

Several segments in my source document (that I made in Microsoft Word with the help of an OCR tool) set off the above alert and completely prevent me from saving my target. This happens a lot when I use TRADOS and its quite maddening! I have tried making the whole source document into unformatted text, and this error still happens.

I have a hunch that it has something to do with sentences that have both Japanese and English in it. Either that or subscripts and superscripts.

By the way, all the segments have been translated so that is NOT the problem.

Please let me know how to fix this!


Direct link Reply with quote
 

Kerstin Green  Identity Verified
United Kingdom
Local time: 03:13
English to German
+ ...
Same problem! Feb 24, 2011

I get the same message. I have 6 documents, they all were prepared in the same way (from pdf with OCR, then cleaned up). 4 work fine, and on the other 2 I get this error.
I have to turn this in tomorrow!
HELP!


Direct link Reply with quote
 

Scott Saylor  Identity Verified
Local time: 19:13
Japanese to English
TOPIC STARTER
Thanks for posting, too, Kersten Feb 27, 2011

Thank you for posting, too, Kersten. I hope SDL will be able to answer this soon, because it is a really critical issue.

I have found a way to avoid it when I am preparing documents for Trados. It actually involves removing all of the formatting, though, but it works. I paste everything into notepad then I paste it from Notepad back into Word using the Paste Special unformatted text option. Then I save that as the file.

However, that is not a satisfactory workaround for me because it involves losing all the formatting. So SDL, please let us know!

[Edited at 2011-02-27 00:20 GMT]


Direct link Reply with quote
 

Hector Aires
Local time: 23:13
Member
English to Spanish
I had the same problem today with Trados Studio 2009 but I solved (four hours) Feb 27, 2011

Hi you both !!!!!

On the source MSWord file I had several terms as "N2" and "H2O2". To make the target more accurate I replaced the "2" in plain text with the "2" in subscript for, as example, "liquid N2" (liquid nitrogen), the same for the hydrogen peroxide "H2O2". When saving target as... the legend "Length cannot be less than zero. Parameter name: length" appeared.
And there was the problem. Inserting the subscripts placed new tags, hence, I deleted those tags and everything went fine.
I replaced the plain text 2s with subscripts 2s on the MSWord translated file and that's all.

Have my best regards

El Étor


Direct link Reply with quote
 

Scott Saylor  Identity Verified
Local time: 19:13
Japanese to English
TOPIC STARTER
Thank you! Feb 27, 2011

Hector, Thank you so much for your reply. I definitely had subscripts in my text, so that must have been the problem. Do you know if this problem is limited to subscripts or if it happens whenever you modify a Word document (i.e. any modifications make new tags)? I hope this only applies to subscripts.

Direct link Reply with quote
 

Scott Saylor  Identity Verified
Local time: 19:13
Japanese to English
TOPIC STARTER
Also Feb 27, 2011

Also, I just saw the subject of your reply. Congratulations for solving even though it took 4 hours! It took me the same amount of time to not be able to solve it.

Direct link Reply with quote
 

Brigitte Hamilton  Identity Verified
Canada
Local time: 21:13
Member (2007)
German to English
Thanks Hector! Feb 27, 2011

I also had the same problem today and was able to save to target once I removed the two subscripts in my document. I would have never guessed that was the problem, so a big thank you for saving me a lot of time!

[Edited at 2011-02-27 04:26 GMT]


Direct link Reply with quote
 

Kerstin Green  Identity Verified
United Kingdom
Local time: 03:13
English to German
+ ...
That was it! Feb 27, 2011

Yup, that solved it for me, too. I had several times "CO2" with subscript in the document.

Thanks!!


Direct link Reply with quote
 

Hector Aires
Local time: 23:13
Member
English to Spanish
I don't know Feb 27, 2011

Scott Saylor wrote:

Hector, Thank you so much for your reply. I definitely had subscripts in my text, so that must have been the problem. Do you know if this problem is limited to subscripts or if it happens whenever you modify a Word document (i.e. any modifications make new tags)? I hope this only applies to subscripts.

I upgraded SDL Trados 2007 to Studio on last December and am applying it very slowly for MSWord, Excel and PP, in fact the Office Suite.
For InDesign and Quark we, my team and me, still use SDL Trados 2007.
Then, my experience with Studio is rather short. However, I think there should be another way to solve the problem. I have added several types of tags on TE other than subscripts and never had a problem. I think Studio should work in a similar way.
Hope this helps.
Cheers
El Étor


Direct link Reply with quote
 

George Cook
United Kingdom
Local time: 03:13
French to English
+ ...
New tags are the culprit Mar 10, 2011

I have had this problem a few times today in a huge document I was working in. The problem is new tags.

After I received the error I went through the document and removed the new tags I had inserted (italics, superscripts, subscripts), either replacing them with nothing, or replacing them with the correct tag pair from the source text.

After each one, I saved the document and tried to Save Target As..., but to no avail, until all of them had been corrected. There was then no problem.

My advice, therefore, is always use the tags from the source text, or do the formatting in the target Word document; adding italics/superscripts etc. from the toggle menu seems to generate this problem.


Direct link Reply with quote
 

Scott Saylor  Identity Verified
Local time: 19:13
Japanese to English
TOPIC STARTER
Reply Mar 11, 2011

Hi George,

Yeah, I was kind of wondering if it might happen with other formatting tags. I agree that its just too much of a risk to format anything in the source if youre going to do an important project.

One thing I don't get is how Trados can see that you have made a "new" tag. Does Microsoft Word somehow secretly store this information when you modify a document that you generated via an OCR or other tool? I wonder.

Either way, it seems like a shame that we can't reliably format our own documents and take advantage of the formatting features in Trados Studio. SDL...are you listening....?

Scott


Direct link Reply with quote
 
Michael-M
Local time: 04:13
French to English
Confirmation Apr 28, 2011

Hi -

Thank goodness for this thread. I only wasted an hour trying to fix my document.

The problem is new tags, as George says.

I had an occurrence of CO2 in my English source, with a subscript in the original, and it didn't come through with a subscript in the French target. I therefore added the subscript with Trados, and soon had the "Length cannot be less than zero" problem. Interestingly enough, the problem cell was identified as being a few sentences later than the cell with CO2.

After reading your posts, I edited the Translation Unit to remove the new subscript tags and my document now regenerates fine. Removing the tags with the subscript button DID NOT have the same effect.

Note: "Preview" and Shift-F12 (to generate the target) seem to be pretty much the same, so by keeping the Preview up to date on my 2nd monitor I was able to find out WHEN the document started to fail, rather than waiting until much later. Thus, the "subscript thing" was fresh in my mind when I saw your post.

I submitted this to SDL as something they definitely need to fix, as you also suggest in this thread.

Thanks again,

Michael


Direct link Reply with quote
 

Scott Saylor  Identity Verified
Local time: 19:13
Japanese to English
TOPIC STARTER
Preview Window Great Idea Apr 28, 2011

Hi Michael,

Thank you for describing your technique of leaving the preview window open to see when the document fails. I am going to use that trick! Last night I actually encountered this problem all over again because I accidentally added subscripts -- but when I took them away using the Trados toolbar commands that remove the subscript, I still couldn't save the target. Now I also know that I have to edit the translation unit (or at least for a few spaces before and after whatever at one point had a subscript or superscript), as I learned last night when I meticulously checked the document for the faulty part.

Anyway, thanks for your message and thanks for sending to SDL!


Direct link Reply with quote
 
Michael-M
Local time: 04:13
French to English
Glad to help Apr 29, 2011

How unusual to feel that I can actually give advice on this forum! I guess I just use Trados so much that I can figure out how to push it when I know it should be able to do something.

Direct link Reply with quote
 
xxxTrans-IT Tra
Canada
Local time: 22:13
English to French
Try this workaround while we get a patch from SDL Apr 30, 2011

We ran into this problem today and found a turnaround that works without having to edit the final Word file (or at least it did for us!):
1- Read the original file in good old Tag Editor and create a TTX.
2- Read this TTX into Trados 2009
3- Translate the document
4- Save target directly as a Word file (ours was a DOCX).

The final document was formatted with the proper superscripts (in our case).
Somewhat cumbersome but what else is new


Direct link Reply with quote
 
Pages in topic:   [1 2] >


To report site rules violations or get help, contact a site moderator:


You can also contact site staff by submitting a support request »

Failed to save target content: Length cannot be less than zero. Parameter name: length

Advanced search







TM-Town
Manage your TMs and Terms ... and boost your translation business

Are you ready for something fresh in the industry? TM-Town is a unique new site for you -- the freelance translator -- to store, manage and share translation memories (TMs) and glossaries...and potentially meet new clients on the basis of your prior work.

More info »
Anycount & Translation Office 3000
Translation Office 3000

Translation Office 3000 is an advanced accounting tool for freelance translators and small agencies. TO3000 easily and seamlessly integrates with the business life of professional freelance translators.

More info »



Forums
  • All of ProZ.com
  • Term search
  • Jobs
  • Forums
  • Multiple search