Pages in topic:   [1 2] >
Trados 2009 TM not updating despite doing everything suggested in forum....
Thread poster: Mary Moritz

Mary Moritz  Identity Verified
Local time: 04:43
Member (2007)
French to English
Mar 8, 2011

I purchased Trados 2009 in January through a ProZ group buy. Since then, I have been trying to get up to speed on using it in my (rare) spare time, but I have run into a very basic problem inhibiting me from moving forward: my TMs do not update.

I have diligently done the available tutorials and webinars to make sure I am doing what needs to be done. I have scrupulously gone through the forums about this. I have followed what seems to be every suggestion. Even though I have checked update beforehand, even though I have finalized the document, even though I have used the Task>Update main TM, my TM simply remains empty.

The absolute only way I can update my TM is by importing the final SDL XLIFF file into the TM, and this is thanks to Jerzy’s suggestion in another forum topic.

None of this seems normal to me and has taken up way too much time. I am now wondering if I shouldn’t uninstall and re-install the software (but, will SDL let me?) just to make sure that it isn’t a bug.

Any suggestions out there?


 

Jerzy Czopik  Identity Verified
Germany
Local time: 04:43
Member (2003)
Polish to German
+ ...
No need to reinstall the software Mar 8, 2011

Please be so kind and check, if your settings in your TM setup are similar to those here:



If yes, do you confirm every segment after translation? Only when you confirm the segment it is written into the translation memory. Unconfirmed segments remain outside of the TM during the translation process, in finalize task and when uodating the TM. When importing the SDLXLIFF you can however change the settings and import even unconfirmed segments.


 

Mary Moritz  Identity Verified
Local time: 04:43
Member (2007)
French to English
TOPIC STARTER
Yes Mar 8, 2011

Hi Jerzy,

Thank you for taking the time to verify this with me.

I have checked the settings and my one TM (I removed the others to start over) is exactly like the TM listed on the top of your screen shot.

When confirming a segment, I press ctrl+alt=enter and it tells me the segment is translated (pencil with green check).


 

Jerzy Czopik  Identity Verified
Germany
Local time: 04:43
Member (2003)
Polish to German
+ ...
Then I really do not understand... Mar 8, 2011

This should really workicon_frown.gif
Without having a possibility to look at your PC I must give up.


 

Bernard Lieber  Identity Verified
Local time: 04:43
English to French
+ ...
TMs in SLD Trados Studio Mar 8, 2011

I found a similar issue. When creating your TM, do you create it under User\Documents\SDL Trados Studio\Translation Memories?

When you actually create a project, the TM appears under Project # and TM and target language (for instance, fr-FR) and that's the TM that gets updated.

Hope this helps


 

SDL Community  Identity Verified
United Kingdom
Local time: 04:43
English
Maybe let us take a look? Mar 8, 2011

Hi Mary,

Maybe you'd have time for a quick webex tomorrow? If so, drop me a mail at pfilkin@sdl.com

Regards

Paul
pfilkin@sdl.com


 

Signe Golly  Identity Verified
Denmark
Local time: 04:43
Danish to English
+ ...
batch task > finalize Mar 8, 2011

I was having problems with my TM not updating recently and could NOT get it to work. Turns out that the problem (I think) was that I was not finalizing the document (file>batch tasks>finalize) which automatically updates the main TM rather than whatever project TMs may have come up.
I'm now working on a different project in which I set up a TM after completing the first of several files and I have been able to successfully update it after each completed file simple by finalizing the task. I never saw the point of finalizing before since I was mainly working with simple Word documents (source and target) and so I would just save my target version from View in > MS word as target (since I prefer to clean up and proofread the document in the end version). I still do that but now I also make sure the finalize at the end of each file so my TMs are updatedicon_smile.gif


 

Mary Moritz  Identity Verified
Local time: 04:43
Member (2007)
French to English
TOPIC STARTER
Yes Mar 9, 2011

Bernard Lieber wrote:

I found a similar issue. When creating your TM, do you create it under User\Documents\SDL Trados Studio\Translation Memories?

When you actually create a project, the TM appears under Project # and TM and target language (for instance, fr-FR) and that's the TM that gets updated.

Hope this helps


Hello Bernard,

I have verified this and this is where my TMs are.

Mary


 

Mary Moritz  Identity Verified
Local time: 04:43
Member (2007)
French to English
TOPIC STARTER
Yes Mar 9, 2011

Signe Golly wrote:

I was having problems with my TM not updating recently and could NOT get it to work. Turns out that the problem (I think) was that I was not finalizing the document (file>batch tasks>finalize) which automatically updates the main TM rather than whatever project TMs may have come up.
I'm now working on a different project in which I set up a TM after completing the first of several files and I have been able to successfully update it after each completed file simple by finalizing the task. I never saw the point of finalizing before since I was mainly working with simple Word documents (source and target) and so I would just save my target version from View in > MS word as target (since I prefer to clean up and proofread the document in the end version). I still do that but now I also make sure the finalize at the end of each file so my TMs are updatedicon_smile.gif


Hi,

Thanks for your response, but yes, I do finalize the document and still nothing.

Mary


 

Mary Moritz  Identity Verified
Local time: 04:43
Member (2007)
French to English
TOPIC STARTER
Thanks for your offer Mar 9, 2011

SDL Support wrote:

Hi Mary,

Maybe you'd have time for a quick webex tomorrow? If so, drop me a mail at pfilkin@sdl.com

Regards

Paul
pfilkin@sdl.com


I'll take you up on this. If we find a solution, I hope to be able to post it here as well for others.

Mary


 

Henry Schroeder  Identity Verified
United States
Local time: 22:43
Member (2002)
German to English
+ ...
A solution Mar 27, 2012

I have also had this annoying problem multiple times.

The glitch is in these sub-translation memories. As Jerzy's screenshot shows, each translation memory (green/yellow) has a "sub-translation member" below it.

I have no idea why: But in this lies the problem. You must get rid of the sub-translation member, otherwise the TM does not update.

The only way that I know of doing this is to create the project from scratch again. During this process, DO NOT include an existing TM, but rather, export the segments in that existing TM to a TMX file and then import that TMX file into your new TM.

This absolutely works and resolves the problem.

If you have already translated a whole bunch of text in Trados Studio and want to include it in the non-updating TM, link the project to a "pure" TM, i.e. a TM without this sub-TM and then change the status of each segment to "untranslated".

You can do this collectively by clicking on the first segment and then pressing down "SHIFT" and the left mouse button on the NUMBER of the last segment (far left column). Then likewise with the cursor in the left column (not on the segment), press the right mouse key and change the status of all segments to "untranslated". Then go through the whole file again by clicking SHIFT + RETURN on each segment (I do not think the TM updates if you repeat the aformentioned collective process by shifting the status to "translated").

Then export the TM to a TMX file and proceed as described above.


 

Henry Schroeder  Identity Verified
United States
Local time: 22:43
Member (2002)
German to English
+ ...
But the problem repeats itself Mar 27, 2012

Although my solution works, you are going to have the same problem in the next round. Once you start translating, a sub-TM appears, and the new segments that you would like to have automatically updated in this TM do not appear.

You can easily verify this by creating an export file, then translating a couple segments and exporting the TM again. The number of segments will be identical.

Until Trados or one of the experts here like Jerzy, whom I would personally like to thank for all his efforts with regard to these trados problems - you have solved more than one of my issues, I suppose you prepare the entire translation with the TM and then remove it and proceed as I described in the previous posting.

It's a stupid glitch that Trados needs to resolve or explain since it is the raison d'etre of the program just like printing money is the raison d'etre of central banks.


 

Atso Puronen
Local time: 05:43
English to Finnish
Prepare without Project TM Mar 27, 2012

When creating a project, make sure you finish the Project Wizard using "Prepare without Project TM" batch task. If you use "Prepare" batch task, Studio will create its own idea of what SDL calls a "Project TM". This "Project TM" contains an assortment of segments from your reference TMs and all the translations you create during this particular project.

So it's not a real project TM in which you have just the translations from a specific project. If you need a project-specific TM, please create a new TM during the Project Wizard and set it to update along with your Main TM.

Unless you're sending your Studio projects to other translators to whom you don't want to give your whole Main TM, then don't use "Project TMs" á la Studio.


 

Shawn Champion  Identity Verified
Sweden
Local time: 04:43
Member (2009)
Swedish to English
+ ...
same problem May 15, 2012

This problem decided to randomly show up today. Yay.

I've always used project TMs because I've had clients ask for them before - after completion of the job of course. I don't understand how Trados produces these types of problems when we've changed nothing, I haven't downloaded the newest service pack either.

What I'm trying:
-switching all confirmed segments to drafts, in small chunks, because my beast of a computer freaks out otherwise
-remember to save
-create new TM from the one that should have been updating
-import said TM into the new one
-remove old TM from project, add new one - even this simple step proved inexplicably difficult
-confirm segments that I've already translated
-and of course that didn't work
-loudly curse Trados for wasting an afternoon, for the nth time


 

SDL Community  Identity Verified
United Kingdom
Local time: 04:43
English
Hard to comment... May 15, 2012

... on your process (it looks a little bizarre). But perhaps you can just import the translated SDLXLIFF into your TM to put an end to your current difficulties?

Regards

Paul


 
Pages in topic:   [1 2] >


To report site rules violations or get help, contact a site moderator:


You can also contact site staff by submitting a support request »

Trados 2009 TM not updating despite doing everything suggested in forum....

Advanced search







PerfectIt consistency checker
Faster Checking, Greater Accuracy

PerfectIt helps deliver error-free documents. It improves consistency, ensures quality and helps to enforce style guides. It’s a powerful tool for pro users, and comes with the assurance of a 30-day money back guarantee.

More info »
SDL MultiTerm 2019
Guarantee a unified, consistent and high-quality translation with terminology software by the industry leaders.

SDL MultiTerm 2019 allows translators to create one central location to store and manage multilingual terminology, and with SDL MultiTerm Extract 2019 you can automatically create term lists from your existing documentation to save time.

More info »



Forums
  • All of ProZ.com
  • Term search
  • Jobs
  • Forums
  • Multiple search