Converting XML file into TTX - help needed
Thread poster: Farzad Akmali

Farzad Akmali  Identity Verified
Member
English to Farsi (Persian)
+ ...
Mar 9, 2011

Dear friends,

I have to work on an XML file, I tried to open it in Tageditor, but all in vain. Please let me know how I can solve the problem, I have to send back the translation prompltly.


Thanks so much in advance.


Direct link Reply with quote
 

Stanislav Pokorny  Identity Verified
Czech Republic
Local time: 10:17
English to Czech
+ ...
Create an INI file first Mar 9, 2011

Hello Farzad,
you need to create an INI file first. This INI file will tell TagEditor which content in the XML file is translatable and which isn't.
This process may be very simple but also quite complicated, so there is no universal process description. I therefore suggest that you read the documentation supplied with T2007.


Direct link Reply with quote
 

Farzad Akmali  Identity Verified
Member
English to Farsi (Persian)
+ ...
TOPIC STARTER
The INI file is also provided! Mar 9, 2011

Stanislav Pokorny wrote:

Hello Farzad,
you need to create an INI file first. This INI file will tell TagEditor which content in the XML file is translatable and which isn't.
This process may be very simple but also quite complicated, so there is no universal process description. I therefore suggest that you read the documentation supplied with T2007.


Hi Stanislav,

Many thanks. The client has provided the INI file, but when I open it, this error appears:

"The DOCTYPE declarations/root elements from the document and the currently selected tag settings file do not match. Would you like to use this setting file anyway?"

What do you advise please?


Direct link Reply with quote
 

Tomás Cano Binder, BA, CT  Identity Verified
Spain
Local time: 10:17
Member (2005)
English to Spanish
+ ...
Quite simple Mar 9, 2011

The best you can do is first add the INI file to your list of document definitions in the Workbench. You simply do the following:

1. Run Translator's Workbench.
2. Choose Options > Translation Memory Options.
3. Choose the Tools tab. Click the Tag Setting button.
4. In the Tag Setting Manager dialog box, click Open and browse for your INI file. Click Open and click OK.

This should add the INI file to the list of possible TTX files, and from now on the XML file should open nicely in TagEditor without the error message.

If you expect to translate this kind of files regularly for your customer, may I suggest that you place the INI file in some place where it stays along time (and not with the project itself). Maybe you have a separate, fixed directory in which you put the customer's translation memory. There would be a good place for the INI files you receive from them.

I say so because Trados will use the INI file only if it finds it next time you open a similar XML file for the same customer. If you put the INI file with the XML file and rename/move the folder, Trados' link to the file is lost and you have to repeat the above steps again. Not very practical...

Good luck!


Direct link Reply with quote
 

Stanislav Pokorny  Identity Verified
Czech Republic
Local time: 10:17
English to Czech
+ ...
A question Mar 9, 2011

Hello Farzad,
did you select the INI file provided by your client to open the XML? If you did and if you still receive this message, you should inform your client and request him/her to update the INI file accordingly.


Direct link Reply with quote
 

Farzad Akmali  Identity Verified
Member
English to Farsi (Persian)
+ ...
TOPIC STARTER
The error message remains! Mar 9, 2011

Tomás Cano Binder, CT wrote:

The best you can do is first add the INI file to your list of document definitions in the Workbench. You simply do the following:

1. Run Translator's Workbench.
2. Choose Options > Translation Memory Options.
3. Choose the Tools tab. Click the Tag Setting button.
4. In the Tag Setting Manager dialog box, click Open and browse for your INI file. Click Open and click OK.

This should add the INI file to the list of possible TTX files, and from now on the XML file should open nicely in TagEditor without the error message.

If you expect to translate this kind of files regularly for your customer, may I suggest that you place the INI file in some place where it stays along time (and not with the project itself). Maybe you have a separate, fixed directory in which you put the customer's translation memory. There would be a good place for the INI files you receive from them.

I say so because Trados will use the INI file only if it finds it next time you open a similar XML file for the same customer. If you put the INI file with the XML file and rename/move the folder, Trados' link to the file is lost and you have to repeat the above steps again. Not very practical...

Good luck!


Thanks so much. I did as you advised, but the same error message appeared again.


Direct link Reply with quote
 

Tomás Cano Binder, BA, CT  Identity Verified
Spain
Local time: 10:17
Member (2005)
English to Spanish
+ ...
Check with the customer Mar 9, 2011

Farzad Akmali wrote:
Thanks so much. I did as you advised, but the same error message appeared again.

This leads me to think that the INI file is not the right one for your XML file. Maybe you want to check with the customer just to be sure. Maybe the customer made a mistake and sent you a wrong INI... If they say that it is the right one, then go ahead and create the TTX file with that INI file despite the error.


Direct link Reply with quote
 


To report site rules violations or get help, contact a site moderator:


You can also contact site staff by submitting a support request »

Converting XML file into TTX - help needed

Advanced search







Wordfast Pro
Translation Memory Software for Any Platform

Exclusive discount for ProZ.com users! Save over 13% when purchasing Wordfast Pro through ProZ.com. Wordfast is the world's #1 provider of platform-independent Translation Memory software. Consistently ranked the most user-friendly and highest value

More info »
memoQ translator pro
Kilgray's memoQ is the world's fastest developing integrated localization & translation environment rendering you more productive and efficient.

With our advanced file filters, unlimited language and advanced file support, memoQ translator pro has been designed for translators and reviewers who work on their own, with other translators or in team-based translation projects.

More info »



Forums
  • All of ProZ.com
  • Term search
  • Jobs
  • Forums
  • Multiple search