Multiterm 2007 suddenly inserts extra space between terms in Word!
Thread poster: Susanne Lomander

Susanne Lomander  Identity Verified
Sweden
Local time: 06:46
Swedish to English
+ ...
Mar 18, 2011

Been having problems with Multiterm, which suddenly has started inserting a double space instead of a single space between the words in terms I insert into the Word document (even though there is just a single space in the actual MT termbase).

I am currently using Freelance 2007 Workbench 8.2.0.835 and + MT 2007 7.5.0.444, working with WB and Word 2000. Everything was working fine until yesterday, and suddenly it will insert two blank spaces instead of one when I use Get term or shortcuts.

Example:
Term: a touch of class = a touch of class

The only thing I have changed was to export an old termbase, save the termbase definition, create a new database using that TB definition and re-import all the terms (I did this because for some reason, my modifications of the TBdefinition weren't being implemented when it came to one of the picklist fields). These modifications WERE implemented in the new database, but ever since I did that, things have been going crazy (with Visual basic errors 91 etc.).

I recreated a new termbase and now WB doesn't crash and Word can insert terms into MT as before, BUT.... when I get terms and insert them into Word, I now get two blank spaces between each word in the term instead of one!

Any ideas on what causes this and how to fix it? Am so frustrated, because I have 576 terms in my termbase, most of them containing multiple words... and the project is 100,000+ words! I just can't face having to manually remove doublespacing in hundreds of documents...!!icon_frown.gif

Please help a desperate colleague in need..

Susanne


 

Susanne Lomander  Identity Verified
Sweden
Local time: 06:46
Swedish to English
+ ...
TOPIC STARTER
Problem solved - it was a WB style sheet issue Mar 18, 2011

I managed to solve the problem, which was somehow caused by the fonts used by Workbench and Word when applying them to the target TU.

I ended up exporting all my TUs from the old TMW, deleting everything between the Stylesheet and Font table (I used Word to open the textfile), fixing any unnecessary double spacing in the textfile, creating a new TMW and importing it all back into the new TM.

Now it works like a charm!

So I guess MT wasn't the culprit - the fonts/stylesheets in WB and Word somehow messed it up.

Hope this helps someone else in the future!icon_smile.gif


 


To report site rules violations or get help, contact a site moderator:


You can also contact site staff by submitting a support request »

Multiterm 2007 suddenly inserts extra space between terms in Word!

Advanced search







TM-Town
Manage your TMs and Terms ... and boost your translation business

Are you ready for something fresh in the industry? TM-Town is a unique new site for you -- the freelance translator -- to store, manage and share translation memories (TMs) and glossaries...and potentially meet new clients on the basis of your prior work.

More info »
Déjà Vu X3
Try it, Love it

Find out why Déjà Vu is today the most flexible, customizable and user-friendly tool on the market. See the brand new features in action: *Completely redesigned user interface *Live Preview *Inline spell checking *Inline

More info »



Forums
  • All of ProZ.com
  • Term search
  • Jobs
  • Forums
  • Multiple search