Studio 2009 error message : Index was out of range.
Thread poster: Pierre-Olivier Vilain

Pierre-Olivier Vilain  Identity Verified
France
Local time: 11:26
English to French
+ ...
Mar 23, 2011

Hello,

Using Trados 2009, I am having some trouble to save the Word 2007 file I am translating back to Word 2007.
It worked when I did it yesterday but today this message appears :
“Studio error message : Index was out of range. Must be non-negative and less than the size of the collection. Parameter name: index”.
I tried to find a solution on Internet and tried to change various settings on my translation file without any success.

Could anyone help?

Thanks


Direct link Reply with quote
 

Jerzy Czopik  Identity Verified
Germany
Local time: 11:26
Member (2003)
Polish to German
+ ...
Does the message appear all the time? Mar 23, 2011

Or just for a particular segment?
If only for one segment, enter the translation there and don't bother that much, AFAIK there is no real solution for that.
Othewise I am sorry, but I don't know what to do.


Direct link Reply with quote
 

Pierre-Olivier Vilain  Identity Verified
France
Local time: 11:26
English to French
+ ...
TOPIC STARTER
just when I want to save the document as target... Mar 23, 2011

... it does not appear during the translation process. I can translate any unit without any error message.
I cannot see the result of my translation in Word and cannot save it.


Direct link Reply with quote
 

Jerzy Czopik  Identity Verified
Germany
Local time: 11:26
Member (2003)
Polish to German
+ ...
Did you test the file before? Mar 23, 2011

Before you started to translate the file did you attempt to save the target text from untranslated file?
If yes and it worked, the error resulted during the translation. However, if the error where there before, the Word file itself is guilty. In that case opening the file with Open&Repari in Word could help before you retranslate it from TM.

Did you restart Studio/PC in the meantime, after getting this error message?


Direct link Reply with quote
 

Pierre-Olivier Vilain  Identity Verified
France
Local time: 11:26
English to French
+ ...
TOPIC STARTER
I did test the file before Mar 23, 2011

There was no problem to save the target text. I also had do save it to send the first half of my translation to the client and there was no problem.

I restarted Studio/PC in the meantime, after getting this error message and I still get it when I try to save the target text.

There is nothing particular (tags, etc) missing form the source text on the target text, enerything semme to be fine until I try to save the target text.

Thanks for your help Jerzy.


Direct link Reply with quote
 

Jerzy Czopik  Identity Verified
Germany
Local time: 11:26
Member (2003)
Polish to German
+ ...
Strange and... Mar 23, 2011

sorry, but I seem not to have any solution for this other than to try to translate a different version of your text (i.e. Word 2007 instead of Word 2003 or so).

Direct link Reply with quote
 

Pierre-Olivier Vilain  Identity Verified
France
Local time: 11:26
English to French
+ ...
TOPIC STARTER
process that worked for me Mar 31, 2011

Hello,

For those that could find it useful, this is how I "solved" the problem:

- finish the translation and keep updatig the TM;
- open the source document in another version of Word and delete the automatic summary the original version contained;
- open the new Word document with Trados using the the TM of the previous translation;
- fill all the translation units with what the TM offers and make sure there is no tag missing.

I had to follow this process twice as the message “Studio error message : Index was out of range. Must be non-negative and less than the size of the collection. Parameter name: index” appeared again when I tried for the first time. Fortunately, I was abble to open and save the target document in Word the second time.

However, I still do not know what was wrong but this process proved to be worth trying.


Direct link Reply with quote
 


To report site rules violations or get help, contact a site moderator:


You can also contact site staff by submitting a support request »

Studio 2009 error message : Index was out of range.

Advanced search







PerfectIt consistency checker
Faster Checking, Greater Accuracy

PerfectIt helps deliver error-free documents. It improves consistency, ensures quality and helps to enforce style guides. It’s a powerful tool for pro users, and comes with the assurance of a 30-day money back guarantee.

More info »
TM-Town
Manage your TMs and Terms ... and boost your translation business

Are you ready for something fresh in the industry? TM-Town is a unique new site for you -- the freelance translator -- to store, manage and share translation memories (TMs) and glossaries...and potentially meet new clients on the basis of your prior work.

More info »



Forums
  • All of ProZ.com
  • Term search
  • Jobs
  • Forums
  • Multiple search