Fatal error in Java Runtime Environment causes SDL XLIFF Validation Error
Thread poster: Pavel Tsvetkov

Pavel Tsvetkov  Identity Verified
Bulgaria
Local time: 07:43
Member (2008)
English to Bulgarian
+ ...

MODERATOR
May 12, 2011

Dear All,

I was working happily on a large (and urgent) translation project for one of my clients I would hate to disappoint, when suddenly Studio 2009 crashed, as a result of this error:

******************************************************************************

#
# A fatal error has been detected by the Java Runtime Environment:
#
# Internal Error (0xc015000f), pid=5528, tid=5112
#
# JRE version: 6.0_14-b08
# Java VM: Java HotSpot(TM) Client VM (14.0-b16 mixed mode, sharing windows-x86 )
# Problematic frame:
# C [ntdll.dll+0x4487f]
#
# If you would like to submit a bug report, please visit:
# http://java.sun.com/webapps/bugreport/crash.jsp
# The crash happened outside the Java Virtual Machine in native code.
# See problematic frame for where to report the bug.
#

--------------- T H R E A D ---------------

Current thread (0x11787c00): JavaThread "main" [_thread_in_native, id=5112, stack(0x00030000,0x00130000)]

siginfo: ExceptionCode=0xc015000f, ExceptionInformation=0x00000002 0x0012b8f8 0x05004be0

Registers:
EAX=0x0012b880, EBX=0x00000002, ECX=0x7c91d4fd, EDX=0x7c90e514
ESP=0x0012b874, EBP=0x0012b8d4, ESI=0x0012b8f8, EDI=0x05004bb0
EIP=0x7c94487f, EFLAGS=0x00000246

Top of Stack: (sp=0x0012b874)
0x0012b874: 00000000 0012b904 16ed0d90 c015000f
0x0012b884: 00000000 00000000 7c94487f 00000003
0x0012b894: 00000002 0012b8f8 05004be0 7e418734
0x0012b8a4: 00000000 00000401 164f4460 00000000
0x0012b8b4: 16ed0d90 dcbaabcd 00000000 0012b904
0x0012b8c4: 16ed0d90 0012b930 7e418bd9 7ffde000
0x0012b8d4: 0012b930 7e41885a 05004bb0 7e418822
0x0012b8e4: 0012b9c0 0012b9b8 0072c340 00000014

Instructions: (pc=0x7c94487f)
0x7c94486f: c7 45 b0 01 00 00 00 8d 45 ac 50 e8 a9 9c fc ff
0x7c94487f: 8b 45 fc 5b e9 80 b6 fc ff 52 74 6c 44 65 61 63

[...] etc. - Anyone feeling they need more detail - I can send you the error report file. www.proz.com does not allow for forum posts of such excessive length.

--------------- S Y S T E M ---------------

OS: Windows XP Build 2600 Service Pack 3

CPU:total 2 (2 cores per cpu, 1 threads per core) family 6 model 23 stepping 10, cmov, cx8, fxsr, mmx, sse, sse2, sse3, ssse3, sse4.1

Memory: 4k page, physical 2097151k(1270920k free), swap 4194303k(2693504k free)

vm_info: Java HotSpot(TM) Client VM (14.0-b16) for windows-x86 JRE (1.6.0_14-b08), built on May 21 2009 08:03:56 by "java_re" with MS VC++ 7.1

time: Wed May 11 10:31:49 2011
elapsed time: 17317 seconds

****************************************************************************

... and when I restarted Studio and tried to continue my work, I got the following (rather general-sounding, but nevertheless dreadful) error message:



> CLICK ON THE IMAGE TO MAKE IT LARGER <

The result was that I could not create the target translation anymore and my blood ran cold.

Now, I tried to start from scratch:

1. Renamed a copy of the original file to be translated.
2. Added it to the list of files to be translated.
3. Ran the 'Prepare' batch task on it
4. ... hoped for the best, but alas!

The segment I was working on when the crash happened has somehow corrupted the project TM, or sth else has went wild, but I got the same error message for my second try as well.

I tried for the third time. This time I first went back to the original file, remembered which segment I had been working on when the crashed appeared, substituted the translated part for some random text (actually, I just input '1' there instead of the whole paragraph), pressed Ctrl+Enter, then saved and closed the file and repeated steps 1-4 from above with a different (renamed) version of the original file.

This did it!

Now, I have several questions to SDL:

1). Having a bad history of about 4-5 or more years of continuous problems with Java, isn't it time to start using something else, or finally start programming in such a way, so that simple freelancers like myself can simply work with their very expensive Trados software and not get error messages all the time, and I mean errors threatening to destroy days of work and possibly cost me a loyal customer?
2). If an xliff has become corrupted, because of Trados's inability to properly manage its own components, isn't there a way to avoid this messing up the whole translation process, thwart translation export, etc. No, really, think of something. I am not a programmer and I do not need to get messages like: "The key sequence fails to refer to some key." As far as I - or my customer is concerned - this means nothing and seeing it means nothing.

I hope this post helps translators running into the same problem in the future.

I also hope an SDL representative can come forward and explain what they were thinking when creating and updating Studio 2009 (and more specifically Multiterm), and when putting together their mystic and dreadful error messages.

Kind regards,
Pavel


Direct link Reply with quote
 

Chunyi Chen
United States
Local time: 21:43
English to Chinese
I can't agree more May 13, 2011

Hi Pavel,

I fully agree with what you said that Studio should make their products more user friendly and less error-prone. I have had a few setbacks recently with Studio and Multiterm SP4 and at the moment I am not a happy user.
I was working on a project in Studio yesterday and right before the deadline I discovered Studio was only able to convert 1/5 of the SDLXLIFF file to the original doc format, with the rest of the text still in source text. I had to deliver the file in bilingual format as a temporary solution. (Fortunately SDLXLIFF Converter was still working!)
Although this problem has been solved this morning by the SDL Support (I do have a support contract with them), the whole experience is scary. Simply put, I need a reliable tool that does what it's supposed to do without worrying about something going wrong at the last minute.

Chun-yi


Direct link Reply with quote
 

Alex Lilo
Ukraine
Local time: 07:43
English to Russian
+ ...
continuous java problems + a new issue every now and then Oct 20, 2011

Pavel,
very good description. I have kept both Studio and Multiterm 2009 up-to-date, but none of the updates, fixes or patches have solved the problem. I keep getting this error at least 7 times a day, esp. on large projects. I saw your post because I got this problem 5 times today (5 hs_err log files on my desktop already) and was looking to see if there was any solution available. this is probably one of the two main reasons that make me a very unhappy sdl user (not for long though. bought another cat tool and waiting to have some free time to migrate. the other reason I am not happy is because I often have to spend additional hours trying to export translations back to their original formats.). sdl support is useless and extremely slow to respond. issues remain unsolved for months.

Chun-yi, I got the same problem several times. Fairly basic (typed, non OCR, text in Word doc (93-2003)), but it did contain a few page breaks and a few small charts. (later I removed the page breaks but I needed the charts, tried again and same result.) Studio exported at least five of such files with only the first page or first two pages translated. I did not have the time to look for a solution, so had to quickly finish it by copying and pasting manually. Never heard from the support and still don't know how to fix it, except that now I think the best way is get over it and start a new life with a cat tool that does not glitch every step of the way.


[Edited at 2011-10-20 16:01 GMT]


Direct link Reply with quote
 

Alex Lilo
Ukraine
Local time: 07:43
English to Russian
+ ...
another java problem Oct 20, 2011

My Studio crashes when I add a term within Studio. I tried the steps below but still have the same problem.

This behavior is caused by a versioning issue with Java on your machine.
Resolution

The first thing to try is to run the MultiTerm repair tool you can find in KB article #3420.

If this does not resolve the freeze problem, or if the problem comes back after a while, you need to uninstall your current versions of Java and only re-install the one that is shipped with SDL MultiTerm 2009, which is JRE1.6.0_14.

Go to Start > Control Panel > Add or Remove Programs.
Find the Java versions currently installed on your machine.
Uninstall all versions.
Reboot your machine.
Go to the folder where the SDL MultiTerm 2009 installer is stored, by default: C:\Program Files\SDL\Installers\SDLMultiTerm2009SP3.
In the directory modules you find the following file: jre-6u14-windows-i586.exe.
If you have Windows XP, just double-click on the file to run the installer. If you have Windows Vista or Windows 7, right-click on the file and select Run as administrator from the short-menu.


Direct link Reply with quote
 


To report site rules violations or get help, contact a site moderator:


You can also contact site staff by submitting a support request »

Fatal error in Java Runtime Environment causes SDL XLIFF Validation Error

Advanced search







memoQ translator pro
Kilgray's memoQ is the world's fastest developing integrated localization & translation environment rendering you more productive and efficient.

With our advanced file filters, unlimited language and advanced file support, memoQ translator pro has been designed for translators and reviewers who work on their own, with other translators or in team-based translation projects.

More info »
PerfectIt consistency checker
Faster Checking, Greater Accuracy

PerfectIt helps deliver error-free documents. It improves consistency, ensures quality and helps to enforce style guides. It’s a powerful tool for pro users, and comes with the assurance of a 30-day money back guarantee.

More info »



Forums
  • All of ProZ.com
  • Term search
  • Jobs
  • Forums
  • Multiple search