SDL Trados Suite 2009 "Confirm and open next segment" function skips segment if 100% match available
Thread poster: richard_l (X)

richard_l (X)
German to English
May 25, 2011

In the editor there are two options for confirming a segment and moving on:

- Confirm and go to next non-confimed segment (Alt+Add)

or

- Confirm and go to next segment (Alt+Enter)

However, I find that if there is a 100% match available for the next (and all subsequent) segments, and I select the second option (Alt+Enter), the editor skips through all the segments (with a 100% match) and goes directly to the next non-confirmed segment.

This is rather enfuriating as I wish to review all 100% matches as they are inserted. I want to open the next segment as the description promises and I want my cursor to stay there! Effectively I may as well be using the first option (Alt+Add) as the result is always the same.

Is there a setting I have missed which could prevent this "skipping" of segments and allow me to genuinely open the "next segment" and stay on it?


 

David Russi  Identity Verified
United States
Local time: 23:35
English to Spanish
+ ...
Try Tools > Options > Editor > Auto-propagation May 25, 2011

See if changing some of these options alters the behavior.

 

richard_l (X)
German to English
TOPIC STARTER
Thanks for the suggestion May 26, 2011

David Russi wrote:

See if changing some of these options alters the behavior.


Thanks for the suggestion but I tried every conceivable auto-propagation setting and none affects this particular problem.


 

Walter Blaser  Identity Verified
Switzerland
Local time: 07:35
French to German
+ ...
CTRL-Enter goes to the next non 100% match May 26, 2011

This is the default behavior. When you confirm a segment in Studio, your cursor dos not move to the next segment but to the next non 100% match. The shortcut to move to the next segment is ALT-CTR-Enter.

You can change this by going to 'Tools -< Options -> Keyboard shortcuts' and exchanging the two shortcuts if you prefer that CTRL-Enrter always goes to the next segment, regardless of whether it is a 100% match or not.

I just realize that you mentioned the old shortcuts from 2007 in your post. This means that you have probably selected the 'SDL Trados' user profile when you first launched Studio.

Personally, I recommend not to use this because the new keyboard shortcuts are much better than the ones from the 2007 version, mainly because they are shorter and do not require a numeric keypad, which is always a problem when you are working on a notebook without numeric keypad.

You can change the user profile by going to 'Tools - Manage User Profile'. Select the 'Standard' profile.

Walter


 

Walter Blaser  Identity Verified
Switzerland
Local time: 07:35
French to German
+ ...
Not related to Autopropagation May 26, 2011

David Russi wrote:

See if changing some of these options alters the behavior.


Richard's problem has nothing to do with 'Autopropagation', but with the keyboard shortcut assignments. See my answer to the post.

Walter

[Bearbeitet am 2011-05-26 10:33 GMT]


 

richard_l (X)
German to English
TOPIC STARTER
Thanks, Walter, still not the answer May 26, 2011

Thanks, Walter but I'm afraid that's not the solution. The shortcuts and my personal settings are irrelevant.
There are two options for confirming a segment. The one I want to activate does not work. This is regardless of whether I use a short cut or the softkey within the software.

Further note:
This problem is (half) solved if the document is pre-translated, i.e. if the segment target is already filled with the 100% match from the TM, the cursor moves to the next segment and stays there.
The problem arises when I am translating a document which is not pre-translated. I select "go to next segment" and the editor immediately inserts the respective 100% match and passes directly to the next non-confirmed segment.

Pre-translating all documents is a solution but it's a compromise solution.
I would really like the command to "do what it says on the tin" regardless of whether the document is pre-translated or not as was the case in all former versions of Trados.


 

David Russi  Identity Verified
United States
Local time: 23:35
English to Spanish
+ ...
Just bad behavior May 26, 2011

Walter Blaser wrote:

David Russi wrote:

See if changing some of these options alters the behavior.


Richard's problem has nothing to do with 'Autopropagation', but with the keyboard shortcut assignments. See my answer to the post.

Walter

[Bearbeitet am 2011-05-26 10:33 GMT]


Actually, it has nothing to do with shortcuts, it's just another bad behavior in poorly designed software.

[Edited at 2011-05-26 20:29 GMT]


 

Walter Blaser  Identity Verified
Switzerland
Local time: 07:35
French to German
+ ...
What do you want, really May 26, 2011

richard_l wrote:

Thanks, Walter but I'm afraid that's not the solution. The shortcuts and my personal settings are irrelevant.
There are two options for confirming a segment. The one I want to activate does not work. This is regardless of whether I use a short cut or the softkey within the software.

Further note:
This problem is (half) solved if the document is pre-translated, i.e. if the segment target is already filled with the 100% match from the TM, the cursor moves to the next segment and stays there.
The problem arises when I am translating a document which is not pre-translated. I select "go to next segment" and the editor immediately inserts the respective 100% match and passes directly to the next non-confirmed segment.

Pre-translating all documents is a solution but it's a compromise solution.



I am not sure I understand what you are expecting. You mention "pretranslated" and "not pretranslated" documents, but in Studio ANY document that you open is pretranslated because this is done automatically in Studio whenever you create a project,
This means that you always deal with pretranslated documents in Studio.
I would really like the command to "do what it says on the tin" regardless of whether the document is pre-translated or not as was the case in all former versions of Trados.

Can you explain more clearly what you mean by this? What is is that you are reading on the tin?

Walter


 

George Cook
United Kingdom
Local time: 06:35
French to English
+ ...
Simple solution May 27, 2011

I may have fundamentally missed the point here, but if you want to go to the next segment, regardless of whether it is a 100% match or not, the key combination Ctrl+Alt+Enter is the one to use.

Certainly works for me!


 

richard_l (X)
German to English
TOPIC STARTER
Simple solution May 27, 2011

Thanks, George, but I'm afraid that is not the solution.

I know how to activate the function and I know how my shortcuts are set but they are irrelevant. As I said: "There are two options for confirming a segment. The one I want to activate does not work. This is regardless of whether I use a short cut or the softkey within the software."

Try the function on a document which is not pre-translated and I'm sure you'll see the cursor fly by those 100% matches.


 

Hugh Matthews  Identity Verified
Denmark
Local time: 07:35
Danish to English
+ ...
Total confusion Jun 29, 2011

Excuse me, but I don't have a brain that can deliberately search through millions of possibilities. People call me an intuitive liguist. I have ADHD.
I cannot for the life of me understand what Trados means by ALT+Add, and whereas I was happily translating using a TM for a specific client, 2009 now tells me it is using all my TMs but doesn't find segments I've already translated, and which should be in the TM I actually want to use.
I am on the verge of resorting 100&% to TagEditor in 2007 Freelance, but I'd kind of like to get my current job over and done with in 2009. It's an events callendar with lots of repetitions...

How do I get A) back to a point where I am only using one TM, and B) write what segments I have to my TM so that I don't have to cut and paste?

Ideas please.

I might not find my way back here, so please mail me on translations@hughm.dk as well.

Thanks in advance.

Hugh M


 

YELDA KAHYA  Identity Verified
Turkey
Local time: 08:35
English to Turkish
+ ...
help Mar 2, 2013

Hi I have a problem I have taken the segment into a frame such as a table row by pressing on alt+row or enter I donot know but now I cannot remove it how can I do this

 


To report site rules violations or get help, contact a site moderator:


You can also contact site staff by submitting a support request »

SDL Trados Suite 2009 "Confirm and open next segment" function skips segment if 100% match available

Advanced search







Anycount & Translation Office 3000
Translation Office 3000

Translation Office 3000 is an advanced accounting tool for freelance translators and small agencies. TO3000 easily and seamlessly integrates with the business life of professional freelance translators.

More info »
WordFinder Unlimited
For clarity and excellence

WordFinder is the leading dictionary service that gives you the words you want anywhere, anytime. Access 260+ dictionaries from the world's leading dictionary publishers in virtually any device. Find the right word anywhere, anytime - online or offline.

More info »



Forums
  • All of ProZ.com
  • Term search
  • Jobs
  • Forums
  • Multiple search