Pages in topic:   [1 2] >
Cannot update TMs in Studio 2009
Thread poster: Chris Carlisle
Chris Carlisle  Identity Verified
Local time: 11:47
Italian to English
+ ...
Jun 22, 2011

Hi

I wonder if someone can help with a teething problem I am having with Studio 2009.

When I translate in the Editor function with the relevant Project TM open in the Translation Memory section, the TM does not update as I progress through the translation, confirming each segment. The Translation memory section only says: (No translation units to display). Is this normal?

To me, this implies the TM is not being updated. However, the odd thing is that when I translated a second, similar document in Editor, it DID detect the previously translated segments.

Also, even when I do Batch Tasks > Update Project TMs, select the right TM and check the 'Update' box, it still does not update the TM.

So my questions are:

1) where are the translations being stored if not in the Project TM open in the TM box?

2) how do I change the settings so that it updates the project TM that I have selected?

Please note that I have ticked the 'Update' tick-box in the individual TM options. I also have the settings in Tools > Options set to 'Update translation memory'. So these are not the problem.

Thank you, thank you for any help you can offer.
Chris


[Edited at 2011-06-22 12:00 GMT]

[Edited at 2011-06-22 12:01 GMT]


Direct link Reply with quote
 

Emma Goldsmith  Identity Verified
Spain
Local time: 12:47
Member (2010)
Spanish to English
Small TMs won't necessarily give results. Jun 22, 2011

Chris Carlisle wrote:

The Translation memory section only says: (No translation units to display). Is this normal?



Well, it could be normal if you have just started using Studio and your TM is very small. You won't get any matches if your new files do not ressemble your previous work.
Try looking up a word that you know you have translated using concordance (F3). It should come up in the translation results window.


Direct link Reply with quote
 
Chris Carlisle  Identity Verified
Local time: 11:47
Italian to English
+ ...
TOPIC STARTER
I'm not sure... Jun 23, 2011

I don't think that is the problem. It should fill as I accept confirm segment, shouldn't it? There have been 100% repetitions.

On completing the project, the TM is also still empty.

Chris

[Edited at 2011-06-23 07:53 GMT]


Direct link Reply with quote
 
xxxStrastran
France
Local time: 12:47
French to English
+ ...
I have this problem too Jun 23, 2011

Hi Chris

I've also wondered about this. When I work in Trados Studio, the TM is never updated automatically, no matter what settings I have ticked. Even with huge TMs, where I know for a fact that a certain term is in there, no results are given.

The only way I've found to update the TM is by going into Batch Tasks and choosing 'Update MainTranslation Memories'. Selecting 'Project Translation Memories' doesn't work for me either.


Direct link Reply with quote
 
Tracey Sweeney  Identity Verified
Local time: 12:47
Spanish to English
Some settings to check Jun 23, 2011

I remember having a similar problem and I can't remember how I solved it. I remember that I had to enable an option that I thought should be enabled by default. Try doing the following and see if that helps:

1. Go to Tools
2. Select Options
3. Select Editor
4. In Automation, check that the Update translation memory option is selected.

Good luck


Direct link Reply with quote
 
Els Reynaert
Local time: 12:47
English to Dutch
+ ...
Cannot update project TM in Studio 2009 Nov 18, 2011

I'm having exactly the same problem as Chris: I've created a Project TM; whilst translating documents in the project it seems the TM is working as it proposes the earlier translated units. But when I open the TM it says "No translated units to display". I have tried with Update TM (project and main) and Populate TM, but I still have an empty TM.


Did you resolve your problem Chris and how?


[Edited at 2011-11-18 01:34 GMT]


Direct link Reply with quote
 
Chris Carlisle  Identity Verified
Local time: 11:47
Italian to English
+ ...
TOPIC STARTER
My solution Nov 18, 2011

Hello Els (and Patrick)

Yes, I did find the solution! It was a fairly obvious oversight on my part, but not helped by the design of the software.

When you open a document for translation, you get a dialogue box that asks you to select the language pair and the TM(s) you want use. You need to make sure that the 'Update' box is ticked for the appropriate TM. This is easy to overlook (and was my mistake) because the 'Update' column is on the far right-hand side and does not appear in the default display size! So you need to scroll across to the right / make the box bigger to see it. The same is true if you go to: Tools > Options > Language Pairs > Translation Memory and Automated Translation. This fixed the problem for me. Please just e-mail me if you want me to send you a screen shot.

As said above, you do also need to make sure that in Tools > Options > Editor > Automation, you have the 'Update translation memory after confirming segments manually' box ticked.

Hope this helps.

Chris



[Edited at 2011-11-18 11:05 GMT]

[Edited at 2011-11-18 11:07 GMT]

[Edited at 2011-11-18 11:07 GMT]


Direct link Reply with quote
 
Els Reynaert
Local time: 12:47
English to Dutch
+ ...
Thanks Chris Nov 21, 2011

This seems to help indeed! I found your post too late to try it out on the new project that I just finished, but I just did a little test and it seems to be working. Hopefully it will work for the next project.

Thanks!

Els


Direct link Reply with quote
 

George Cook
United Kingdom
Local time: 11:47
French to English
+ ...
Screen resolution Nov 22, 2011

Chris Carlisle wrote:

This is easy to overlook (and was my mistake) because the 'Update' column is on the far right-hand side and does not appear in the default display size! So you need to scroll across to the right / make the box bigger to see it.


Never had this problem; the box shows up just fine in the standard display size. This being the case, it's probably to do with your monitor resolution settings. Mine's set to 1680x1050, so this might explain things. Presumably if the resolution is lower, then the box gets pushed out of view.

That said, I had been under the impression that if you only add one TM to the project, the "Update" box is ticked by default. It is for me, anyway. Maybe there's a setting for that, somewhere in the impenetrable jungle of expandable menus...


Direct link Reply with quote
 
Chris Carlisle  Identity Verified
Local time: 11:47
Italian to English
+ ...
TOPIC STARTER
Screen resolution Nov 30, 2011

I disagree: there's nothing unusual about my screen resolution settings. One often has to expand/maximise windows! This is simply down to poor software design.

Direct link Reply with quote
 
XXXphxxx  Identity Verified
United Kingdom
Local time: 11:47
Portuguese to English
+ ...
Agreed Chris Nov 30, 2011

Chris Carlisle wrote:

I disagree: there's nothing unusual about my screen resolution settings. One often has to expand/maximise windows! This is simply down to poor software design.


Just seen your post, too late to help but had the same problem myself. I also have to scroll across to my 'Update' box, which seems daft for such a crucial step in the process. In fact I'm wondering in what circumstances you wouldn't want to update the TM and why it isn't ticked by default?


Direct link Reply with quote
 

tjsajja
Thailand
Local time: 18:47
English to Thai
+ ...
A solution in YouTube Dec 21, 2011

Thank Chris. Your suggestion can solve the problem.

I made a clip video for everyone in YouTube.

http://www.youtube.com/watch?v=hZqWjDAAFtY


Direct link Reply with quote
 

Hrvoje Pticar  Identity Verified
United Kingdom
Local time: 11:47
German to Croatian
+ ...
Updating just one TM doesn't work Jan 31, 2012

My problem is that I want to use 2 TMs for lookup, but update just one of them.
One would think this is achieved by ticking the "Update" box next to the TM one wants to update - WRONG. It doesn't work. If I don't tick both TMs, nothing gets updated, and the Translation Results Windows keeps showing "No matches found" when I go over segments I've already translated...
Same issue with both Studio 2009 and 2011...

Can someone please shed some light on this, it's doing my head in...


Direct link Reply with quote
 

Hrvoje Pticar  Identity Verified
United Kingdom
Local time: 11:47
German to Croatian
+ ...
after a sleepless night Feb 1, 2012

I just couldn't leave it and found out this happens if you just open documents. You don't get this problem if you create new projects.

There's obviously something wrong in Studio's prep phase when using the Open Document feature, since I do have Create Project TM in my default tasks for new projects...


Direct link Reply with quote
 

SDL Community  Identity Verified
United Kingdom
Local time: 12:47
English
Can you clarify this? Feb 1, 2012

Hrvoje Pticar wrote:

There's obviously something wrong in Studio's prep phase when using the Open Document feature, since I do have Create Project TM in my default tasks for new projects...


Hello Hrvoje,

I don't follow this one. If you use Open Document then this does not use a Project TM at all. Project TMs are only a feature of projects created using New Project, and of course this is optional.

Regards

Paul


Direct link Reply with quote
 
Pages in topic:   [1 2] >


To report site rules violations or get help, contact a site moderator:


You can also contact site staff by submitting a support request »

Cannot update TMs in Studio 2009

Advanced search







PerfectIt consistency checker
Faster Checking, Greater Accuracy

PerfectIt helps deliver error-free documents. It improves consistency, ensures quality and helps to enforce style guides. It’s a powerful tool for pro users, and comes with the assurance of a 30-day money back guarantee.

More info »
TM-Town
Manage your TMs and Terms ... and boost your translation business

Are you ready for something fresh in the industry? TM-Town is a unique new site for you -- the freelance translator -- to store, manage and share translation memories (TMs) and glossaries...and potentially meet new clients on the basis of your prior work.

More info »



Forums
  • All of ProZ.com
  • Term search
  • Jobs
  • Forums
  • Multiple search