Using Tags in Trados Studio 2009
Thread poster: sophie_jane
sophie_jane
Local time: 04:57
German to English
Jun 27, 2011

Does anyone know how to get Trados to recognise tags?
I have tags from another software that are protecting variables and I can't merge the segments as the option is greyed out.
Any ideas anyone?

e.g. my sentence which should be

Im Dialog Optionen (Anwendungsmenü>Optionen ([Alt]+[MI]) können Sie im Register Anzeige, Abschnitt Optionen für Spezifikationstexte, das Standardformat (Schriftart und -größe) für Spezifikationstexte anpassen.

Looks like this:

Im Dialog
(
([Alt]+[MI]) können Sie im Register
, Abschnitt
, das Standardformat (Schriftart und -größe) für Spezifikationstexte anpassen.

The tags are not even shown (example of one of the tags which marks a variable: ) and all of the segments are split making my translation have to look like this:

You can use the dialog (
([Alt]+[MI]) to customize the default format (font and size) for specification texts in the
tab in the section
to customize the default format (font and size) for specification texts.

This then means that the wrong translations are getting saved for the wrong segments.


Direct link Reply with quote
 

Jerzy Czopik  Identity Verified
Germany
Local time: 04:57
Member (2003)
Polish to German
+ ...
What was the source format? Jun 27, 2011

Looks like the file definition has not been designed properly.

Direct link Reply with quote
 
sophie_jane
Local time: 04:57
German to English
TOPIC STARTER
Parser rules Jun 28, 2011

I added parser rules that Trados should recognise the tags but it doesn't seem to work.
I am using MadCap files (htm. files) if that is any help?


Direct link Reply with quote
 

Jerzy Czopik  Identity Verified
Germany
Local time: 04:57
Member (2003)
Polish to German
+ ...
HTM is standard format Jun 28, 2011

Did you try using the standard html file type in Studio?
If not, how did you add the parser rules. How are the tags in question defined in the rule?
As external or internal tags?


Direct link Reply with quote
 
sophie_jane
Local time: 04:57
German to English
TOPIC STARTER
Own file type Jun 29, 2011

Hi,

I made a copy of the Trados html file type and added extra things to the set-up so that all the parser rules from the standard html files are included.
The funny thing about the tags is that you can't actually see them in Trados when you open a translation. They are hidden and just split the segment when one occurs.
An example of the tag:
[]


Direct link Reply with quote
 

Jerzy Czopik  Identity Verified
Germany
Local time: 04:57
Member (2003)
Polish to German
+ ...
Tag types Jun 29, 2011

sophie_jane wrote:

Hi,

I made a copy of the Trados html file type and added extra things to the set-up so that all the parser rules from the standard html files are included.
The funny thing about the tags is that you can't actually see them in Trados when you open a translation. They are hidden and just split the segment when one occurs.
An example of the tag:
[<MadCap:variable name="UIVar_Dlg.DlgBtnOK" />]


Can you check, how the tag definition for <MadCap:variable name="UIVar_Dlg.DlgBtnOK" /> is? Is it defined as inline tag?


Direct link Reply with quote
 
sophie_jane
Local time: 04:57
German to English
TOPIC STARTER
Inline Jun 29, 2011

The Rule is as follows:

Rule type: XPath
Rule/XPath: //MadCap:variable
Properties/Translate: Translatable (but not in protected content)
Tag type: inline
Whitespace: Inherit from Parent

Any ideas?


Direct link Reply with quote
 

Jerzy Czopik  Identity Verified
Germany
Local time: 04:57
Member (2003)
Polish to German
+ ...
No, sorry - not for the parser rule Jun 29, 2011

But you could fool the rule by placing a non-breaking spaces before and after such tags in your source tags. At least this is what I've done in similar situation.

What would happen, if you build an INI for TagEditor in similar way and open the file there? Are the tags then separated too, if you run a segmentation with Workbench by translating the file with an empty TM and the option "segment unknown sentences" activated? Should that work, you can easily open the ttx in Studio, remove all content from target and translate.


Direct link Reply with quote
 
sophie_jane
Local time: 04:57
German to English
TOPIC STARTER
Thanks for the suggestions Jun 29, 2011

I can't believe that it's not possible for Trados Studio to recognise these rules. There must be a simpler way than doctering the source files.
I'm translating an entire online help and most of the files are like this - that would basically double my workload having to modify the files beforehand.
It is also an ongoing work process, as when changes are made to the source online help, I will then need to update the target help. This would then involve modifying the files again.


Direct link Reply with quote
 

Jerzy Czopik  Identity Verified
Germany
Local time: 04:57
Member (2003)
Polish to German
+ ...
Try the workflow via Trados 2007 Jun 29, 2011

This can be a quite reasonable and fast way round this.
As for the parser rules - there must be a different setting I am unfortunately not aware of.
Without having the possibility to test I can't tell you more.


Direct link Reply with quote
 

Sandra Garcia
United States
Local time: 19:57
English to Spanish
Parser rule - Correct settings Dec 2, 2011

Hi Sophie,

I was having the same problem and, although this reply might come a bit too late for you, I thought I'd post it anyway in case it can help you or any other users in the future.

I edited the parsing rule settings as follows:

Rule type: XPath
Rule/XPath: //MadCap:variable
Properties/Translate: Always translatable
Tag type: inline
Whitespace: Inherit from Parent

Also, in the Advanced settings dialog, I checked the option Text lines can be wrapped after the tag, and selected the Segmentation hint Include with text.

Now, I can actually see the tags in the Editor and the lines aren't breaking anymore every time the sentence includes a MadCap:variable.

Hope it helps,
Sandra García.


Direct link Reply with quote
 


To report site rules violations or get help, contact a site moderator:


You can also contact site staff by submitting a support request »

Using Tags in Trados Studio 2009

Advanced search







SDL MultiTerm 2017
Guarantee a unified, consistent and high-quality translation with terminology software by the industry leaders.

SDL MultiTerm 2017 allows translators to create one central location to store and manage multilingual terminology, and with SDL MultiTerm Extract 2017 you can automatically create term lists from your existing documentation to save time.

More info »
SDL Trados Studio 2017 Freelance
The leading translation software used by over 250,000 translators.

SDL Trados Studio 2017 helps translators increase translation productivity whilst ensuring quality. Combining translation memory, terminology management and machine translation in one simple and easy-to-use environment.

More info »



Forums
  • All of ProZ.com
  • Term search
  • Jobs
  • Forums
  • Multiple search