Studio SP3 doesn't show some 100% matches
Thread poster: Jacques DP

Jacques DP  Identity Verified
Switzerland
Local time: 05:39
Member (2003)
English to French
Jul 15, 2011

Hello,

Here is what I am exactly doing right now: I am translating a segment, then hit Alt-Add. The cursor moves to a new segment, with empty target. The TM window says: "No matches found." Now I select the whole source segment, and hit F3. Surprise: the TM window now shows a 100% match (this match is not a segment I translated previously in this project by the way, it is dated 2009).

I am using one large TM (31K TUs), and a project TM that was generated by Studio. If I go to Project Settings and look at the Translation Memory options, I see my large TM, with Enabled, Lookup, Concordance, but not Update, and under it (both vertically and structurally), what seems to be the project TM, with the project name followed by the big TM name, and which is Enabled. Check boxes for other options don't appear.

Please advise.


Direct link Reply with quote
 

Natalie  Identity Verified
Poland
Local time: 05:39
Member (2002)
English to Russian
+ ...

Moderator of this forum
Hi Jaques Jul 15, 2011

Please try to remove the TM in the project settings and to add it once again.

Natalia



[Edited at 2011-07-15 20:04 GMT]


Direct link Reply with quote
 
MikeTrans
Germany
Local time: 05:39
Italian to German
+ ...
An old issue not resolved Jul 15, 2011

Hi Jaques,

please feadback if the proposition of Natalie has worked. I've spent much time searching in the forums, but it seems that even the most veterans of Trados didn't find a solution yet and all related posts always ended in ...nothing.
In my case, simply removing/re-adding the TMs and even making a new project from sratch after deleting all Project TMs hasn't worked, still 100% *may* be ignored, I mean: some of them will show, some will not.

Note: Your main TM being set to "update" or not is not important, as anything you translate goes in the Project TM first. Only if you finalize you'll be asked to update (or not) your main TM.
What's however important is to set the project settings in a way to update your Project TM as you translate (after CTRL-ENTER). If you don't do this, you will not retrieve any *new* 100%.

Thanks,
Mike


[Edited at 2011-07-15 20:13 GMT]


Direct link Reply with quote
 

Giles Watson  Identity Verified
Italy
Local time: 05:39
Italian to English
Ignore project TM when preparing your document Jul 15, 2011

You could try preparing your documents without the project TM. That way, confirmed segments should go straight to the main TM you have assigned to the project and be available immediately.

I add attribute values to my main TMs after each job, filtering the relevant segments by date, so if there is anything confirmed that I decide I don't want, I can eliminate or correct it at that stage.


Direct link Reply with quote
 

SDL Community  Identity Verified
United Kingdom
Local time: 05:39
English
Not necessarily an old issue.... etc Jul 15, 2011

Hi Jacques,

Concordance and TM lookup are two different things and work in different ways. It is not unusual in this forum to see a thread like this and I have yet to see one that could be substantiated. I don't mean that to sound arrogant... but this has been my experience so far and I have looked at a few.

If you can share a Project with me and give the steps to reproduce what you get I would be happy to take a look at this?

Regards

Paul


Direct link Reply with quote
 
MikeTrans
Germany
Local time: 05:39
Italian to German
+ ...
@Paul Jul 15, 2011

Dear Paul,
I highly appreciate your intensive help for the Trados Support, but I must say here that I've heard this exact reply of you in at least 3 different topics of the same problem: there all were 3 sides long involving the very best Trados users and as I said above: All this has lead to ... nothing as for resolving this matter (or the solution has not been posted, what I will not believe).

The problem of Jacques (and mine) is not the Concordance, but the Exact Matches not showing up. There is no Concordance involved in this problem, even if Jacques makes usage of it in order to show what's wrong. These are just apples and pears.

BTW, always asking to send the TM surely helps to keep problems confidential, but don't resolve harassed discussions in the past or in the very present.

It would be very nice from your part, or from SDL, to make an entry in the KB that this problem is unresolved yet, so that we all can all turn the page. As serious software users, we accept that not every aspect may work 100%, and this may just turn to be another one. And that's OK.

If this was not a problem at all, I'd be always happy to hear a clear procedure description, but I sincerly doubt there is such a one.

Greets,
Mike


[Edited at 2011-07-15 22:10 GMT]


Direct link Reply with quote
 

Jacques DP  Identity Verified
Switzerland
Local time: 05:39
Member (2003)
English to French
TOPIC STARTER
Removing and restoring TM Jul 16, 2011

I wanted to try Natalia's suggestion, so I went in project settings, and removed the large TM (see previous posts). That also removed the project TM since it is structurally below the large TM (whatever that means). Then I tried to add the large TM. It was added, but without the project TM this time. Then I added the project TM which I found in the project folder. Then clicked OK and got and Error message: "Index was out of range. Must be non-negative and less than the size of the collection.
Parameter name: index". Should I proceed in another way? (I've switched to Studio only recently, so I am not necessarily familiar with all its aspects.)

I ignored the error and went back in Editor. This time the 100% match showed. Let's hope it stays that way and that the error reported was not serious. I wonder if after adding the TM in this way it will update the main TM correctly when finalizing the project.


Direct link Reply with quote
 
MikeTrans
Germany
Local time: 05:39
Italian to German
+ ...
@Jacques Jul 16, 2011

Hi Jacques,
thanks very much to take the time. I will try to reproduce that. If I see that all my 100% will show, I'll post a topic with the mention [WORKAROUND]. Alas, such a "dance" will have to be done everytime after creating a project; still this procedure may be worthwile in a large multi-file project.

Important:
Anyone who plans to use Studio 2011 should not bother with all this, because this problem may just become obsolete.

Mike

[Edited at 2011-07-16 14:10 GMT]


Direct link Reply with quote
 

SDL Community  Identity Verified
United Kingdom
Local time: 05:39
English
Can we try to look at this in the forum? Jul 16, 2011

Hi Mike,

I am perfectly happy to do this in the forum and if there is a real problem we need to fix then we will do so.

I am referring to the concordance issue, and where users have given me data after we discussed in this forum this was the problem we discussed. Concordance was used to describe their opinion that a 100% match should have been there, where in fact it should not because it was a concordance 100% and not a TM lookup.

If Jacques stated that he confirmed the segment and then the next segment where he used concordance was actually the same as the previous one then I did not understand that from what was written... and still don't.

A picture really does paint a thousant words, and when I have the project on my machine I can see it properly, but I'm happy to do this in the forum with plenty of pictures and step by step instructions if you can repro and are happy to share what you see?

Regards

Paul


Direct link Reply with quote
 
MikeTrans
Germany
Local time: 05:39
Italian to German
+ ...
I will be glad to help Jul 17, 2011

Hi Paul,

I'll be happy to help in this matter. If any, there can only be a workaround for this problem like a possible one forwarded by Jacques which I will check by reproducing it.
As for solving, this problem should be sent to the developing department of SDL as they have the only competence.

Just to show you how "critical" this issue is, consider the following:

If I work on a project with a lot of files, not retrieving my past 100% matches is annoying, but I still can proceed working.
If a client asks me 1 week later to update one of these files, not all Exact Matches showing up is a situation where I *cannot* go on working reasonably: I have to assume that what's not showing up will have to be updated, making me eventually work twice.
I hope you are a translator, otherwise please do a little inquiry to confirm that.

About Concordance:
Paul, it's very simple: if I switch off Concordance the problem still remains. Forget about Concordance and read the title of Jacques' first post.

For technical and licensing reasons I will not be able to use Studio until middle of next week, but I will give an indepth look at Jacques last steps, also considering the different scenarios a possible content can be imported into a TM which may cause the trouble (importing with plain text, importing with codes, TMX issues etc.)
One issue that I can already mention here, is that Studio doesn't export to TMX correctly; this causes problems when re-importing and could also be the font of this issue.

[Note to developers]: When exporting to TMX, duplicates should *not* be merged. To see the problem, just export and re-import a somewhat complex TM and go to in the Attribute section: There will be merged attributes which shouldn't be there. This will probably mess up the indexing.

Greets,
Mike



[Edited at 2011-07-17 13:35 GMT]


Direct link Reply with quote
 

SDL Community  Identity Verified
United Kingdom
Local time: 05:39
English
A plan Jul 17, 2011

Hi Mike,

ok - the next time you manage to repro this behaviour drop me a mail at pfilkin@sdl.com and we can take a look immediately. I'll post whatever the findings are into this thread and we can take the appropriate action as a result.

I'm not a translator, but I think I have a pretty good idea of how a translator works.

On your note to developer comment. I recall seeing the post from you about this and actually just forgot to respond. I think it was this one:

http://www.proz.com/forum/sdl_trados_support/202783-studio_migration_question_for_multiple_cat_users_only.html#1767691

Studio will remove what you call “true duplicates” in Studio on import and if there are duplicates, each with different attributes it will merge them into one TU.

On export then, there is only one TU anyway so this would be why it has both attributes.

Same source, different targets is a valid possibility so not duplicates at all really… but there could be some due to an error in translation here or there, hence the search for potential duplicates. It also depends on the “Overwrite existing translations” option in the import wizard. Unchecked – duplicates will be imported. Option checked – duplicates will overwrite existing translations.

As for tags, it really depends on the other CAT tool. The tags are encoded in the TMX format so they could be imported correctly by the other tool or they may not. I can't really comment on other tools.

Nearly forgot... I’d be interested to see your TMX files and also which TMX Manager application you are using. Maybe it's this application that is not importing/exporting them correctly?

Regards

Paul

[Edited at 2011-07-17 21:14 GMT]


Direct link Reply with quote
 
MikeTrans
Germany
Local time: 05:39
Italian to German
+ ...
@Paul Jul 18, 2011

SDL Support wrote:

(...)

Nearly forgot... I’d be interested to see your TMX files and also which TMX Manager application you are using. Maybe it's this application that is not importing/exporting them correctly?


Paul,
Thanks for your details. You are most probably right here, as some of my last posts in other forums pointed me to stay very careful with my TMX manager (Olifant).

For checking this matter I will not rely on any manager but examine the TMX directly in UltraEdit (a text editor for large files).

Condidering my future workflows and seeing the high number of feedbacks in other posts on this forum, I have a personal motivation that this matter turns to be resolved in some way.

Thanks,
Mike


Direct link Reply with quote
 
MikeTrans
Germany
Local time: 05:39
Italian to German
+ ...
Must wait for this phenomena to occur... Jul 22, 2011

Hi,

I started my test run today by creating a new project and using files and TMs of a past project where this phenomena has occured, but surprisingly it didn't show up with my new project. The steps were:

- Exported TM and checked for TMX anomalies in UltraEdit; no anomalies found
- Created new project with 1 problem-file, 1 TM; allowed creation of Project TM
- Batch Task > Prepare

The Pre-translation correctly filled up with CM matches, the only few no-matches are due to a different segmentation of the file's text, and so: perfectly normal.

I have to wait or check other projects where this phenomena will occur in order to check the steps of Jacques.
I will keep on the run for hunting down this problem (if possible of course...)

Mike


Direct link Reply with quote
 


To report site rules violations or get help, contact a site moderator:


You can also contact site staff by submitting a support request »

Studio SP3 doesn't show some 100% matches

Advanced search







PerfectIt consistency checker
Faster Checking, Greater Accuracy

PerfectIt helps deliver error-free documents. It improves consistency, ensures quality and helps to enforce style guides. It’s a powerful tool for pro users, and comes with the assurance of a 30-day money back guarantee.

More info »
BaccS – Business Accounting Software
Modern desktop project management for freelance translators

BaccS makes it easy for translators to manage their projects, schedule tasks, create invoices, and view highly customizable reports. User-friendly, ProZ.com integration, community-driven development – a few reasons BaccS is trusted by translators!

More info »



Forums
  • All of ProZ.com
  • Term search
  • Jobs
  • Forums
  • Multiple search