Studio 2009 extremely poor performance
Thread poster: Achim Hofmeyer
Achim Hofmeyer  Identity Verified
Germany
Local time: 06:46
English to German
+ ...
Jul 27, 2011

Hey there,

I am just testing several Filetype settings for our specific .xml files in order to be able to switch from 2007 to Studio 2009 as conveniently as possible.

In 2007, we have worked with a customized .ini file to specify the tag settings. Although Studio 2009 should be able to handle (i.e. import and convert) the 2007 .ini files, it does not want ours (it just creates a filetype with completely empty parser rules).

So I created a filetype based on one of the .xml files we are using in our CMS. I assigned the parser rules for all the elements and started the "prepare" batch task to check that I have set all the rules correctly.

I started the task at 10:12 this morning, now it's 16:04 and meanwhile the status bar has "rushed" to a good 85%..... the .xml file merely has 1,585 KB

What could cause this poor performance? Usually Studio 2009 (I use it at home for other file types) processes my files rather quickly....

Any Ideas?

Edit: As I see now, Studio 2009 shows an extremely poor overall performance with our corporate memory (Upgraded from Trados 2007, 114757 KB, character-based concordance disabled).

The batch task that slows everything down is the pretranslation, and a standard concordance search query takes between 25 and 120 seconds (with Trados 2007, it takes between 0.x and 2 seconds max).

Has Studio 2009 general issues with large memories or upgraded memories?

I am currently running Studio 2009 in trial mode. This had better not be the reason for the poor performance. After all, the trial version is to attract customers rather than putting them off....

[Edited at 2011-07-28 08:56 GMT]


Direct link Reply with quote
 
Achim Hofmeyer  Identity Verified
Germany
Local time: 06:46
English to German
+ ...
TOPIC STARTER
Common issue or not? Jul 28, 2011

Given the billions of replies I suppose that this is not a very common issue huh?

Direct link Reply with quote
 

Jean-Pierre Artigau
Canada
Local time: 00:46
English to French
+ ...
Partly right Jul 28, 2011

It is true that Studio 2009 can slow you down considerably, compared to old-fashioned methods. This mostly depends on the type of project you have, on how "clean" your source document is, and on the amount of preliminary manipulations you have to do (sometimes two or three times because you missed one detail and the whole operation failed after a long series of steps).

Very often your original document (I work with Word) has "hidden" codes (tags) that mess things up once they appear in your Trados version. The first thing you should do once you get your text in Trados, before you start translating, try to obtain a "View in ... as target" (e.g. MS Word as target). If this doesn't work, you will probably have to play with your source document and put it back into Trados.

I sometimes have to convert .doc files to .txt files before I translate them in Trados, then re-create the formatting in Word in the final version... which means more waste of time.

Jean-Pierre


Direct link Reply with quote
 

SDL Community  Identity Verified
United Kingdom
Local time: 06:46
English
Could also be your filetype, or the xml? Jul 28, 2011

Hi Achim,

I'm sure you have done a good job of this, but maybe there is something in this that is causing the problem. If you can share your filetype (just the sdlftsettings file) and your xml file I can take a look for you?

Regards

Paul


Direct link Reply with quote
 
FarkasAndras
Local time: 06:46
English to Hungarian
+ ...
Sytem resources Jul 28, 2011

Achim Hofmeyer wrote:


The batch task that slows everything down is the pretranslation, and a standard concordance search query takes between 25 and 120 seconds (with Trados 2007, it takes between 0.x and 2 seconds max).

Has Studio 2009 general issues with large memories or upgraded memories?


No, there are no major issues with large TMs in general. I would reorganize the TM to make sure there's nothing wrong with the TM itself.
Other than that, as I posted in a very recent thread, this could be caused by poor system resources in your own computer. A reasonably fast hard disc and a lot of RAM will definitely speed this process up a lot. Kill memory-intensive tasks when you run Studio, and defragment your HDD if necessary. This worked for the poster in that thread. Hardware upgrades can help even more (more RAM, 3GB on a 32-bit system and 4-6 GB if you're on 64 bits, and a faster hard disc, preferably a good SSD).
Of course this could in principle be caused by some problem in your installation of Studio, but system resources are more likely as the culprit in my opinion.


Direct link Reply with quote
 
MikeTrans
Germany
Local time: 06:46
Member (2005)
Italian to German
+ ...
@Achim, Jul 28, 2011

Hi Achim,
I recently had performance issues, so you may want to take a look here:

http://www.proz.com/forum/sdl_trados_support/204023-[solved]_studio:_concordance_takes_ages_to_run_the_first_time.html

I don't know if this relates to your problem (nothing to do with XML files), but the "SOLVED" procedure couldn't harm anyway.

Mike


Direct link Reply with quote
 
Achim Hofmeyer  Identity Verified
Germany
Local time: 06:46
English to German
+ ...
TOPIC STARTER
Not th resources, not the file Jul 29, 2011

Thank you for your replies and tips.

@Jean-Pierre: I sometimes have those file/tag issues as well with certain translation projects.
However, the xml I used for my first Studio 2009 tests comes from our corporate content management system where we always use the exact same structure for each and every xml.
It would not make sense to me that Studio 2009 has issues with xml files that we have been using in Trados 2007 (and earlier) for years.
Meanwhile I have tested certain docx files as well and I get the same or similarly poor results...:(

@SDL support: As I get similar results with docx files I doubt it is the filetype. I shall send it to via your profile nonetheless, thank you so much for this.

@FarkasAndras and MikeTrans: Being a permanent translation drone in an industrial company, I am in the convenient position to be provided with a separate, test system for this purpose.

32 bit system, 4 GB RAM, 2.67 GHz 4-core processor, Vista SP1

Hard drive:

Intel SATA 160 GB 3.0 Gb/s (SSDSA2M160G2HP)
Bandwidth 250 MB/s read, 100 MB/s write
Latency 65 microseconds read, 85 microseconds write
IOPS 35000 read, 8600 write

Utilization during concordance search:

11-30% CPU

max 1.66 GB of 4 GB RAM

Utilization during "prepare" batch task:

11-20 % CPU

max 1.74 GB of 4 GB RAM

...sadly, I doubt it is related to system resources either but I shall clean-out any redundant data anyway.

I also have created another TM from a different backup -> same issues, even after re-indexing....

EDIT:

@SDL Support: cannot send the file via your profile as I can neither upload this file type nor a zip or rar folder. And sharing via one of our corporate ftp servers will certainly get me into trouble with our IT security....:(

[Edited at 2011-07-29 09:02 GMT]


Direct link Reply with quote
 
FarkasAndras
Local time: 06:46
English to Hungarian
+ ...
Nice hardware! Jul 29, 2011

Your system is easily powerful enough, so barring any strange issues (SSD driver problems or whatever), the problem should be in Studio. As it's an SSD, it's not a disc fragmentation issue, either. Win7 or even Vista SP2 could theoretically be an improvement, but it's hard to believe it would be significant for a process like this, on hardware this powerful.
My next suggestion would have been to reimport/reindex the TM, which you've apparently already done. Try testing on a different computer, with a smaller TM etc. to isolate the variable that's causing the problem.

[Edited at 2011-07-29 09:53 GMT]


Direct link Reply with quote
 

Jean-Pierre Artigau
Canada
Local time: 00:46
English to French
+ ...
Convert your source files to xml? Jul 29, 2011

Achim, you say you say you use the same xml structure for all your documents, so you must somehow "convert" every new document into your predetermined "structure". I don't see how you can do that. All I can do with my Word documents is plug them into Trados 2009 and click "prepare". Is there another way to make them fit into a predetermined "structure" that will avoid subsequent problems in Trados?

Jean-Pierre


Direct link Reply with quote
 
Achim Hofmeyer  Identity Verified
Germany
Local time: 06:46
English to German
+ ...
TOPIC STARTER
Strangely seems to work... Jul 29, 2011

@FarkasAndras: today I have tested several combinations of TM settings, file types, concordance settings and files to maybe solve the riddle.

Result: now I use the exact same TM and TM settings, concordance settings and file type as yesterday, and the performance is way better.

Tasks that took a good 300 minutes yesterday do now take merely 12 minutes. Concordance is down to 1-3 seconds from 25-120 seconds, except the first query after startup or longer idle time but this is due to the shift from hard drive to RAM I suppose.

I don't exactly know why it works but it seems to work now. I cannot see the logic behind this, but as computer scientists say, those machines always act logically.....I for one am a bit confused now.

@Jean-Pierre: That came out wrong. We mainly translate our technical documentation, which is all created based on the same xml structure in our cms. Translations from all the other departments are processed based on the provided files (doc(x), ppt(x), xls(x), etc.) without converting them, and usually we do not encounter major problems...


Direct link Reply with quote
 


To report site rules violations or get help, contact a site moderator:


You can also contact site staff by submitting a support request »

Studio 2009 extremely poor performance

Advanced search







PDF Translation - the Easy Way
TransPDF converts your PDFs to XLIFF ready for professional translation.

TransPDF converts your PDFs to XLIFF ready for professional translation. It also puts your translations back into the PDF to make new PDFs. Quicker and more accurate than hand-editing PDF. Includes free use of Infix PDF Editor with your translated PDFs.

More info »
SDL Trados Studio 2017 Freelance
The leading translation software used by over 250,000 translators.

SDL Trados Studio 2017 helps translators increase translation productivity whilst ensuring quality. Combining translation memory, terminology management and machine translation in one simple and easy-to-use environment.

More info »



Forums
  • All of ProZ.com
  • Term search
  • Jobs
  • Forums
  • Multiple search