TagEditor spaces before and after tags
Thread poster: matt robinson

matt robinson  Identity Verified
Spain
Local time: 03:12
Member (2010)
Spanish to English
Aug 11, 2011

Reviewing a document I've produced in TagEditor I see that I've missed some spaces before tags, causing words to join up. Is there any way of setting it up so that it always leaves a space before and/or after tags? Can I now correct my mistakes without having to go through the whole document manually?

Thanks.


Direct link Reply with quote
 

Tomás Cano Binder, BA, CT  Identity Verified
Spain
Local time: 03:12
Member (2005)
English to Spanish
+ ...
Not that I know of... Aug 11, 2011

Unfortunately I don't know of any way of doing so. It would also be incorrect to add spaces all the time, given the enormous range of possible tags available. A majority of tags are formatting tags that should not have spaces before or after them.

If you know the exact tags that should have the space, there is a little trick I can recommend:
- Open the TTX file in MS Word or any text editor with find and replace.

- Do a global search and replace for the tag, replacing it with space, the tag, and another space. This will add a space even if there is already one.

- Once you have added spaces before and after the tags you are sure require the spaces, you will end up with many places with double spaces. To convert them to a single space, do a global search and replace for two spaces, replacing with one space. Repeat until you have no double spaces.

- Save the TTX file and work with it normally.

(The TTX file is in UTF-8 encoding, in case you are asked by the text editor.)

I hope this is useful in some way!

[Edited at 2011-08-12 09:48 GMT]


Direct link Reply with quote
 

Martina Klett  Identity Verified
Germany
Local time: 03:12
Italian to German
+ ...
Space after tag for next translation project Aug 12, 2011

You cannot automatically insert a space before a tag in TagEditor (as far as I know) but after every tag (which may be useful for your next translation project).
In Translator's Workbench go to the Options menu - Translation Memory Options - General and there you may activate the option "Insert blank after tag".

HTH


Direct link Reply with quote
 

matt robinson  Identity Verified
Spain
Local time: 03:12
Member (2010)
Spanish to English
TOPIC STARTER
Thanks Aug 12, 2011

Thanks to both of you.

Direct link Reply with quote
 


To report site rules violations or get help, contact a site moderator:


You can also contact site staff by submitting a support request »

TagEditor spaces before and after tags

Advanced search







SDL MultiTerm 2017
Guarantee a unified, consistent and high-quality translation with terminology software by the industry leaders.

SDL MultiTerm 2017 allows translators to create one central location to store and manage multilingual terminology, and with SDL MultiTerm Extract 2017 you can automatically create term lists from your existing documentation to save time.

More info »
CafeTran Espresso
You've never met a CAT tool this clever!

Translate faster & easier, using a sophisticated CAT tool built by a translator / developer. Accept jobs from clients who use SDL Trados, MemoQ, Wordfast & major CAT tools. Download and start using CafeTran Espresso -- for free

More info »



Forums
  • All of ProZ.com
  • Term search
  • Jobs
  • Forums
  • Multiple search