Cannot export inx files from Studio 2009 - java errors
Thread poster: Giorgia Nosenzo

Giorgia Nosenzo
Austria
Local time: 10:03
German to Italian
+ ...
Aug 28, 2011

Hi everyone,

I know this issue has been already discussed many times (the most similar thread in http://www.proz.com/forum/sdl_trados_support/151694-cannot_export_inx_files_in_studio_2009.html) but after reading every possible post about this problem I still haven't found any useful solution, so I'm posting it one more time.

I use Trados Studio 2009 (SP3) and I currently have Java Version 6 Update 14 installed on my computer.

I've managed to import and translate a quite big inx file without problems but now when I try to save the file in the target language a number of errors appear:

* The file contains a large story object which cannot be handled by the current Java Virtual Machine size. Please use a Filter Settings option to increase the Java Virtual Machine size

After decreasing / increasing the jvm size I get another error (I don't remember the exact message) which invites me to *change the file processing settings.

After doing that I get another error, usually concerning *Java heap space.

Lately I then got the errore message *Java class not found.

I've been trying changing settings and java versions but up to now I just ended up getting other error messages...
I'm really grateful for any input on this since right now I feel quite helpless and I've no idea on how to get the target file out of Trados (and obviously my deadline is approaching).

Thanks in advance!
Giorgia



[Bearbeitet am 2011-08-28 12:40 GMT]


 

Bernard Lieber  Identity Verified
Local time: 10:03
English to French
+ ...
Workaround Aug 28, 2011

The only workaround I've found so far is to break up the original file into smaller files and use the TM from the larger file - around 50 pages maximum - to translate them again, is a sort of trial and error procedure under 2009. Also found that Alchemy Publisher 3.0 handles large inx files much better than Studio.

 

septima
Local time: 10:03
To try Aug 28, 2011

Giorgia, from your post I understand that you have already tried setting up your Java Virtual Machine sizes both globally and within the individual project, but that is not helping.
Now please try this:

1. Under Tools -> Options -> Java Runtime Engine Setup, UNTICK the box "Start Java Runtime Engine when starting SDL Trados Studio". Save and close.

2. Restart Trados.

3. Go to Projects View. Right click your project file -> Batch Tasks -> Generate Target Translations.

I hope perhaps that will help, best wishes.


 

Giorgia Nosenzo
Austria
Local time: 10:03
German to Italian
+ ...
TOPIC STARTER
It worked! Aug 29, 2011

Thank you Bernard and Septima for your inputs.

I tried first what Septima suggested and it worked for me!!

I was able to extract the target inx file just by unticking the box "Start Java Runtime Engine when starting SDL Trados Studio" and then restarting Trados (I actually opened the bilingual file outside of my project, as a single file, but I don't know if this matters).

Thank you so much!
I hope this will help others as well.


 

septima
Local time: 10:03
That's great Aug 29, 2011

I'm so glad it worked for you, Giorgia. I don't think it's too important whether you open the file outside or inside of a project in the end. The key step is to prevent Trados from autonomously starting up Java in this instance. Generating a translation from the project view rather than editor view just allows a little more RAM to be accessed, I believe.

But after generating your translation, I think it's good to re-enable (re-tick) the Java start up function in general, for integration with Multiterm etc.

Best wishes,

septima.


 

Henny Willis  Identity Verified
United States
Local time: 03:03
Member
English to Indonesian
+ ...
Work for me too! Jun 22, 2012

Many thanks, septima!

 


To report site rules violations or get help, contact a site moderator:


You can also contact site staff by submitting a support request »

Cannot export inx files from Studio 2009 - java errors

Advanced search







Déjà Vu X3
Try it, Love it

Find out why Déjà Vu is today the most flexible, customizable and user-friendly tool on the market. See the brand new features in action: *Completely redesigned user interface *Live Preview *Inline spell checking *Inline

More info »
BaccS – Business Accounting Software
Modern desktop project management for freelance translators

BaccS makes it easy for translators to manage their projects, schedule tasks, create invoices, and view highly customizable reports. User-friendly, ProZ.com integration, community-driven development – a few reasons BaccS is trusted by translators!

More info »



Forums
  • All of ProZ.com
  • Term search
  • Jobs
  • Forums
  • Multiple search