"Semi-WYSIWYG formatting will not be applied to the TTX file...
Thread poster: JaneD

JaneD  Identity Verified
Sweden
Local time: 04:06
Member (2009)
Swedish to English
+ ...
Sep 13, 2011

The whole error message is

"Semi-WYSIWYG formatting will not be applied to the TTX file, as there was a problem with filter framework 1 components. The TTX file will be fully functional but will appear without formatting if opened in TagEditor.

Error in plug-in filter definition file [path to my Temp directory, ending in .xml]
Invalid invokation attribute: COM"


I get this in Studio 2011 when trying to "save Target as" for a .ttx file. I can't see why any filter definition would be required, nor why if one was it should be looking in the Temp directory to find it, apparently for an .xml file.

I haven't yet tried this in Studio 2009, so I don't know whether this is a version specific issue, but if anyone could clarify what the message means it'd be much appreciated.

Jane

Edit: Have now tried it in Studio 2009, and there is no error message. I would be even more interested to find out what this means, as I would like to upgrade to 2011!

[Edited at 2011-09-13 10:04 GMT]


Direct link Reply with quote
 

Jerzy Czopik  Identity Verified
Germany
Local time: 04:06
Member (2003)
Polish to German
+ ...
The message is quite clear Sep 13, 2011

Your TTX file will be fully functional and correct. Just when you open it in TagEditor no bold or italic formatting will be shown, just plain text anb tags.
I inded do not know the reason why S2009 does not show the message, but in fact I do not care. All my TTX files are no-formatting and if I deliver to the customer they just need it to update the TM, where tags but not formatting matters.


Direct link Reply with quote
 
Stefan de Boeck  Identity Verified
Belgium
Local time: 04:06
English to Dutch
+ ...
ini Sep 13, 2011

... apparently for an .xml file.


Studio can’t locate the .ini file for your xml.ttx.sdlxliff.

You could help the old dear along by opening the xml.ttx in a text editor and edit the SettingsFilePath to a spot that actually exists on your hard disk (and where the .ini file is now sitting).


Direct link Reply with quote
 

Jerzy Czopik  Identity Verified
Germany
Local time: 04:06
Member (2003)
Polish to German
+ ...
But for what reason? Sep 13, 2011

Stefan de Boeck wrote:

... apparently for an .xml file.


Studio can’t locate the .ini file for your xml.ttx.sdlxliff.

You could help the old dear along by opening the xml.ttx in a text editor and edit the SettingsFilePath to a spot that actually exists on your hard disk (and where the .ini file is now sitting).

Indeed that should work, nevertheless I do not see any sense in adding work for that.


Direct link Reply with quote
 
Stefan de Boeck  Identity Verified
Belgium
Local time: 04:06
English to Dutch
+ ...
odd Sep 13, 2011

Jerzy Czopik wrote:
Indeed that should work, nevertheless I do not see any sense in adding work for that.


To produce the translation? TargetOnly.xml? Not the Bilingual.xml.ttx.sdlxliff any more?

Not, of course, to have the benefit of the copywriter’s monkeybrush formatting in full wysiwyg.




[Edited at 2011-09-13 18:40 GMT]


Direct link Reply with quote
 

Jerzy Czopik  Identity Verified
Germany
Local time: 04:06
Member (2003)
Polish to German
+ ...
You're missing the point I am afraid Sep 13, 2011

Stefan de Boeck wrote:

Jerzy Czopik wrote:
Indeed that should work, nevertheless I do not see any sense in adding work for that.


To produce the translation? TargetOnly.xml? Not the Bilingual.xml.ttx.sdlxliff any more?

Not, of course, to have the benefit of the copywriter’s monkeybrush formatting in full wysiwyg.


With or without the ini Studio will produce a fully functional TTX file, which will then deliver a fully functional and fully formatted target translation.
The error message says only, that the TTX will not show bold and so on (semi-WYSIWYG) on the screen in TagEditor. Nothing more.
There will be no problems with the TTX whatsoever and I am even ready to bet most people will not notice the difference. Or even if, the TTX without the semi-WYSIWYG effect is better for work - no format changes whatsoever in such files.


Direct link Reply with quote
 

JaneD  Identity Verified
Sweden
Local time: 04:06
Member (2009)
Swedish to English
+ ...
TOPIC STARTER
Additional clarification Sep 13, 2011

In any case, the original file is an .xls file (ie .xls.ttx) - so why would it want an .xml .ini file?

Direct link Reply with quote
 

Jerzy Czopik  Identity Verified
Germany
Local time: 04:06
Member (2003)
Polish to German
+ ...
It does not want an xml.ini Sep 13, 2011

The xml mentioned is most probably a configuration setting file.
You can ignore that message fully.
If you have the source XLS just try to save the ttx from Studio AND the target XLS too.
If not, deliver the ttx to the customer and let them save the xls. This will work.
The message refers only to how the TTX file ITSELF will be viewed in TagEditor. It does not say anything about the final formating of any target file.


Direct link Reply with quote
 


To report site rules violations or get help, contact a site moderator:


You can also contact site staff by submitting a support request »

"Semi-WYSIWYG formatting will not be applied to the TTX file...

Advanced search







Protemos translation business management system
Create your account in minutes, and start working! 3-month trial for agencies, and free for freelancers!

The system lets you keep client/vendor database, with contacts and rates, manage projects and assign jobs to vendors, issue invoices, track payments, store and manage project files, generate business reports on turnover profit per client/manager etc.

More info »
Déjà Vu X3
Try it, Love it

Find out why Déjà Vu is today the most flexible, customizable and user-friendly tool on the market. See the brand new features in action: *Completely redesigned user interface *Live Preview *Inline spell checking *Inline

More info »



Forums
  • All of ProZ.com
  • Term search
  • Jobs
  • Forums
  • Multiple search