Studio 2009 added tags to XML files
Thread poster: Simon Willmott
Simon Willmott  Identity Verified
United Kingdom
Local time: 11:42
German to English
+ ...
Sep 29, 2011

I encountered an issue with a recent project, where the target XML files I delivered to my client had extra tags that were not present in the source, rendering them invalid.

I originally received XML source files, and had to deliver target XML and TTX files. As I prefer to work in Studio, my workflow consisted of:

1. Open XML files in TagEditor, save as TTX
2. Create new project in Studio, add TTX files as source files
3. Translate
4. Finalize project in Studio to create translated TTX files
5. Clean these TTX files up in Workbench to get target XML files.

This process resulted in some XML files that were not valid, as the tag structure had been altered. When trying to work out what had happened, I discovered that a workflow without the Studio 2009 stage (i.e. translate in TagEditor) resulted in perfectly valid XML files.

To illustrate what I mean, here are a few screenshots. I've altered the text to remove any sensitive client details.

TTX file translated in the Studio 2009 workflow. Note the tags at the end of the line. These occur outside the TU and are what cause the target XML files created from this file to not work:



TTX file processed solely in TagEditor. Target XML files created from this file work fine:



Comparison of the two target XML files (using BeyondCompare software). The top line is from the file created with the Studio 2009 workflow and this file does not work. The bottom one works fine and was processed exclusively in TagEditor:


There are going to be further batches in this project, so I need to know how to ensure the error does not occur again. Can anyone shed any light on why this happened?

Thanks!


Direct link Reply with quote
 

SDL Community  Identity Verified
United Kingdom
Local time: 12:42
English
Smart tag pairing Oct 1, 2011

Hi,

It looks as though you have processed the TTX files in Studio without disabling smart tag pairing. A TTX often produces placeholders that Studio can try to turn into proper tag pairs. This is done to provide for working with a better wysiwyg effect in the editor.

Now, if you are taking the TTX and saving the proper target file rather than a TTX to return to 2007 then this is usually ok. But if you are returning a TTX file instead then you should disable smart tag pairing to be on the safe side.

The option can be found in Tools - Options - TRADOSTag - Compatibility. Try aain with smart tag pairing disabled and see if this is better (I hope this is the reason..!).

This is covered in the Studio migration guide in the start menu if you want more info on it.... there is also a whitepaper on this here:

Regards

Paul


Direct link Reply with quote
 


To report site rules violations or get help, contact a site moderator:


You can also contact site staff by submitting a support request »

Studio 2009 added tags to XML files

Advanced search







LSP.expert
You’re a freelance translator? LSP.expert helps you manage your daily translation jobs. It’s easy, fast and secure.

How about you start tracking translation jobs and sending invoices in minutes? You can also manage your clients and generate reports about your business activities. So you always keep a clear view on your planning, AND you get a free 30 day trial period!

More info »
WordFinder
The words you want Anywhere, Anytime

WordFinder is the market's fastest and easiest way of finding the right word, term, translation or synonym in one or more dictionaries. In our assortment you can choose among more than 120 dictionaries in 15 languages from leading publishers.

More info »



Forums
  • All of ProZ.com
  • Term search
  • Jobs
  • Forums
  • Multiple search