Pages in topic:   [1 2] >
F12 stopped working after installing Trados Studio 2011
Thread poster: Richard Hill

Richard Hill  Identity Verified
Mexico
Local time: 21:46
Member (2011)
Spanish to English
Sep 30, 2011

Hi.

I just installed Trados 2011 (nice and smooth on the surface) but F12 won't save a term in Multiterm in Studio 2011. I opened a document in Trados 2009 and F12 doesn't work there either anymore. I had heard of some people having problems with F12 not working in 2009 but mine had always worked fine until I installed 2011 today, and as this key function (Save this Entry) is not reassignable, it's gunna be a real pain to use the mouse, so I wonder if anyone knows of a solution?

Thanks!


Direct link Reply with quote
 

Nora Diaz  Identity Verified
Mexico
Local time: 19:46
Member (2002)
English to Spanish
+ ...
Are your other F keys working well? Sep 30, 2011

Hi Rich,

My keyboard as an "F lock" key right next to F12 that I sometimes inadvertently hit and that messes up all my F keys, they stop working or start doing unusual things. Hitting this key again restores everything back to normal.


Direct link Reply with quote
 

Richard Hill  Identity Verified
Mexico
Local time: 21:46
Member (2011)
Spanish to English
TOPIC STARTER
F12 works fine directly in Multiterm Sep 30, 2011

Hi Nora,

This is really annoying, F12 works fine in Multiterm itself. I can't imagine why they would make the Save (term) function reassignable in Multiterm but not in Trados.
Anyway, all keys are set to default in Multiterm but still doesn't work within Trados.
Here's hoping Jerzy or Paul come up with a solution. I'll give it a few days and if not, maybe reinstall, but I really hope it won't be necessary to do so.

I have a Microsoft keyboard but it doesn't seem to have an F-Lock key, anyway, like I say, the F keys are working everywhere else except in Trados.

I have just read this post
http://www.proz.com/forum/sdl_trados_support/149675-trados_studio_2009_sp1_f12_to_save_a_new_term.html from way back in 2009
Grzegorz Gryc wrote:
Unlike in the Multiterm main applications, the shortcuts work only when you click on the right side of the Termbase viewer
When the focus is on the term list (on the left side), you have to click on the icons


and I can't believe it, F12 works when I "click on the right side of the Termbase viewer", which is ridiculous, because this is a LONGER route than just clicking on the "Save this Entry" icon in the termbase viewer.

Do you have to click on the right side of the Termbase viewer Nora, to save terms with F12 in your Trados 2011, or does it work for you from within the main window?

Again, I stress that before installing 2011, I did not have this issue in 2009, but now the issue is there in both 2009 and 2011.

Ahhhggg!

Thanks again Nora

Rich


Direct link Reply with quote
 

Nora Diaz  Identity Verified
Mexico
Local time: 19:46
Member (2002)
English to Spanish
+ ...
F12 works as expected for me Sep 30, 2011

Hi Rich,

Sorry you're experiencing this frustrating issue. Everything works as expected for me, I hit F11 to add my selected terms and F12 right after to save them.

There are however some times when hitting F12 too quickly results in the Save As dialog opening up instead. Do you see a difference if you wait a split second before hitting F12? Or is F12 completely disabled for you?

Hopefully someone will offer a solution soon.


Direct link Reply with quote
 

Richard Hill  Identity Verified
Mexico
Local time: 21:46
Member (2011)
Spanish to English
TOPIC STARTER
No difference if I wait Oct 1, 2011

Hi Nora,

There's no difference if I wait. When I hit F12, the termbase viewer sort of flashes as though its going to enter the term, but doesn't. I thought it might be the key itself, but ruled that out because if I click on the termbase viewer F12 works fine, just doesn't work from the main window.

Another thing I find weird is that F12 is assigned to "Save As" (in the main trados menu) by default, which is probably irrelevant, but considering that F12 MUST be used to save terms, I can't see would they assign it to "Save As" by default.

Anyway, I uninstalled and reinstalled Multiterm and Trados last night (2009 and 2011) but no luck.

I've got loads of work to do, so I'll be adding terms with the mouse for now.

Thanks again Nora

Rich


Direct link Reply with quote
 

Emma Goldsmith  Identity Verified
Spain
Local time: 03:46
Member (2010)
Spanish to English
f12 in Studio / Multiterm Oct 1, 2011

As far as I can remember, F12 in Studio has always been "save as", unless of course you have changed the shortcut at some point. By installing 2011, F12 should be assigned to "save as" by default.

F12 is "save term" in Multiterm (inside Studio). It works correctly for me in 2009 and 2011.

I don't think "add new term" comes with any shortcut in 2011, but you could assign one I guess. If you want it to be F12 then you could delete it first under "save as" and then assign it to "add new term".

Or maybe you have been through all this already?


Direct link Reply with quote
 

Richard Hill  Identity Verified
Mexico
Local time: 21:46
Member (2011)
Spanish to English
TOPIC STARTER
Yes I have done that already Oct 1, 2011

Hi Emma

At this stage, I'd be happy if I could assign ANY key or key combination to "Save this Entry", especially considering that I have 3 similar documents to translate this week, and would obviously benefit from adding loads of terms from the first document to use in the next two. Of course I am adding terms, but with the mouse which is a right pain. At least Alt F7 is working for adding Autotext.

Thanks for your reply Emma

Rich


Direct link Reply with quote
 

SDL Community  Identity Verified
United Kingdom
Local time: 03:46
English
Maybe you have a conflict with another application? Oct 1, 2011

Hi Rich,

Sometimes other applications can cause a keyboard conflict. It might be worth closing as many applications as you have active then trying again. If it works then add them back in again one at a time until you find the culprit. Then see if you can figure out what might be the conflict.

If that doesn't help perhaps we can arrange a webex and take a look at your setup?

Regards

Paul


Direct link Reply with quote
 

Richard Hill  Identity Verified
Mexico
Local time: 21:46
Member (2011)
Spanish to English
TOPIC STARTER
Webex Oct 1, 2011

Hi Paul,

I will try what you suggest, but my first thought is that this is not the case as F12 works fine in Multiterm, without closing any other programs, and like I say it worked fine until two days ago before I installed Trados 2011. Could the conflict be with Multiterm 2009 and Multiterm 2011?

What is a webex and what does it involve?

Cheers!

Rich


Direct link Reply with quote
 

SDL Community  Identity Verified
United Kingdom
Local time: 03:46
English
Webex... Oct 1, 2011

Hi Rich,

Hard to comment to be honest until we see your set up. This is what a webex is. We can remote onto your PC and take a closer look.

Regards

Paul


Direct link Reply with quote
 

Richard Hill  Identity Verified
Mexico
Local time: 21:46
Member (2011)
Spanish to English
TOPIC STARTER
Webex Oct 1, 2011

Hi again Paul

I tried your suggestion to no avail. Then I tried uninstalling 2009 and 2011 again then only installing Trados and Multiterm 2011 but no luck either. I have the feeling it could be something to do with file association but I don't know enough to sort it out and I'm more than likely wrong about that. The reason I mention this is because the sdlxliff files are shown as plain white "sheets" like this:



Anyway, I'd be grateful if you could help me arrange the webex on Monday?

Cheers Paul

Rich


Direct link Reply with quote
 
Tanja Hieber  Identity Verified
United Kingdom
Local time: 02:46
Member (2003)
English to German
It's a Java issue Oct 3, 2011

I had the same problem when I started to use Studio 2011 - then I remembered I used to have it with Studio 2009 as well in the beginning. What did the trick for me was to deactivate the Java setting "Enable the next-generation Java Plug-in" (to be found under: Control Panel > Java > Advanced > Java Plug-in). The 2011 installer also installs a new Java version which must have changed the setting back to default. Hope this helps you too.

ETA: You have to restart Studio after changing the setting.

[Edited at 2011-10-03 10:00 GMT]


Direct link Reply with quote
 

Richard Hill  Identity Verified
Mexico
Local time: 21:46
Member (2011)
Spanish to English
TOPIC STARTER
Java Oct 3, 2011

Hi Tanja.

Having previously read about this issue
http://www.proz.com/forum/sdl_trados_support/138575-multiterm_2009_editing_and_adding_terms_is_slow-page2.html your suggestion was one of the first things I'd tried. But then upon reading your reply this morning, I thought I'd double check and give it another go, and hey presto! F12 is working as normal.
I'm so glad you posted this suggestion and prompted me to uncheck "Enable the next-generation Java Plug-in" again. Maybe I did not close and restart Trados the last time I did it, who knows and who cares, it's as it should be now and I am one happy camper. Thanks you so much Tanja, and thank you Nora, Paul and Emma too.

Rich


Direct link Reply with quote
 
Alain Pommet  Identity Verified
Local time: 03:46
Member (2006)
French to English
F12 fixed but the solution causes another problem Oct 17, 2011

Hi everyone,

Using studio 2011

I followed the advice given on this post and links to get the F12 key working but have found this causes a problem in a set of files I try to open. I get the message

InvalidArgument=Value of '-1' is not valid for 'index' and the files don't open

However turning the Java switch back on cures the problem. I assume this is an undocumented feature....


Direct link Reply with quote
 

Aurelie Sheehan  Identity Verified
Australia
Local time: 13:46
Member (2010)
English to French
InvalidArgument = Value of "-1" is not valid for "index" Aug 31, 2012

Hi Alain,

I am getting the same error message as you are mentionning in your comment. I am not sure why it is appearing. I have basically tried to open a document for review and this message appeared. Since then, I am not able to review a document or to even edit one! Once I click OK on the error message pop-up window, the text disappears from the editor or review window.

I am not sure if this is linked to Java or not. Could you tell me if you eventually managed to fix the problem and how?

Thank you
Aurélie

[Edited at 2012-08-31 04:22 GMT]


Direct link Reply with quote
 
Pages in topic:   [1 2] >


To report site rules violations or get help, contact a site moderator:


You can also contact site staff by submitting a support request »

F12 stopped working after installing Trados Studio 2011

Advanced search







SDL MultiTerm 2017
Guarantee a unified, consistent and high-quality translation with terminology software by the industry leaders.

SDL MultiTerm 2017 allows translators to create one central location to store and manage multilingual terminology, and with SDL MultiTerm Extract 2017 you can automatically create term lists from your existing documentation to save time.

More info »
CafeTran Espresso
You've never met a CAT tool this clever!

Translate faster & easier, using a sophisticated CAT tool built by a translator / developer. Accept jobs from clients who use SDL Trados, MemoQ, Wordfast & major CAT tools. Download and start using CafeTran Espresso -- for free

More info »



Forums
  • All of ProZ.com
  • Term search
  • Jobs
  • Forums
  • Multiple search