Studio 11: 'Not enough storage is available to process this command'
Thread poster: Mary Worby

Mary Worby  Identity Verified
United Kingdom
Local time: 22:51
Member
German to English
+ ...
Oct 25, 2011

I installed Studio 2011 at the weekend and am already beginning to regret doing so! The software seems virtually identical to Studio 2009 but slower and buggier!

At the moment, I'm struggling with the above error message, which pops up when I'm happily translating away, mid-segment. Initially I could dismiss it, but now it keeps on popping up again and again and I can't get rid of it or ignore it.

I'm using Windows 7, if that makes a difference.

Any ideas?

Many thanks


Direct link Reply with quote
 

Jerzy Czopik  Identity Verified
Germany
Local time: 23:51
Member (2003)
Polish to German
+ ...
Restart Studio Oct 25, 2011

Close some background programms.
This is simply a message to inform you, that your PC does not have enough memory to process your command now (mostly for AutoSuggest hits). Saving the work in Studio can also help at least for the moment.

BTW, Studio 2011 is faster and far less buggy than Studio 2009 I know that from the beta testing phase.

[Edited at 2011-10-25 09:48 GMT]


Direct link Reply with quote
 

Mary Worby  Identity Verified
United Kingdom
Local time: 22:51
Member
German to English
+ ...
TOPIC STARTER
Thanks Jerzy Oct 25, 2011

I don't have any background programs to close. I'm just running Trados, Outlook and Firefox. I have a swishy new computer with 4.0 GB of RAM. Surely that should be enough?

I'm hoping what I'm experiencing is just teething problems, and it's good to know it is worth persevering!


Direct link Reply with quote
 

Jerzy Czopik  Identity Verified
Germany
Local time: 23:51
Member (2003)
Polish to German
+ ...
Should be enough indeed Oct 25, 2011

However, I do get this error sometimes on a machine with 8 GB RAM, when many programs are running - this error shows when AutoSuggest entries are processed. In my case it is enough to close some background task, save the job and continue or to restart Studio.

Direct link Reply with quote
 

Mary Worby  Identity Verified
United Kingdom
Local time: 22:51
Member
German to English
+ ...
TOPIC STARTER
OK! Oct 25, 2011

I had to force Studio to close in the end, as the message wouldn't click itself away, and since then the problem hasn't reoccured. Fingers crossed it was just a one-off! It was in quite a large segment which would probably have generated a fair few Auto-Suggest entries.

Thanks for your help, as ever, Jerzy!


Direct link Reply with quote
 

François Rossi  Identity Verified
Local time: 22:51
English to French
+ ...
java.exe error Jan 29, 2012

I'm having the same problem. Running XP SP3 with 1.9 Gb free for apps.

I was translating a 25000 words document and the problem started after I had done about 8000 words. Now, as soon as I start Studio 2011 (after booting the PC), I get the "not enough storage available" and an error message from java.exe.

I'm particularly annoyed as I had upgraded from 2009 hoping to bypass the "out of memory" errors I was getting with large files.

Any idea ?



[Edited at 2012-01-30 11:39 GMT]


Direct link Reply with quote
 

François Rossi  Identity Verified
Local time: 22:51
English to French
+ ...
solution found Jan 29, 2012

I've managed to find a solution that seems to be working for now. Read on...

The "not enough storage" error is due to a Resource Heap shortage.

There is a registry entry that can be increased to raise the heap size for XP. For Vista Microsoft already sets the default value higher. Changing the default 3072 value to at least 8192 helps.

This information is documented in the Knowledge Base Article ID 126962 (or search for "Out of Memory"). Additional details concerning the parameter values may be found in the Knowledge Base Article ID 184802.

The change means editing the Windows Registry.

1) Run Registry Editor (REGEDT32.EXE).

2) From the HKEY_ LOCAL_MACHINE subtree, go to the following folder:
\System\CurrentControlSet\Control\Session Manager\SubSystem

3) On the right hand side of the screen double-click on the key:
windows

4) On the pop-up window you will see a very long field selected. Move the cursor near the beginning of the string looking for this (values may vary):
SharedSection=1024,3072,512

5) SharedSection specifies the System and desktop heaps using the following format: SharedSection=xxxx,yyyy,zzz where xxxx defines the maximum size of the system-wide heap (in kilobytes), yyyy defines the size of the per desktop heap, and zzz defines the size of the desktop heap for a "noninteractive" window station.

6) Change ONLY the yyyy value to 8192 (or larger) and press OK.

7) Exit the Registry Editor and reboot the PC for the change to take effect.

Now, back to work!

PS: Still annoyed with SDL. This is the sort of stuff that should have been flagged during beta-testing. A translator who has no advanced knowledge of computing would have no chance finding a solution to this sort of problems.


Direct link Reply with quote
 
Windows 7 Oct 20, 2012

Note that the numbers for windows 7 and Vista might be different, and microsoft has a different patch to address the issue:

http://support.microsoft.com/kb/947246


Direct link Reply with quote
 


To report site rules violations or get help, contact a site moderator:


You can also contact site staff by submitting a support request »

Studio 11: 'Not enough storage is available to process this command'

Advanced search







CafeTran Espresso
You've never met a CAT tool this clever!

Translate faster & easier, using a sophisticated CAT tool built by a translator / developer. Accept jobs from clients who use SDL Trados, MemoQ, Wordfast & major CAT tools. Download and start using CafeTran Espresso -- for free

More info »
LSP.expert
You’re a freelance translator? LSP.expert helps you manage your daily translation jobs. It’s easy, fast and secure.

How about you start tracking translation jobs and sending invoices in minutes? You can also manage your clients and generate reports about your business activities. So you always keep a clear view on your planning, AND you get a free 30 day trial period!

More info »



Forums
  • All of ProZ.com
  • Term search
  • Jobs
  • Forums
  • Multiple search