Studio 2009: TM does not recognize nubmers
Thread poster: Witold Palka
Witold Palka  Identity Verified
Poland
Local time: 13:28
Member (2005)
German to Polish
+ ...
Nov 13, 2011

Hi All

Translation from German into Polish.
In the German file decimal places of numbers are shown with "."
I need the decimal places in polish to follow after ","
There is always a single number in original segment (example 559.56)

In the TM the options to recognize numbers, dates, measurements etc. is on.

The TM does not recognize the segment 556.56 as number. Probably because in German decimal places follows after ",".

Question: Is there any way to re-define the symbol for decimal place in original language? So the soft would recognize the decimal place by any (defined) character?

My workaround was to use filter and CTRL+H but I fill less than comfortable with it.

Regards

WP


Direct link Reply with quote
 

SDL Community  Identity Verified
United Kingdom
Local time: 13:28
English
One thing you could try is this... Nov 13, 2011

Hi,

Go to your Windows Control Panel, then Region and Language. In here you can define the rules that Windows uses to recognise numbers. I just tested this quickly with English United Kingdomn and by adding a comma for the decimal serator and full stop for the list seperator for numbers I now get either commas or full stops recognised in English and they were correctly localised into German for me.

I would close Studio first and then restart after making the changes in Windows. I tested this with W7 so can't guarantee what might happen in other systems but it seems likely it should work ok.

Regards

Paul


Direct link Reply with quote
 

SDL Community  Identity Verified
United Kingdom
Local time: 13:28
English
Incorrect response Nov 14, 2011

Hi Witold,

I gave you a poor response here and after discussing with a developer wanted to correct this advice. In some circumstances (only if they are “full stop” and “comma), it is allowed to swap the decimal and group separators. So if that alternative reading then produces a valid number, it will be accepted.

I tested this with your example and found that 559.56 was recognised in German but was autolocalised to 559.56 in Polish which is clearly wrong. The explanation for this is that the full stop is “incorrectly” used as a decimal separator in de-DE, so there’s a “separator use exception”, in this case a “separator swap”. But since the full stop is neither the decimal nor the group separator in pl-PL, there’s no way to also apply the “separator swap” for p-PL, and it’s assumed that the full stop use is a stylistic convention in the source language, or “not a number”, so it’s retained.

So one option, that would work for any filetype (in case you don't have the software to work with the source filetype) would be to copy source to target in Studio and then search and replace all the numbers. Save the target, then translate the target as a corrected source so you get the benefit of correct autolocalisation.

Alternatively just search & replace the target translation.

Apologies for misleading you earlier.

Regards

Paul


Direct link Reply with quote
 

Stanislav Pokorny  Identity Verified
Czech Republic
Local time: 13:28
English to Czech
+ ...
Group and decimal separators Nov 14, 2011

Hi Paul,
this thread is quite interesting for me because I often deal with source texts where group and decimal separators are used incorrectly.

It would be nice if both source-text and target-text group and decimal separtors could be set up on the project level, i.e. in the Project Settings, not just globally.

Do you think this would be feasible? My guess is that this can be already done using the Language Resource Templates (LRT), e.g. by creating new LRT for the recognition of incorrect separators. Is this idea correct, or totally misleading?

Thank you!


Direct link Reply with quote
 

hhl
Local time: 13:28
English to German
custom separator settings are a must Nov 14, 2011

Studio completely depends on Microsoft's country settings, which are not generally correct. And even if they were, there are chances (like in this thread), that you need to redefine them.

The Studio developers should finally go away from this dependence and better leave it to the translators, which charcters they want to use.
And yes, Stan, being able to define these project-dependent would be preferred.

This way I could finally advise Studio to use the correct grouping characters for German (a protected space, and not a point)!

[Edited at 2011-11-14 13:57 GMT]


Direct link Reply with quote
 
Witold Palka  Identity Verified
Poland
Local time: 13:28
Member (2005)
German to Polish
+ ...
TOPIC STARTER
So everything in hands of SDL... Nov 14, 2011

Thanks to All for input and discussion.

Stanislav, I was trying to help myself with LRT, no luck. If it's feaslible this way - it must be very well hidden and not intuitive.

SLD - as you can see this can be improved in the soft, because I saw many people complaining about it and all of them were using work-arounds.
So thank's in advance for including it in the next service pack.

Regards

WP


Direct link Reply with quote
 

István Hirsch  Identity Verified
Local time: 13:28
English to Hungarian
Workaround Nov 15, 2011

I do not know how you used the filter and Ctrl + H, I would do this to copy to the target side and convert segments which have only those numbers:

1. Filter the source segments with
^[0-9.]{1,}$
(to collect segments with those numbers).

2. Select and copy/paste the filtered segments to the target side:
Click on the first line, hold down Shift and click on the last line in the column of segment numbers (in front of the column of source segments). All (filtered) segments on the source side go brown/gold. Right click and select Copy Source to Target from the drop-down list.

3. Replace period with comma on the target side (uncheck Use wildcard!):

Find:
.
Replace with:
,

4. Restore All Segments by deleting the Containing box.

The numbers so transported are not in the tm – if it is needed, use a batch process or finalizing.


Direct link Reply with quote
 
Atso Puronen
Local time: 14:28
English to Finnish
Also a poor situation for Finnish... Apr 12, 2012

Hi,

My colleaques have a similar issue with decimal separators and Studio.

Our client sends us .csv workload reports which have commas as field separators. As the Finnish decimal separator is also a comma, we had to change the system decimal separator to a period in order to open those .csv files correctly (yes, we could batch convert the commas to semicolons before opening .csv files in Excel, but I've had too much resistance over the idea).

This obviously creates a problem with Studio when it now auto-substitutes decimal separators with periods instead of commas. This is not exclusive to SDL, it's a common problem for Microsoft and their other developers as well.

For us translators it's practically impossible to utilize centralized settings for locale information and still work fluently across languages. Therefore software developers should include an option to override the system settings whenever necessary.

Atso Puronen

P.S. I think comma-separated values are the worst invention since tomato wine. Tab-separated values are harder to get mixed up with anything useful.


Direct link Reply with quote
 
Richard Antonin  Identity Verified
Local time: 13:28
Member (2007)
English to Czech
Very helpful! I struggled with this issue in Studio 2011. Oct 19, 2012

SDL Support wrote:

Hi,

Go to your Windows Control Panel, then Region and Language. In here you can define the rules that Windows uses to recognise numbers. I just tested this quickly with English United Kingdomn and by adding a comma for the decimal serator and full stop for the list seperator for numbers I now get either commas or full stops recognised in English and they were correctly localised into German for me.

I would close Studio first and then restart after making the changes in Windows. I tested this with W7 so can't guarantee what might happen in other systems but it seems likely it should work ok.

Regards

Paul


Direct link Reply with quote
 


To report site rules violations or get help, contact a site moderator:


You can also contact site staff by submitting a support request »

Studio 2009: TM does not recognize nubmers

Advanced search







BaccS – Business Accounting Software
Modern desktop project management for freelance translators

BaccS makes it easy for translators to manage their projects, schedule tasks, create invoices, and view highly customizable reports. User-friendly, ProZ.com integration, community-driven development – a few reasons BaccS is trusted by translators!

More info »
PerfectIt consistency checker
Faster Checking, Greater Accuracy

PerfectIt helps deliver error-free documents. It improves consistency, ensures quality and helps to enforce style guides. It’s a powerful tool for pro users, and comes with the assurance of a 30-day money back guarantee.

More info »



Forums
  • All of ProZ.com
  • Term search
  • Jobs
  • Forums
  • Multiple search