Automatic confirmation of 100% matches & CM won't work
Thread poster: Peter Sass

Peter Sass
Germany
Local time: 09:30
Member
English to German
+ ...
Nov 16, 2011

Hi there,

For some reason the automatic confirmation of 100% and context matches in Studio 2009 doesn't work anymore when pre-translating documents. The target segments from the TM get inserted but not confirmed.
I have selected both the confirmation option in Options - Editor - Automation and in Options - All Language Combinations - 'Batch management' (I work with the German version so I'm not sure about the precise English terms) - Pre-translate.
Initially I had these options de-selected mistakenly, so I selected them again during work on a project, but now the confirmation feature won't work.
Could it be that it only works when setting up a project and running pre-translation but not when running the pre-translation function again?

Thanks for any hints on this, as it is quite time-consuming to manually confirm segments!

Peter


 

Anja Brito  Identity Verified
Canada
English to German
+ ...
same predicament Jan 20, 2012

Hi Peter,
Did you find a solution for this problem? I am in exactly the same situation right now - and any help with this would be greatly appreciated!!!
In the old SDLX, there used to be a menu option "confirm 100% matches" which would set all 100% to confirmed with one click - as simple as that! Surely there must be something like this in SDL 2009 SP3??? HELPicon_smile.gif
Anja


 

Peter Sass
Germany
Local time: 09:30
Member
English to German
+ ...
TOPIC STARTER
Several places to tick Jan 20, 2012

Hi Anja,

I'm not sure how and if I've solved the problem during the ongoing project, but as this problem comes up time and again I've found that there are two locations in SDL Trados Studio 2009 where you need to tick the box 'confirm 100 % matches':

a) the one mentioned before in Options - Editor - Automation and in Options - All Language Combinations - 'Batch management' (I work with the German version so I'm not sure about the precise English terms) - Pre-translate;
b) and in Options - Editor - All Language Pairs - Batch processing - Pretranslate

Also, for Context matches there's a box to tick in Editor – Autopropagate - Confirm segment after autopropagation.
When doing the pretranslation manually (with a project already set up) I'd also check whether the option 'confirm 100 % matches' is actually selected under batch processing - Pretranslate files.

So this is what my personal 'Studio checklist' includes about the problem, yet I still find that the function doesn't work properly all the time I'm afraid. It would certainly help if there were a button to manually confirm all 100% matches with one click, but as far as I know there is none in Studio. Hope this helps a bit - if you find anything new on how to make this function work better, please let me know and post here as well.

Best wishes

Peter


 

Tom Fennell
United States
Local time: 02:30
Member (2010)
Russian to English
+ ...
No automatic confirmation with AT segments Apr 3, 2012

I'm having a similar problem.

I am translating set of thousands of HTML files. I translated a "model" file and used AT when translating (mainly to fill in the English HTML in a RU>EN file).

I then went through and edited and manually confirmed these segments.

Then I created "clean" TM which contained only this model file.

After using this "model" TM to pre-translate other files, all the segments which were originally marked "AT" in the "model" file are still marked as "AT" segments in the other files, and they are not confirmed: the segment status is "draft." This despite the fact that I did everything I could to have the segments confirmed:

Project Settings>Language Pairs>All Language Pairs>Batch Processing>Pre-translate files

set to

"Confirm 100% Matches" and "Always overwrite existing translation"

and

Project Settings>Language Pairs>All Language Pairs>Translation Memory and Automated Translation>Penalties

set to
0 for Multiple translation penalty, Auto-localization penalty and Text replacement Penalty
1 for Missing formatting penalty and Different formatting penalty.


Any suggestions?

[Edited at 2012-04-03 21:46 GMT]


 

Peter Sass
Germany
Local time: 09:30
Member
English to German
+ ...
TOPIC STARTER
No news on my part Apr 4, 2012

Hi Tom,

I'm afraid I haven't found out anything new about this issue, so I can't help much further, but have you tried ticking this other box

Options - Editor - Automation - Confirm 100% match?

Good luck,

Peter


 

SDL Community  Identity Verified
United Kingdom
Local time: 09:30
English
AT or MT Apr 4, 2012

Tom Fennell wrote:

After using this "model" TM to pre-translate other files, all the segments which were originally marked "AT" in the "model" file are still marked as "AT" segments in the other files, and they are not confirmed: the segment status is "draft." This despite the fact that I did everything I could to have the segments confirmed:



Hi Tom,

Can you give me a small sample file I can test this process with? I have done this myself in the past and lost all the AT markers when I use the new TM on other files so I don;t know what's happenning here. I'm wondering if the segments in question are really AT'd by Studio rather than the MT provider, so this would make no difference whatever you did... but if it's all the segments irrespective of whether they are AT'able by Studio then I need to see what you have.

I don't think the settings you played with have anything to do with this particular issue.

Regards

Paul


 

Alexandre Oberlin  Identity Verified
France
Local time: 09:30
English to French
+ ...
Workaround: reload the source file Oct 28, 2012

Hi all,

Tom Fennell wrote:
This despite the fact that I did everything I could to have the segments confirmed:


I had exactly the same problem as you.

Normally the settings that are going to be applied are indicated and modifiable in the pre-translate wizard if you select Next rather than Finish. This is a nice feature, since the applied options may come from different settings (e.g. global options or Project settings, All language pairs or particular language pair, etc.). However, I had done everything to have the settings confirmed again (after having tried once to uncheck the Confirm boxes), and the wizard said it would confirm, but it did not.

The following workaround did the trick:

In Files view, select your source language in the drop-down list of the upper left corner

1. Select the offending .sdlxliff file and delete it:
Context menu >> Delete Files
(don't worry, despite the plural it deletes only the selected file(s))
2. Re add the corresponding source file:
Context menu >> Add Files
3. Rebuild the .sdlxliff:
Context menu >> Batch Tasks >> Convert to translatable format
4. Copy it in the target languages folder:
Context menu >> Batch Tasks >> Copy to Target Languages

The four steps above are the very ones you should perform every time the source file has changed for whatever reason.

Now select your target language in the drop-down list of the upper left corner and pre-translate your fresh .sdlxliff file(s):
1. Batch Tasks >> Pre-translate Files

Now your segments should be confirmed,

Hope it helps.

Cheers,

Alexandre


 

Jaco Breytenbach
South Africa
Local time: 09:30
English to Afrikaans
+ ...
How do you confirm 100% matches with one click - SDL Trados 2014? Jun 19, 2014

I am working on a series of similar documents and have a score of 100% matches. How do I confirm them all with one click?

 

Mpoma  Identity Verified
United Kingdom
Local time: 08:30
French to English
works for me in SDL Studio 2014 May 16, 2015

Options --> Editor --> Auto-propagation --> check "Confirm segment after auto-propagating an exact match"

 

alenius  Identity Verified
Croatia
Local time: 09:30
English to Bosnian
+ ...
Automatic copy from TM May 8, 2017

Hello,

How can I apply automatic inserting and confirmation of segments from TM? I opened the same file twice, and now I try to recover all translation from the old file and insert it automatically to the new one.

Thanks!


 

Daniela Alunni  Identity Verified
Italy
Local time: 09:30
Member (2008)
English to Italian
+ ...
Thank you!! It works in Studio 2017 as well;) Aug 21, 2017

Mpoma wrote:

Options --> Editor --> Auto-propagation --> check "Confirm segment after auto-propagating an exact match"


 

Luca Tutino  Identity Verified
Italy
Local time: 09:30
Member (2002)
English to Italian
+ ...
This still an unresolved problem in Trados 2017!! Jan 10

Apparently, despite all the settings, there is no way to confirm automatically the 100% and CM with only numbers changed, in alphanumeric strings. The Translation results window recognizes them, applies the right numbers and marks them as 100%, but then it stops and waits for manual confirmation. HUGE waste of time in technical catalogs!!!

 


To report site rules violations or get help, contact a site moderator:


You can also contact site staff by submitting a support request »

Automatic confirmation of 100% matches & CM won't work

Advanced search







SDL MultiTerm 2017
Guarantee a unified, consistent and high-quality translation with terminology software by the industry leaders.

SDL MultiTerm 2017 allows translators to create one central location to store and manage multilingual terminology, and with SDL MultiTerm Extract 2017 you can automatically create term lists from your existing documentation to save time.

More info »
Anycount & Translation Office 3000
Translation Office 3000

Translation Office 3000 is an advanced accounting tool for freelance translators and small agencies. TO3000 easily and seamlessly integrates with the business life of professional freelance translators.

More info »



Forums
  • All of ProZ.com
  • Term search
  • Jobs
  • Forums
  • Multiple search