Perils of Parallels
Thread poster: Vadim Zima

Vadim Zima  Identity Verified
Local time: 18:34
English to Russian
+ ...
Dec 13, 2011

I am speaking about Parallels Desktop 7 for Mac, which allows me to work in SDL Trados without leaving my Mac. I am using Windows 7 32-bit, and so far I have had no problems. Today, however after hitting some unfortunate key combination I was practically paralyzed. I could not go on with my work because I activated "Text overwrite", which I didn't need or want. I can see OVR in the bottom status (?) bar of my Editor window, and cannot figure out how to deactivate it. Double clicking on it has no... See more
I am speaking about Parallels Desktop 7 for Mac, which allows me to work in SDL Trados without leaving my Mac. I am using Windows 7 32-bit, and so far I have had no problems. Today, however after hitting some unfortunate key combination I was practically paralyzed. I could not go on with my work because I activated "Text overwrite", which I didn't need or want. I can see OVR in the bottom status (?) bar of my Editor window, and cannot figure out how to deactivate it. Double clicking on it has no effect.

I spent three or four hours looking for a solution, but could not find any meaningful info neither in the Trados help, nor in "google help". Does anybody else here use a similar setup? The keyboard I am using when in Windows is the Microsoft Natural Keyboard 4000 USB.

Any leads?
Collapse


 

Sam Pinson  Identity Verified
United States
Local time: 19:34
Member (2011)
Russian to English
Insert key? Dec 13, 2011

Does pressing the "Insert" key help?

 

Vadim Zima  Identity Verified
Local time: 18:34
English to Russian
+ ...
TOPIC STARTER
That's the first thing I tried... Dec 14, 2011

Sam Pinson wrote:
Does pressing the "Insert" key help?
No, it doesn't. But the problem may be hidden in the maze of relationships and dependancies of Parallels devices and the host Macintosh settings. There are too many factors that can affect the keyboard's behavior...

I hope there is some path to a menu in the Studio itself that allows activate/deactivate text overwriting.


 

Adam Podstawczynski (X)  Identity Verified
Local time: 03:34
Polish to English
+ ...
AutoHotkey Dec 14, 2011

Hi Vadim,

Most probably your Parallels does not forward the Insert key code properly to Windows. If that is so:

Install the free AutoHotkey (which is useful to a Translator for many other purposes too), and remap any button to "Insert", e.g. put this in the configuration file:

RAlt::Insert

The above will remap the right Alt to "proper" Windows Insert key.

Since AutoHotkey is a Windows application, it has nothing to do with Parallel
... See more
Hi Vadim,

Most probably your Parallels does not forward the Insert key code properly to Windows. If that is so:

Install the free AutoHotkey (which is useful to a Translator for many other purposes too), and remap any button to "Insert", e.g. put this in the configuration file:

RAlt::Insert

The above will remap the right Alt to "proper" Windows Insert key.

Since AutoHotkey is a Windows application, it has nothing to do with Parallels. It will throw the proper Insert keycode within Windows itself.

Mind you, I have not tried this particular example, so you won't know until you try. But I did try many other keycode experiments using AutoHotkey, and the software has been extremely helpful in similar situations.
Collapse


 

Johanna Liljenzin  Identity Verified
Sweden
Local time: 03:34
Member (2009)
English to Swedish
+ ...
Fn + return Dec 14, 2011

Vadim,

This happened to me, as well, when I first started working in Parallels. Luckily, I found very easy shortcut that solves this problem:

Simply hold down the function key [fn] and press return.

(To turn on overwriting mode again, use the same shortcut.)

Kind regards,
Johanna


 

Vadim Zima  Identity Verified
Local time: 18:34
English to Russian
+ ...
TOPIC STARTER
Fn+Return did it! Dec 14, 2011

Johanna Liljenzin wrote:
Simply hold down the function key [fn] and press return.
(To turn on overwriting mode again, use the same shortcut.)
Thank you, dear Johanna!
Silly me, I should've guessed it. "Fn" is right next to "Ctrl", which together with "Return" is used to accept a segment.

Adam, thank you for your suggestion. I played with AutoHotkey (both basic and L) but didn't have any success. It's a nifty little thing, but in MacOS we have our own toys. I wish I had more time to play.


 


To report site rules violations or get help, contact a site moderator:


You can also contact site staff by submitting a support request »

Perils of Parallels

Advanced search







SDL Trados Studio 2019 Freelance
The leading translation software used by over 250,000 translators.

SDL Trados Studio 2019 has evolved to bring translators a brand new experience. Designed with user experience at its core, Studio 2019 transforms how new users get up and running, helps experienced users make the most of the powerful features.

More info »
Déjà Vu X3
Try it, Love it

Find out why Déjà Vu is today the most flexible, customizable and user-friendly tool on the market. See the brand new features in action: *Completely redesigned user interface *Live Preview *Inline spell checking *Inline

More info »



Forums
  • All of ProZ.com
  • Term search
  • Jobs
  • Forums
  • Multiple search