Trados Studio 2009 :: Updating translation units after TM changes
Thread poster: Kathy Prochaska

Kathy Prochaska  Identity Verified
Germany
Local time: 01:26
Member (2007)
French to German
+ ...
Dec 16, 2011

Dear collegues,

I am working with Trados Studio 2009 on a huge project consisting in several files. During the working process, it can happen that I decide to translate a term differently. As there are many translation files in my project and I lose track of which specific file contains which specific terms, I do not want to open every file and to check manually if it contains my updated term. I know that I can open the translation memory in the TM editor and filter out only those translation units (via source text for example) including the specific term. But after saving my changes in the TM, how do I update the translation files? The batch process "pretranslate" does not change the old TM units into the new. Opening a translation file that contains the changed term, I have to see that it has not been updated.

Does anyone have an idea? Thank you very much!

Kind regard,
Kathy


Direct link Reply with quote
 

Emma Goldsmith  Identity Verified
Spain
Local time: 01:26
Member (2010)
Spanish to English
SDL Batch Find/Replace Dec 16, 2011

I would recommend using SDL Batch Find/Replace, an OpenExchange app where you add xliff files and perform find&replace.

http://www.sdl.com/en/language-technology/sdl-openexchange/AppDetails.aspx?appid=35

If I have a project with lots of files, I usually merge them when creating the project in order to avoid the situation you describe. Also, autopropagation works can be really useful for repetitions between different files if they are merged into one.

HTH.


Direct link Reply with quote
 
Atso Puronen
Local time: 02:26
English to Finnish
See Batch task settings Dec 19, 2011

Hi Kathy,

You need to change the settings of the Pre-translate Files batch task in order to get your units updated.

1. Select Batch tasks > Pre-translate Files.
2. Advance to Settings pane and select Language Pairs > All Language Pairs > Batch Processing > Pre-translate Files.
3. From Translation overwrite mode menu, select Always overwrite existing translation.

This forces your units to be updated from TM. Default setting won't update your unit if its match is not better than last time. Also, if you have used several TMs as leverage, I suggest you temporarily disable them (leave just the updated TM enabled). I've had issues where Studio doesn't respect the TM order and selects a match from a TM that gave the match last time.


Direct link Reply with quote
 


To report site rules violations or get help, contact a site moderator:


You can also contact site staff by submitting a support request »

Trados Studio 2009 :: Updating translation units after TM changes

Advanced search







memoQ translator pro
Kilgray's memoQ is the world's fastest developing integrated localization & translation environment rendering you more productive and efficient.

With our advanced file filters, unlimited language and advanced file support, memoQ translator pro has been designed for translators and reviewers who work on their own, with other translators or in team-based translation projects.

More info »
LSP.expert
You’re a freelance translator? LSP.expert helps you manage your daily translation jobs. It’s easy, fast and secure.

How about you start tracking translation jobs and sending invoices in minutes? You can also manage your clients and generate reports about your business activities. So you always keep a clear view on your planning, AND you get a free 30 day trial period!

More info »



Forums
  • All of ProZ.com
  • Term search
  • Jobs
  • Forums
  • Multiple search