Why can't I upgrade my .tmx TM from Workbench to Studio 2011?
Thread poster: Fredrik Pettersson

Fredrik Pettersson  Identity Verified
Hong Kong
Member (2009)
English to Swedish
+ ...
Dec 17, 2011

I received a .tmx file from my customer that was exported from a SDL Trados 2007. I need to upgrade this to .sdlxliff so I can use it when translating in SDL Trados Studio 2011.

But it didn't work to directly upgrade in SDL Trados Studio 2011, I receive this error message when I have started the wizard in SDL Trados Studio 2011 for upgrading:

The translation memory ... could not be loaded: "\' is an unexpected token. The expected token is ';'. Line 1122, position 29.'


Direct link Reply with quote
 

Stephanie Busch  Identity Verified
Germany
Local time: 04:18
Member (2010)
English to German
+ ...
Create new TM and import TMX Dec 17, 2011

Hi Fredrik,

you can't upgrade an exported TMX file because it is not a TM. (The file extension of Trados 2007 TMs is TMW.)

In order to work with TMX files in Studio, you need to create a new TM in Studio and import the TMX file into it. This will work when it's a TMX 1.4b file.

HTH
Stephanie


Direct link Reply with quote
 

Fredrik Pettersson  Identity Verified
Hong Kong
Member (2009)
English to Swedish
+ ...
TOPIC STARTER
Still the same error message Dec 17, 2011

Hi Stephanie,

Thanks for clarifying for me, I remember long ago I exported a tmw-file (or was it .tmx?) from Workbench and chose the alternative 1.4b.

I thought it would work now but on the last step, after I've created the TM in Studio and imported the .tmx-file, I received exactly this same error message.

Do you think perhaps the customer did not choose alternative 1.4b when she exported the .tmw-file to .tmx? I know she uses SDL Trados 2007.

Or does it have anything to do with language settings for the TM (I created the TM with British English as source)? If the import file contains American English, would the import fail?

Or is there any character on that line in the error message that I need to delete, by opening the actual .tmx file in a text editor? As they discuss in this ProZ-forum topic:

http://www.proz.com/forum/sdl_trados_support/146774-problems_importing_tmx_into_trados.html


Direct link Reply with quote
 

Fredrik Pettersson  Identity Verified
Hong Kong
Member (2009)
English to Swedish
+ ...
TOPIC STARTER
Import as plain text did not work either Dec 17, 2011

I tried to import the translation units as plain text to avoid any problems with the tags as well as the alternative "The imported data will be primarily used in mixed scenarios". But the same error message is still displayed.

[Edited at 2011-12-17 13:40 GMT]


Direct link Reply with quote
 

Stephanie Busch  Identity Verified
Germany
Local time: 04:18
Member (2010)
English to German
+ ...
Better make sure about the TM settings Dec 17, 2011

Hi Fredrik,

I have never experienced TMX import issues myself, but I suggest that you make sure about the correct TM settings.

When you open the TMX file in a text editor, you can see the source language, either from the "srclang=" string in the file header, or by scrolling down to the individual segments.

The third line of the TMX file will show either "tmx version=1.1" (for the TMX 1.1 file type) or "tmx version=1.4"" (for the TMX 1.4 and 1.4b file types). So you can at least see whether it's the 1.1 file type that you can't use for Studio. (I have just tried exporting a TM as 1.4 and 1.4b, and indeed both have the same "tmx version=1.4" string in the TMX file.)

What you can also do of course if you've got Trados 2007 as well is to create a Trados 2007 TM, import the TMX file, and re-export it as TMX 1.4b, as suggested by Farkas in the thread you mentioned. (Or instead of re-exporting, upgrade the Trados 2007 TM (TMW) with Studio's wizard.)

Failing that, you can try to locate the "token" Studio objects to ("&"), and replace it with an appropriate one, as Farkas also suggests.


Direct link Reply with quote
 

Stefan Gentz
Local time: 04:18
English to German
+ ...
Incompatible TMX Code Dec 17, 2011

Dear Fredrik,

there is something wrong or incompatible in your TMX file. Without seeing the acual code it's impossible to solve this. Please open the TMX file in an XML editor or in Windows Notepad. Go to Line 1122 (use Ctrl+G to jump to this line directly) and copy this line with a few lines before and after this line to this forum. Try to copy everything starting between <tu> and </tu>.

Should look like similar to this (probably more complex):

<tu>
<tuv xml:lang="de-DE"><seg>Hilfe</seg></tuv>
<tuv xml:lang="en-GB"><seg>Help</seg></tuv>
</tu>

Important: make sure to replace all < with &lt; and > with &gt; in this forum editor here, otherwise the code will not be visible.

Then we can analyse it in more detail.

Kind regards,
Stefan Gentz

TRACOM OHG Consulting | Training | Services

[Bearbeitet am 2011-12-17 15:18 GMT]


Direct link Reply with quote
 

Fredrik Pettersson  Identity Verified
Hong Kong
Member (2009)
English to Swedish
+ ...
TOPIC STARTER
The TMX was created in WordFast and not Workbench Dec 17, 2011

Hi again Stephanie,

I opened the TMX with Notepad++ to check the version and language locale. These were 1.4b and GB so that was in order.

The row that Studio for some reason doesn't accept looks like this:

pt i="1"> 1 2 &fA\;;Rekommenderad <2>pt i="1">} 2 fA

I've tried to change by removing the backslash etc. but can't get it to work.


Direct link Reply with quote
 

Fredrik Pettersson  Identity Verified
Hong Kong
Member (2009)
English to Swedish
+ ...
TOPIC STARTER
Worked now! Dec 17, 2011

It worked now! I did as Farkas suggested and changed the faulty reference to &
After that I could import all the TU:s.


Direct link Reply with quote
 

Fredrik Pettersson  Identity Verified
Hong Kong
Member (2009)
English to Swedish
+ ...
TOPIC STARTER
More lacks of closing Dec 17, 2011

There were many more lacks of closing but it seems it will work out in the end anyway.

Direct link Reply with quote
 

Fredrik Pettersson  Identity Verified
Hong Kong
Member (2009)
English to Swedish
+ ...
TOPIC STARTER
Best solution was to import to Workbench Dec 17, 2011

The absolutely easiest was to create a new TM in SDL Trados 2007 and import the TMX file as Farkas suggested.

When I then upgraded the TMW to Studio I didn't have any problems doing so.


Direct link Reply with quote
 


To report site rules violations or get help, contact a site moderator:


You can also contact site staff by submitting a support request »

Why can't I upgrade my .tmx TM from Workbench to Studio 2011?

Advanced search







CafeTran Espresso
You've never met a CAT tool this clever!

Translate faster & easier, using a sophisticated CAT tool built by a translator / developer. Accept jobs from clients who use SDL Trados, MemoQ, Wordfast & major CAT tools. Download and start using CafeTran Espresso -- for free

More info »
Anycount & Translation Office 3000
Translation Office 3000

Translation Office 3000 is an advanced accounting tool for freelance translators and small agencies. TO3000 easily and seamlessly integrates with the business life of professional freelance translators.

More info »



Forums
  • All of ProZ.com
  • Term search
  • Jobs
  • Forums
  • Multiple search