International Translation Day 2018

Join ProZ.com/TV for a FREE event September 25-26th celebrating International Translation Day! 50+ hours of content, Chat, Live Q&A & more. Join 1,000's of linguists from around the globe as ProZ.com/TV celebrates International Translation Day.

Click for Full Participation

TagEditor corrupts characters that are correct in Workbench
Thread poster: Dennis Boffy

Dennis Boffy
Denmark
Local time: 17:30
English to Danish
+ ...
Feb 14, 2012

I am using Trados 2007 (7.1.0.600 build 863) to translate a Doc file delivered by my client as a TTX (with an ini file which I have selected in Tageditor). Every time Workbench finds a match, it is displayed correctly in Workbench, but in Tageditor the Danish letters æ, ø and å and the following character are replaced by a question mark. I have had this problem before, so it is not linked specifically to this TTX file.

After searching in this forum I have tried exporting my TM, removing most of the fonts and all the styles and re-importing in a new TM, but this has not resolved the problem. The language setting in Windows (Win 7) is Danish. Can anyone help?


 

Jerzy Czopik  Identity Verified
Germany
Local time: 17:30
Member (2003)
Polish to German
+ ...
Why INI for a doc file? Feb 14, 2012

Did you create the TTX file on your own by opening a Word document (a doc file) in your TagEditor?
If yes, then please do the following: close Tageditor and Workbench.
Go to Filter Settings (in the same program group, where you would start Workbench - subgroup Filters) and change the settings so, that Tageditor will NOT show display formatting:


Then RECREATE the TTX from DOC and try again.

BTW, is your Trdaos version really 7.1.0.600 bukd 863) - this wouldn't be Trados 2007 afair, but Trados 2006. In that case the above might not work.
Check the fonts used in Word before you open it in Tageditor, most probably a font is used, which you do not have on your system. Replace the fonts by such which you do have or ask the customer for advice and help.


 

Ulrika Mansson
Local time: 17:30
German to Swedish
+ ...
edit TM and create new Feb 14, 2012

Hi,
according to SDL support this problem can be solved by following these steps:

IMPORTANT: make a backup copy of your TM before you start.

1. Open your translation memory (make sure that you check the Exclusive option when opening it).
2. From the File menu, select Export.
3. In the Export dialog box, simply click OK.
4. Choose an appropriate folder and file name for your export file.
5. Open the exported file in a text editor like Notepad or (if it's a really big file) Word.
6. In the section of the file, look for following line:
{\fonttbl

This is the start of the font table. Leave the first 2 lines untouched:
{\f1 \fmodern\fprq1 \fcharset0 Courier New;} {\f2 \fswiss\fprq2 \fcharset0 Arial;}

but select the following line ({\f3) until the last font (starting with {\f followed by a number). Be very careful while selecting (don't select a partial line, for instance). Then delete your selection.

7. Create a new translation memory with the same language pair (don't use the Copy button).
8. While the new translation memory is open, select the Import command from the File menu.
9. In the Import dialog box, click OK (leave the default options), and then select the file you've just modified.
10. When the import is done, your translation memory should be fixed.

/Ulrika


 

Dennis Boffy
Denmark
Local time: 17:30
English to Danish
+ ...
TOPIC STARTER
Customer delivered Doc and INI Feb 14, 2012

No, my client delivered the Doc and INI files. I'm not sure why, perhaps because the contents is from a website. I tried disabling the options you mentioned anyway, but I received an error.

And the Trados version is correct - and it says "Part of SDL Trados 2007"...


 

Jerzy Czopik  Identity Verified
Germany
Local time: 17:30
Member (2003)
Polish to German
+ ...
7.1.0.600 is a very old version of Trados Feb 14, 2012

And the Tageditor in this version has had its problems with Word files.
Nevertheless, for a Word file you do not need any INI file.
Check the Word file for fonts used.

As for the font table in TM: you can delete the whole font table. Makes no difference if you delete all entries or just a few. In the TXT export you must just leave the lines where the words "font table" are written, everything between those lines may be deleted.


 

Dennis Boffy
Denmark
Local time: 17:30
English to Danish
+ ...
TOPIC STARTER
Problem solved Feb 14, 2012

Ulrika Mansson wrote:

7. Create a new translation memory with the same language pair (don't use the Copy button).



Thanks a lot, it worked! I already tried this trick before, but I used the Copy button, and the problem continued. This time I did not use the Copy button thanks to your suggestion, and that solved the problem. Thanks again!


 

Stefan de Boeck (X)  Identity Verified
Belgium
Local time: 17:30
English to Dutch
+ ...
utf-8 Feb 14, 2012

Dennis Boffy wrote:
... in Tageditor the Danish letters æ, ø and å and the following character are replaced by a question mark. ... I have tried exporting my TM, ...

My idea would be to have another look at both the TTX file and in particular the TM_export (txt or tmx). Save both as utf-8 (or unicode if you must) and start with a brand new TM.
The problem should be gone now.


 


To report site rules violations or get help, contact a site moderator:


You can also contact site staff by submitting a support request »

TagEditor corrupts characters that are correct in Workbench

Advanced search







SDL MultiTerm 2019
Guarantee a unified, consistent and high-quality translation with terminology software by the industry leaders.

SDL MultiTerm 2019 allows translators to create one central location to store and manage multilingual terminology, and with SDL MultiTerm Extract 2019 you can automatically create term lists from your existing documentation to save time.

More info »
PerfectIt consistency checker
Faster Checking, Greater Accuracy

PerfectIt helps deliver error-free documents. It improves consistency, ensures quality and helps to enforce style guides. It’s a powerful tool for pro users, and comes with the assurance of a 30-day money back guarantee.

More info »



Forums
  • All of ProZ.com
  • Term search
  • Jobs
  • Forums
  • Multiple search