Trados 2011 emergency: Urgently trying to save to target and failing miserably no matter what I do
Thread poster: Sarah Downing

Sarah Downing  Identity Verified
Local time: 13:22
German to English
+ ...
Mar 6, 2012

Unfortunately, I’m having a Trados emergency and I’m concerned that the agency I work with won’t be able to help me either, so they asked me to ask anyone I know at Trados if they know an answer. God, I hope someone does because I am unable to save the translation to target.

Basically, I finished the translation last night and it looked like it had saved fine as the target in 2011, but when I opened the Word file this morning (after the client told me they couldn't open it) it told me:

The file X.docx cannot be opened because there are problems with the contents.

I clicked on Details >>>

and it told me: Unexpected end of input.

Location: Part: /word/document.xml, Line: 36219, Column: 6059


I then tried to open the file in 2009 in hopes that I could save it to target there (because in the past some glitches have been existent in 2011 and not in 2009). But no apparently it is the file, but this time I actually got a message:

Failed to save target content: Missing tag ‘’in segment. Please run the Tag Verification to see details.

When I clicked on Tools-Verification, I got the same error message (red cross) and it tells me the origin is “File Writing”, but unlike the other error and warning messages clicking on the error message doesn’t take me to it.

So right now I’m at a loss as to what to do. Sadly, the job is due today and I thought it had saved fine last night and forgot to double-check by opening the Word file (before anyone says anything, I too am only human;-)), so now I’m in a bit of a conundrum to say the least.

I even tried to open the file in WordPad to see if there was anything I could see there and whilst it opens all it shows is gobbledegook.

I’m hoping someone here understands these error messages better than I do and has an idea how I can solve them, so that I can save my metaphorical bacon and deliver the file after all.

Thanks in advance!

Sarah


Direct link Reply with quote
 

ghislandi  Identity Verified
Local time: 18:22
English to Italian
Help Mar 6, 2012

Hello
I am from SDL - I wonder if you would be ok to send us the file so we can take a look?

Regards
Massi


Direct link Reply with quote
 

Sarah Downing  Identity Verified
Local time: 13:22
German to English
+ ...
TOPIC STARTER
Thanks, Massi, which address should I send it to? Mar 6, 2012

Thanks, Massi:-). Which address should I send it to? Is it listed in your profile?

Regards,

Sarah

[Edited at 2012-03-06 14:44 GMT]

[Edited at 2012-03-06 14:55 GMT]


Direct link Reply with quote
 

Sarah Downing  Identity Verified
Local time: 13:22
German to English
+ ...
TOPIC STARTER
Thanks, Massi, I received your email and have forwarded you the file Mar 6, 2012

Thanks again:-).

Regards,

Sarah


Direct link Reply with quote
 
FarkasAndras
Local time: 19:22
English to Hungarian
+ ...
Post the outcome Mar 6, 2012

Please update us on how this is resolved in the end so other people with the same problem have something to go by in the future.

Some advice in the meantime based on what I do to avoid/resolve problems of this sort:

- When starting a job, test whether the file imports correctly. You can just click File/Save target as...
If everything checks out, you're not likely to run into problems at the end, or if you do, you'll at least know that the problem was introduced in the translation stage (subscripts, superscripts, merged/split sentences and missing/added/wrong tags have been known to cause problems).

- When the smelly stuff has already hit the fan: try and repeat the import/translate/export workfow with some tweaks. For instance, resave the original .doc file as .docx or .rtf, open it with Trados, translate it with your TM (if you didn't split/merge many segments, it should only take a minute or two), then export it. Or do the same with TagEditor instead of Studio.


Direct link Reply with quote
 

Sarah Downing  Identity Verified
Local time: 13:22
German to English
+ ...
TOPIC STARTER
Thanks so much, Massi - you did save my bacon!:-) Mar 6, 2012

Copying Massimo's message below:

Hi Sarah

It looks like we found the issue. At first look it appears that a header in the source file caused some troubles.
See attached the fixed files.
Do please give it a check.

We are investigating nonetheless what happened. If you need to save the file again - the issue might reoccur until we have fully understood the reason for it.

So unfortunately, I can't tell you anything more specific. However, another friend with MemoQ also sent me a usable version of the file by using CodeZapper on the Word file and running it through MemoQ again. That seemed to work too, although we weren't sure whether it was as clean a convert. I guess many roads lead to Rome.

Thanks for your advice, FarkasAndras - that makes a lot of sense and I should always check to see I can save to target, although I often do forget. Reimporting and retranslating the file was the last resort for this project because there were so many tags and I was worried about disturbing them, but that makes sense too.

All the best,

Sarah


Direct link Reply with quote
 

Conor Murphy  Identity Verified
United Kingdom
Local time: 18:22
German to English
I am encountering the same problem here. What's the solution? Aug 30, 2013

Hi all,

I am currently translating a 7500 word docx file using Studio 2011 with track changes turned on (it's a updated version of some terms and conditions).

The file contains a great number of changes.

I thought I would see how it came out again in Word, so I hit "Save target as". But when I try to open the file in Windows Explorer, I get the error message "The file XXXXXX cannot be opened because there are problems with the contents.

Clicking on Details I get "Unexpected end of input. ... Location: Part:/word/document.xml, Line: 15463, Column 14.

I am at a total loss here and need to deliver at noon.

Sarah Downing mentioned a MemoQ / Codezapper solution. I have MemoQ though I have never actually used it. How might this solution work?

Thanks in advance.


Direct link Reply with quote
 
ma1cius
United Kingdom
Local time: 18:22
French to English
+ ...
Possible workaround Dec 10, 2014

I came across this issue with a file a colleague was working on and managed to open it in WordPad.
Obviously this solution may lose some formatting but if the file is fairly straightforward, it may be better than the alternatives.

There is now an SDL Knowledge Base article relating to this issue (or at least a very similar one) at
http://kb.sdl.com/?portalid=23&articleid=4802#tab:homeTab:crumb:7:artId:4802

I hope this is helpful


Direct link Reply with quote
 
Vojtěch Olšan
Czech Republic
Solution, but coding required! Jun 23

Hello,
I have this problem quite often. The problem is that for some reason Trados doesn't export the target file properly and there is a part of code missing the document.xml. DOCX files are essentially just a zip file containing different XML files so if you open the zip and go to the folder word, you will find the document.xml and if you compare the document.xml from the source file and the target file, there is usually a piece of code missing, so you have to find what is missing and copy it from source to target, then it opens correctly.
We are still using Trados Studio 2014 so I hope the problem is fixed in higher versions.
Hope it helps,
Vojtech


Direct link Reply with quote
 


To report site rules violations or get help, contact a site moderator:


You can also contact site staff by submitting a support request »

Trados 2011 emergency: Urgently trying to save to target and failing miserably no matter what I do

Advanced search







Déjà Vu X3
Try it, Love it

Find out why Déjà Vu is today the most flexible, customizable and user-friendly tool on the market. See the brand new features in action: *Completely redesigned user interface *Live Preview *Inline spell checking *Inline

More info »
memoQ translator pro
Kilgray's memoQ is the world's fastest developing integrated localization & translation environment rendering you more productive and efficient.

With our advanced file filters, unlimited language and advanced file support, memoQ translator pro has been designed for translators and reviewers who work on their own, with other translators or in team-based translation projects.

More info »



Forums
  • All of ProZ.com
  • Term search
  • Jobs
  • Forums
  • Multiple search