Pages in topic:   [1 2] >
How to convert/open bilingual Excel in Studio
Thread poster: Ivaylo Ivanov

Ivaylo Ivanov  Identity Verified
Luxembourg
Member (2005)
English to Bulgarian
+ ...
Mar 21, 2012

Hi,

I have an Excel file with source text in column A and its translation in column B.

Please advise me how to convert this so that I can open the resulting file in Trados Studio.

I need this because I have to run the terminology verifier. My only task is to check the terminology.

I have an online Multiterm database, I don't have an access to export it but I can attach it to Trados.

Any ideas?


Direct link Reply with quote
 

SDL Community  Identity Verified
United Kingdom
Local time: 05:25
English
Save the file as CSV Mar 22, 2012

Hi,

If you save the file as CSV then this is simple. For example I have this file:


I save this as a CSV and then make sure the CSV filetype is set up to match it like this:


Then when I open the file in Studio I see this:


Regards

Paul


Direct link Reply with quote
 

Ivaylo Ivanov  Identity Verified
Luxembourg
Member (2005)
English to Bulgarian
+ ...
TOPIC STARTER
Thank you, Paul Mar 22, 2012

Simple and easy...

You're helpful as always!


Direct link Reply with quote
 

Ivaylo Ivanov  Identity Verified
Luxembourg
Member (2005)
English to Bulgarian
+ ...
TOPIC STARTER
Any idea about this one? Mar 22, 2012

http://www.proz.com/forum/sdl_trados_support/218156-how_to_recreate_the_multiterm_database_from_xml_export.html#1891793

Direct link Reply with quote
 

Selcuk Akyuz  Identity Verified
Turkey
Local time: 07:25
Member (2006)
English to Turkish
+ ...
Feature unique to Studio Mar 23, 2012

AFAIK, "bilingual" CSV support is available only in Studio. It could save me at least 5 minutes in each project as I receive such excel files almost everyday.

However, saving as CSV from Excel sometimes cause problems in particular if a segment ends with a comma. And encoding problems are possible to occur.

I would use Notepad++ to create a CSV file.

Copy table from Excel
Paste in Notepad++ (you will notice that delimiter is TAB)
Change encoding to UTF-8
Save as Text file
Change extension to CSV
When importing to Studio select TAB as delimiter


Direct link Reply with quote
 

prmueller  Identity Verified
Germany
Local time: 05:25
Member (2008)
English to German
Lost when trying to import Apr 3, 2012

Selcuk Akyuz wrote:
When importing to Studio select TAB as delimiter


How would I do that? This is what I tried:

1. Create a new project in Trados (2011 in my case) or open an existing one.
2. Go to the Files section
4. In the left panel, change the language to source language
5. Right-click on the project file in the section "Project folder".
6. In the pop-up menu, chose "Add file". Now the file is in your project list.
7. Right-click it an chose "Batch Tasks" and then "Prepare". The assistant for adding files comes up.
8. There, in the dialog, the second screen is "Settings". Here you can edit the file type and change it to TAB separated.
9. Press "Finish".
10. Trados acts up and reports that it cannot read the file.


Here is how I got it to work:

1. In Excel, copy the Target column to a new document. Replace all commas in the target text with another ASCI symbol (I used #, as it was not used in my text) using Excel's search and replace feature.
2. Paste the edited column back to your source document.
3. Now, both columns (source and target) from the Excel source document into a text editor.
[I am working on a Mac, so I used the free TextWrangler http://www.barebones.com/products/textwrangler/ - as far as I know there's a Windows version, too.]
4. Save the document as a CSV file. For "Line breaks", chose Windows (CRLF), for "Encoding" select Unicode (UTF-16) (This is important: If you use UTF-8, all your non-ASCI letters like German Umlauts in my case will be lost. UTF-16 is perfect for non-English languages.).
5. Now import it into Trados (see above, drop step 8)
6. You got a perfectly aligned document in Trados now. Check the number of segments to see whether it matches the rows in your Excel file.
7. Now replace your special character with the "Replace all" command with comma. Voila!


If someone from Trados should ever read this:
This is truly a pain-in-the-ass approach on importing a bilingual Excel file into Trados. A professional application like Trados should have a user-friendly out-of-the-box solution for this. Or at least truly support TSV files.



[Bearbeitet am 2012-04-03 14:16 GMT]


Direct link Reply with quote
 

Ivaylo Ivanov  Identity Verified
Luxembourg
Member (2005)
English to Bulgarian
+ ...
TOPIC STARTER
Tab-delimited Apr 3, 2012

prmueller wrote:
When I use the "Add file" command in the files section, I have tons of formats to chose from, but TSV (tab separated values) is not one of them. How do I import a TAB delimited file?


Use csv file but specify a tab as a delimiter. See the second screenshot above


Direct link Reply with quote
 

Birthe Omark  Identity Verified
Denmark
Local time: 05:25
Member (2006)
French to Danish
+ ...
What if there is a comma in the target text (pre-translated)? Jul 7, 2012

Thank you.
I thought this thread hit the nail, until I found that a comma in the target text overrules the column (tab) so that my transtion units show the source text + the first part of the target text to the left (source) and the remainder of the translated sentence to the right (target).
I was wondering if this could be solved by adding an extra tab when checking the txt-file.

Maybe there is a far better solution at hand?

Kind regards,
Birthe


Direct link Reply with quote
 

prmueller  Identity Verified
Germany
Local time: 05:25
Member (2008)
English to German
Here's a better alternative May 6, 2014

After giving up frustrated with yet another bilingual Excel file that would produce totally mixed up results with Trados 2014 SP1 alignment I finally found something that works:
http://sourceforge.net/projects/aligner/

LF Aligner is open source software and freely available for a number of operating systems. On my Mac it runs in Terminal, but to my amazement I found it to be more intuitive than Trados. Plus, I got a neatly aligned file exported into TMX at the end. Way to go.


Direct link Reply with quote
 

SDL Community  Identity Verified
United Kingdom
Local time: 05:25
English
This has to be down to file preparation... May 6, 2014

... in either the source file or the filetype Studio uses. In one of the original posts the changes were made too late in the process to take effect.

If anyone is able to share one of these files with me (if still interested) then I'll have a go and maybe record the process to make it clear?

Certainly there seems little point in aligning bilingual excel files as they are already aligned (unless you want the formatting if there is any).

Regards

Paul


Direct link Reply with quote
 

Darius Daniel Grigoras  Identity Verified
Romania
Romanian to English
+ ...
I can't import a CSV file in a project Jun 2, 2014

I created a project and then tried adding a CSV file in SDL Studio 2014, but I received the following warnings:



Also, there are no batch tasks for it:



[Edited at 2014-06-02 07:03 GMT]


Direct link Reply with quote
 

SDL Community  Identity Verified
United Kingdom
Local time: 05:25
English
Tricky without seeing the file... Jun 2, 2014

... to understand why you get this message. Clearly Studio doesn't think the settings in the CSV filetype for your project match your CSV.

On the batch tasks, I guess if the file was not recognised then it was probably added as a reference file. This being the case batch tasks seem as though they should not be available (I did not test this, but it seems logical).

So if we can figure out why the file was not recognised this will probably resolve your batch task issue too.

Maybe share a screenshot of your CSV settings in your Project Settings, and explain what the CSV contained and how you wish it to be treated.

Regards

Paul


Direct link Reply with quote
 

Darius Daniel Grigoras  Identity Verified
Romania
Romanian to English
+ ...
Options vs. Project Settings Jun 2, 2014

Dear Paul,

Apologies for my late reply, but I hadn' received any notification of your post.

Indeed, it was added as a reference file, and I couldn't change its status because I haven't changed the filetype settings under the Project Settings, where I should have changed them, but under General Options.


Direct link Reply with quote
 
MartaDuarteDias
Portugal
Local time: 04:25
English to Portuguese
+ ...
'File sniffer for file type 'CSV v 2.0.0.0. failed' Oct 30, 2014

Hi there,

I've received the above message when trying to open a .csv file (a bilingual Excel file). I've looked it up a bit, but cannot find any relevant answers. Any suugestions? Thanks!

P.S. In the meantime ended up being able to convert it via UTF-8 encoding!

[Editado em 2014-10-30 16:56 GMT]


Direct link Reply with quote
 

juanpablosans  Identity Verified
Mexico
Local time: 04:25
Member (2011)
English to Spanish
+ ...
The same .csv issue Jun 17, 2015

Hello,

I have exactly the same issue, and my Trados is not recognizing the .CSV. Any suggestions?


Direct link Reply with quote
 
Pages in topic:   [1 2] >


To report site rules violations or get help, contact a site moderator:


You can also contact site staff by submitting a support request »

How to convert/open bilingual Excel in Studio

Advanced search







Déjà Vu X3
Try it, Love it

Find out why Déjà Vu is today the most flexible, customizable and user-friendly tool on the market. See the brand new features in action: *Completely redesigned user interface *Live Preview *Inline spell checking *Inline

More info »
Anycount & Translation Office 3000
Translation Office 3000

Translation Office 3000 is an advanced accounting tool for freelance translators and small agencies. TO3000 easily and seamlessly integrates with the business life of professional freelance translators.

More info »



Forums
  • All of ProZ.com
  • Term search
  • Jobs
  • Forums
  • Multiple search