Saving Files On html UTF-8
Thread poster: Mohamed Mahmoud

Mohamed Mahmoud  Identity Verified
Egypt
Local time: 07:01
Member (2011)
English to Arabic
+ ...
Mar 23, 2012

Dear Colleges

I hope to fine and Ok.

I got 20 K files from a client in HTML format to be translated From English into Arabic using Trados so I used Tag editor , Trados 7.1 to translated.

Though the work was smooth, The client asked me to deliver the files on Html utf - 8.

No I do not know how to do this.

I choose file \save target as


The only option available is HTML documents

So I press ok

The Problem that It does not work as the Arabic letter does not appear.

Instead it appears like

تمتلك شركة سيف كاب للاستثمارات المحدودة Safecap Invsetments Ltd ( المعروفة إختصاراً سيف كاب) الموقع الإلكترونى The Markets.com. أما شركة سيف كاب Safecap فهى شركة استثمار خاضعة لهيئة الأوراق والأسواق المالية القبرصية بموجب ترخيص رقم CIF 092/08. ووفقاً لقانون الإشراف على أدوات الأسواق المالية فى الاتحاد الأوروبى European Union’s Markets in Financial Instruments Directive ( المعروف اختصاراً "MiFID") ووفقا لقانون تنظيم السوق وأنشطة خدمات الاستثمار للعام 2007

In the same time when I open the Target Html using Notepad it opens like this



تعريف تضارب المصالح

So the Arabic Translation is there


How can this be solved

Thanks in Advance


Direct link Reply with quote
 
esperantisto  Identity Verified
Local time: 08:01
Member (2006)
English to Russian
+ ...
Not clear Mar 23, 2012

Mohamed Mahmoud wrote:

The Problem that It does not work as the Arabic letter does not appear.



In the same time when I open the Target Html using Notepad it opens like this



تعريف تضارب المصالح



I don’t understand: first you say “does not appear”, then you say “translation is there”. Where does the problem emerge?


Direct link Reply with quote
 

Mohamed Mahmoud  Identity Verified
Egypt
Local time: 07:01
Member (2011)
English to Arabic
+ ...
TOPIC STARTER
Saving Files On html UTF-8 Appear Mar 23, 2012

Dear

Thanks a lot for your respond
when I open the translated HTML file using browser it opens as:

ªÙ„Ùƒ شركة سيف كاب للاستثمارات المحدودة Safecap Invsetments Ltd ( المعروفة إختصاراً سيف كاب) الموقع الإلكترونى The Markets.com. أما شركة سيف كاب Safecap فهى شركة استثمار خاضعة لهيئة الأوراق والأسواق المالية القبرصية بموجب ترخيص رقم CIF 092/08. ووفقاً لقانون الإشراف على أدوات الأسواق المالية


while I tried using Notepad to check the file So I found the Arabic Translation is there but it does not appear on the browser

Thanks


Direct link Reply with quote
 

Elenka Ganeva  Identity Verified
Local time: 08:01
Member (2007)
English to Bulgarian
+ ...
Similar problem solved in the past Mar 23, 2012

Please try the following:
Open the cleaned up file.
Click 'Save as' and select 'Plain text' as type of file.
Click 'Save'
A new window appears with some options.
Tick 'Other coding'
Choose UTF-8 and click OK.

I am not quite sure this will help, but why not try...

Good luck!


Direct link Reply with quote
 
esperantisto  Identity Verified
Local time: 08:01
Member (2006)
English to Russian
+ ...
Don't do that Mar 24, 2012

Elenka Ganeva wrote:

Please try the following:
Open the cleaned up file.
Click 'Save as' and select 'Plain text' as type of file.
Click 'Save'
A new window appears with some options.
Tick 'Other coding'
Choose UTF-8 and click OK.

I am not quite sure this will help, but why not try...


If you're not sure, why you give any (and bad) advise?

What Mohamed described, makes me think that the problem is as follows. The HTML file is really in UTF-8 (thus, opens correctly in Notepad), but has wrong or missing encoding declaration in the HTML header (thus, the browser misinterprets it). So, just add or correct the declaration with any text editor (Notepad should be fine for this purpose, but I do recommend something better like jEdit or UniRed, as they can change the encoding as needed).


Direct link Reply with quote
 

Rolf Keller
Germany
Local time: 07:01
English to German
UTF-8 in HTML Mar 24, 2012

esperantisto wrote:

What Mohamed described, makes me think that the problem is as follows. The HTML file is really in UTF-8 (thus, opens correctly in Notepad), but has wrong or missing encoding declaration in the HTML header (thus, the browser misinterprets it).


Or the browser ist not set to UTF-8. (Our Arabic speaking colleagues might use different settings.)


Direct link Reply with quote
 

Samuel Murray  Identity Verified
Netherlands
Local time: 07:01
Member (2006)
English to Afrikaans
+ ...
I also think it is a problem with the declaration Mar 24, 2012

esperantisto wrote:
What Mohamed described, makes me think that the problem is as follows. The HTML file is really in UTF-8 (thus, opens correctly in Notepad), but has wrong or missing encoding declaration in the HTML header (thus, the browser misinterprets it).


I have the same feeling.

You can check if this is so by setting your browser to assume UTF8 when opening an HTML page of unknown encoding. This is just a temporary solution on your side, of course, to see if this is the problem. If you discover that the HTML page looks correct when you tell your browser to load it as UTF8, then it means that the HTML pages themselves have incorrect character encoding declarations in their heads. You may be able to solve this with a program that does find/replace across multiple files, but make sure you make backups of your files in case something goes wrong.

I'm not sure if Trados 7.1 would break a working character encoding declaration in an HTML file. If not, then it means that the files you received from the client did not have the correct declarations in them to begin with

You could also open the HTML page in Notepad and check the very top of the page, to see if it contains something at the very top that starts with "<?xml". If not, then you need to add it (or the client's webmaster has to add it), or fix it so that it says "UTF-8" (not e.g. ISO-something). The important thing about this particular line is that it must be at the very, very top of the file.

Also check if near the top of your HTML page you should have something like this:
<META http-equiv="Content-Type" content="text/html; charset=SOMETHING">
If not, or if it doesn't say "UTF-8", then you (or the webmaster) needs to fix that.

See also:
http://www.w3.org/QA/2008/03/html-charset.html


Direct link Reply with quote
 

Mohamed Mahmoud  Identity Verified
Egypt
Local time: 07:01
Member (2011)
English to Arabic
+ ...
TOPIC STARTER
Thanks for help Mar 24, 2012

Dear friends

Thanks a lot for your wonderful help.
Special thanks to Samuel Murray & esperantisto.
you are the best.


Best Wishes for all of you


Direct link Reply with quote
 


To report site rules violations or get help, contact a site moderator:


You can also contact site staff by submitting a support request »

Saving Files On html UTF-8

Advanced search







CafeTran Espresso
You've never met a CAT tool this clever!

Translate faster & easier, using a sophisticated CAT tool built by a translator / developer. Accept jobs from clients who use SDL Trados, MemoQ, Wordfast & major CAT tools. Download and start using CafeTran Espresso -- for free

More info »
Anycount & Translation Office 3000
Translation Office 3000

Translation Office 3000 is an advanced accounting tool for freelance translators and small agencies. TO3000 easily and seamlessly integrates with the business life of professional freelance translators.

More info »



Forums
  • All of ProZ.com
  • Term search
  • Jobs
  • Forums
  • Multiple search