How to add terms to a translation memory?
Thread poster: Pedro Godfroid

Pedro Godfroid
Local time: 19:55
English to French
+ ...
Apr 19, 2012

Yes, I know, it's supposed to be automatic but it does not work for me so, can somebody explain the procedure in details for a stupid old n00b like me?

Tx and bye.

--
Pedro Godfroid Goffin


Direct link Reply with quote
 

Heinrich Pesch  Identity Verified
Finland
Local time: 20:55
Member (2003)
Finnish to German
+ ...
Add terms to termbase, not to TM Apr 19, 2012

Make sure you understand what is translation memory and what is termbase in your translation environment.

Direct link Reply with quote
 

Pedro Godfroid
Local time: 19:55
English to French
+ ...
TOPIC STARTER
How can I fill the translation memory? Apr 19, 2012

Heinrich Pesch wrote:

Make sure you understand what is translation memory and what is termbase in your translation environment.


I've seen the introductory videos and the introductory tutorials and I understand the difference. I may not have used the correct term because I've been working all night but the idea is the same. The translation memory is supposed to be automatic but I've translated a whole text with a bunch of repeated test, in some cases whole translations units, but *nothing* appears in the translation memory.

So, if you prefer, let me rephrase my question for you: how do I get stuff there?


Direct link Reply with quote
 

Heinrich Pesch  Identity Verified
Finland
Local time: 20:55
Member (2003)
Finnish to German
+ ...
You have to confirm each segment Apr 19, 2012

I don't use Studio very much, but each segment should appear in the TM after you confirm it. Then in front of the segment appears a green check-mark. Look what key-combination you have to press in order to "confirm and move to next segment" under Options > Keyboard shortcuts.
Perhaps you just wrote the translation and moved the cursor to the next row? Then the segment stays unconfirmed.


Direct link Reply with quote
 

Annett Hieber  Identity Verified
Germany
Local time: 19:55
English to German
Update Apr 19, 2012

Please also look, if you have checked the option "update" when you have opened/created the TM. In my Studio 2009 version, this option is not checked by default, I always have to check it anew when creating a new TM.

Annett


Direct link Reply with quote
 

Pedro Godfroid
Local time: 19:55
English to French
+ ...
TOPIC STARTER
Each segment has been confirmed Apr 19, 2012

Heinrich Pesch wrote:

I don't use Studio very much, but each segment should appear in the TM after you confirm it. Then in front of the segment appears a green check-mark. Look what key-combination you have to press in order to "confirm and move to next segment" under Options > Keyboard shortcuts.
Perhaps you just wrote the translation and moved the cursor to the next row? Then the segment stays unconfirmed.


This is what I did as I'm not a keyboard wiz but after that I did the routine on all lines. And they do not appear in the TM.

One thing weird is that, with those phrases which are identical, a "100%" appears in the central column where the status icon is besides those identical phrases that have been translated before so the program in some way knows that but does not moves them to TM. And I've checked what Annett told me about the "update option" of my TM. It is indeed checked.

I'm using the 30 days trial version so maybe it's a limitation of this version. Does anybody knows if it's that way?

--
Pedro Godfroid


Direct link Reply with quote
 

Pedro Godfroid
Local time: 19:55
English to French
+ ...
TOPIC STARTER
Update option checked Apr 19, 2012

Annett Hieber wrote:

Please also look, if you have checked the option "update" when you have opened/created the TM. In my Studio 2009 version, this option is not checked by default, I always have to check it anew when creating a new TM.

Annett


It's the 2011 trial version and the "update" option is checked.


--
Pedro Godfroid


Direct link Reply with quote
 

Michael Joseph Wdowiak Beijer  Identity Verified
United Kingdom
Local time: 18:55
Member (2009)
Dutch to English
+ ...
Hi Pedro, Apr 19, 2012

Since you are still on the trial version, I would highly recommend that you also give memoQ a try. I think it is a much better program.

'Download policy

You can download a full-featured 45-days trial version of memoQ translator pro free of charge. Once this evaluation period expires, you can choose from the following options:

Use memoQ 4free free of charge forever, with a lot of features limited. Learn more about memoQ4free.
Buy the full-featured memoQ translator pro license ...' (from their website)

http://kilgray.com/downloads

PS: I would also recommend having a look at their mailing lists before deciding to buy anything, to get a better idea of the difference between the two:

http://tech.groups.yahoo.com/group/memoQ/
http://tech.groups.yahoo.com/group/TW_users/

Michael


Direct link Reply with quote
 

Pedro Godfroid
Local time: 19:55
English to French
+ ...
TOPIC STARTER
It's not my choice and I'm not buying anything Apr 19, 2012

Michael Beijer wrote:

Since you are still on the trial version, I would highly recommend that you also give memoQ a try. I think it is a much better program.

'Download policy

You can download a full-featured 45-days trial version of memoQ translator pro free of charge. Once this evaluation period expires, you can choose from the following options:

Use memoQ 4free free of charge forever, with a lot of features limited. Learn more about memoQ4free.
Buy the full-featured memoQ translator pro license ...' (from their website)

http://kilgray.com/downloads

PS: I would also recommend having a look at their mailing lists before deciding to buy anything, to get a better idea of the difference between the two:

http://tech.groups.yahoo.com/group/memoQ/
http://tech.groups.yahoo.com/group/TW_users/

Michael


Oh, I'm not buying anything because I have no income and thus no money. . And less for such a pricey program as TRADOS... I'm unemployed and in dire need of a job. Do not judge me on my formal picture: it's marketing.

That's why I'm using the trial version. Not because I want to buy it but because it is what's required for the test translation I'm doing to try to get my first translation job. That's why I need this problem solved ASAP. I have only hours left before the deadline and I've been working hard for this one and only opportunity I have.

When I begin to make money doing translations, I'll think about buying stuff. Right now I do not have even MS Office, only OpenOffice, for instance.


Tx for the advice anyway.

--
Pedro Godfroid Goffin


Direct link Reply with quote
 

Emma Goldsmith  Identity Verified
Spain
Local time: 19:55
Member (2010)
Spanish to English
Project TM? Apr 19, 2012

Pedro Godfroid wrote:

One thing weird is that, with those phrases which are identical, a "100%" appears in the central column where the status icon is besides those identical phrases that have been translated before so the program in some way knows that but does not moves them to TM. And I've checked what Annett told me about the "update option" of my TM. It is indeed checked.


If you're getting identical phrases (segments) autopropagated, then these segments are going into a TM. Maybe you are using a project TM? When you open a new project one of the batch tasks is "prepare without project TM". That's what you should be using.

Check by going to project>project settings>language pairs>(your pair)>translation memory and automated..
Have a look to see if there is a project TM on the righthand side, not just the main TM.

If that's the case, then run file>batch tasks>update main translation memories, and see if that helps.

By the way, this has nothing to do with using a trial version.


Direct link Reply with quote
 

SDL Community  Identity Verified
United Kingdom
Local time: 19:55
English
Check the location of your TM Apr 19, 2012

Pedro Godfroid wrote:
One thing weird is that, with those phrases which are identical, a "100%" appears in the central column where the status icon is besides those identical phrases that have been translated before so the program in some way knows that but does not moves them to TM. And I've checked what Annett told me about the "update option" of my TM. It is indeed checked.


This effect is AutoPropagation and would happen even without a TM.

Did you create a Project or did you use Open Document to start work? If the former then make sure the Project is active in the projects viiew and then go to Project Settings - Language Pairs - All Language Pairs - Translation Memory and Automated Translation. Here you will see the TM you are using. If there is one on it's own then you are not using a Project TM, so just hover over the TM and see where it is. Then double check that it is the same as the one you are looking at.

If there is another indented underneath it then you are using a Project TM. In this case hover again and then open the Project TM to look for your translated segments.

Also in this view check that you have Update checked.

If you used Open Document then go to the Projects View and look for the project that was created for you. Make sure it is highlighted and do the same as above.

If none of this points you in the right direction then maybe we can do a quick webex later today and look your setup?

Regards

Paul


Direct link Reply with quote
 

Emma Goldsmith  Identity Verified
Spain
Local time: 19:55
Member (2010)
Spanish to English
Autopropagation Apr 19, 2012

SDL Support wrote:

AutoPropagation ...would happen even without a TM.


It hadn't occurred to me that autopropagation has nothing to do with TMs. Thanks Paul, for that little ounce of knowledge


Direct link Reply with quote
 

Pedro Godfroid
Local time: 19:55
English to French
+ ...
TOPIC STARTER
You're right Apr 19, 2012

Emma Goldsmith wrote:

Pedro Godfroid wrote:

One thing weird is that, with those phrases which are identical, a "100%" appears in the central column where the status icon is besides those identical phrases that have been translated before so the program in some way knows that but does not moves them to TM. And I've checked what Annett told me about the "update option" of my TM. It is indeed checked.


If you're getting identical phrases (segments) autopropagated, then these segments are going into a TM. Maybe you are using a project TM? When you open a new project one of the batch tasks is "prepare without project TM". That's what you should be using.

Check by going to project>project settings>language pairs>(your pair)>translation memory and automated..
Have a look to see if there is a project TM on the righthand side, not just the main TM.

If that's the case, then run file>batch tasks>update main translation memories, and see if that helps.

By the way, this has nothing to do with using a trial version.


OK.

It seems that you are right.

As this is my first use of the program and I did not had time for anything more than the introductory video, which did not told me much BTW, and a quick browsing through the help, I got started as soon as possible loading the .TTX I was given. Then I fumbled around with the project and such but did not know quite well what I was doing. I have very few hours left to the deadline and I do not want to lose this as it was extremely hard to get. So I've checked what you say and indeed my project does not have TM in its list although I did created a TM and open it every time I open the job (although it does not do anything).

Now my question is: how do I add the TM I created? Or any for that case as the one I created is empty...


Tx and bye.


--
Pedro Godfroid Goffin


Direct link Reply with quote
 

Pedro Godfroid
Local time: 19:55
English to French
+ ...
TOPIC STARTER
Solved, thanks. Apr 19, 2012

SDL Support wrote:

Pedro Godfroid wrote:
One thing weird is that, with those phrases which are identical, a "100%" appears in the central column where the status icon is besides those identical phrases that have been translated before so the program in some way knows that but does not moves them to TM. And I've checked what Annett told me about the "update option" of my TM. It is indeed checked.


This effect is AutoPropagation and would happen even without a TM.

Did you create a Project or did you use Open Document to start work? If the former then make sure the Project is active in the projects viiew and then go to Project Settings - Language Pairs - All Language Pairs - Translation Memory and Automated Translation. Here you will see the TM you are using. If there is one on it's own then you are not using a Project TM, so just hover over the TM and see where it is. Then double check that it is the same as the one you are looking at.

If there is another indented underneath it then you are using a Project TM. In this case hover again and then open the Project TM to look for your translated segments.

Also in this view check that you have Update checked.

If you used Open Document then go to the Projects View and look for the project that was created for you. Make sure it is highlighted and do the same as above.

If none of this points you in the right direction then maybe we can do a quick webex later today and look your setup?

Regards

Paul


Thanks for all the info you and Emma were right. I opened a TTX file directly and begun to work then I created a TM, a project and all that jazz to try to use the more advanced features but I fumbled as it's not intuitive. So I did had and view a TM but it was not working because it was not in the project.

I'm one of these old geeks who usually read the manual before anything else but here I do not have the time so I begun to work directly trusting my geekiness but I'm a coder, not a translator and that has little in common with Eclipse or NetBeans. Necessity is a harsh mistress...


Thanks and bye.


--
Pedro Godfroid


Direct link Reply with quote
 


To report site rules violations or get help, contact a site moderator:


You can also contact site staff by submitting a support request »

How to add terms to a translation memory?

Advanced search







SDL MultiTerm 2017
Guarantee a unified, consistent and high-quality translation with terminology software by the industry leaders.

SDL MultiTerm 2017 allows translators to create one central location to store and manage multilingual terminology, and with SDL MultiTerm Extract 2017 you can automatically create term lists from your existing documentation to save time.

More info »
Déjà Vu X3
Try it, Love it

Find out why Déjà Vu is today the most flexible, customizable and user-friendly tool on the market. See the brand new features in action: *Completely redesigned user interface *Live Preview *Inline spell checking *Inline

More info »



Forums
  • All of ProZ.com
  • Term search
  • Jobs
  • Forums
  • Multiple search