EU TM and Studio 2011 errors
Thread poster: Silvia D'Amico

Silvia D'Amico  Identity Verified
United States
Local time: 09:59
English to Italian
+ ...
May 3, 2012

Hi everyone,

Since I work mainly with EU texts I was quite excited about the TM released by the European Union (info here http://langtech.jrc.it/DGT-TM.html). After downloading and extracting all the files, yesterday I was able to use it, but today after opening Studio 2011 I got this error message "cannot access a disposed object". I was still able to open my project, but after enabling the above mentioned TM I got another error "database file is locked". I tried to restart Studio and I got the same error messages except this time it let me use the concordance search with that TM.

Is there any way to fix these errors? It would bother me to have those errors pop up every time I open Studio. Any thoughts?

Many thanks,

Silvia


Direct link Reply with quote
 

Denise Phelps  Identity Verified
Local time: 15:59
Spanish to English
+ ...
Try a different thread May 3, 2012

I can't help personally you, but if you go over to this thread (http://www.proz.com/forum/translator_resources/223715-euro_commission_multilingual_tm_for_the_acquis_communautaire_publicly_accessible.html) the people there seem to know about the TM in question and might be able to help you.

Direct link Reply with quote
 

Silvia D'Amico  Identity Verified
United States
Local time: 09:59
English to Italian
+ ...
TOPIC STARTER
Thanks May 4, 2012

I'll try that.

Direct link Reply with quote
 

Richard Hill  Identity Verified
Mexico
Local time: 09:59
Member (2011)
Spanish to English
"database file is locked" May 31, 2012

Hi Silvia,

I am getting the same ""database file is locked" message with the EU TM so I was wondering if you found a solution.

Best regards,

Rich


Direct link Reply with quote
 

SDL Community  Identity Verified
United Kingdom
Local time: 15:59
English
Where is the TM located? May 31, 2012

Hi Rich,

Do you have the TM located on a seperate drive or on a network somewhere? Are you sharing it locally with another user?

This type of error message sometimes results from this because shared access, or slow access, isn't managed for file based TMs so simultaneous processes can cause this message until a process finishes. Does the message go away if you wait a little while and try again?

Regards

Paul


Direct link Reply with quote
 

Silvia D'Amico  Identity Verified
United States
Local time: 09:59
English to Italian
+ ...
TOPIC STARTER
Problem solved itself May 31, 2012

I did not know what to do or how to solve it, so I simply removed the TM, restarted Studio and added the TM again and it worked. However, since then I didn't try to use that TM again so I am not sure if it will give the same error or not.

Hope it helps,

Silvia


Direct link Reply with quote
 
jimshanks
Local time: 14:59
Dutch to English
Maybe slow access Jun 1, 2012

I have downloaded the Dutch - English version of this TM and encountered the same problem intermittently. I suspect that there may be a slow access problem as my TM has (I think) 1,800,000 plus TUs!
As I said, the problem appears to be intermittent. Sometimes it works, sometimes it throws an error and closes the TM.
Does TRADOS have an upper limit for size of TM, or is there any way to increase the time before lockout?


Direct link Reply with quote
 

SDL Community  Identity Verified
United Kingdom
Local time: 15:59
English
Database is locked Jun 1, 2012

Hi Jim et al.,

I'm not aware of a limit, and I am aware of people with larger filebased TMs than this so I don't think size alone is the problem.

I discussed this with some of the support team earlier today and things that can cause database locking are heavy duty tasks like large imports/exports, big/parallel analysis or pre-translates. So if you are sharing a filebased TM or running multiple instances of Studio to do this then it may happen.

Sharing a TM should really only be used for interactive translation. For project preparation etc. it should only be used one at a time. We have TM server/Team to cater for these scenarios.

It might also be other things, like AntiVirus on a Network drive running, or a backup happening at just that moment. Another reason could also be if you are running a Linux-based NAS file system as described in the following article:

http://kb.sdl.com/#tab:homeTab:crumb:7:artId:3910

We also have a KB article on Best practice for sharing if you are doing this:

http://kb.sdl.com/#tab:categoryTab:crumb:2:artId:2550

So quite a few things worth looking at that may give you some ideas based on your own setups?

Regards

Paul


Direct link Reply with quote
 
jimshanks
Local time: 14:59
Dutch to English
Not shared Jun 1, 2012

Hi Paul,
I am not running a shared TM at all and not running multiple instances either.
I am running multiple TMs (sometimes 4!) just because I can.
Usually a supplied Project TM - generally not very large and my own TM(s) - which can be up to 50k TUs. I have only recently downloaded the EU TM (purely out of curiosity as a result of this thread, to see if I had the same problems. After the initial conversion to a STUDIO TM the problem occurred so I removed the TM from the project and continued working the rest of the day.
Next morning, after closing STUDIO and shutting down the PC, I added the TM back to the project and all seemed OK.
This morning I had to remove it again as the error reoccurred on the first search (i.e. when I opened the first segment and it tried to find a match in the (4) TMs. Once again, I removed the TM from the project and continued working.
I am not running on a network drive and backups do not occur while I am working.
I am running under Windows 7 (albeit as a VM under Parallels on a Mac running OS X.
Obviously, I am not devoting a great deal of attention to this problem because it is only curiosity value for me at the moment.
I may continue to try using this TM (I don't update it only use it for reference) to see how it behaves in future. Hope this helps throw more light on this (or at least rule out some of the scenarios).
Jim


Direct link Reply with quote
 
Barbara Rhoton  Identity Verified
United States
Local time: 06:59
English to German
+ ...
Same problem Aug 11, 2012

My TMs do this all the time, there seems to be no discernible pattern or any rhyme or reason to this, it happens when opening Studio (nothing else is running), during translation, and with various different TMs - and it's very aggravating.

Direct link Reply with quote
 


To report site rules violations or get help, contact a site moderator:


You can also contact site staff by submitting a support request »

EU TM and Studio 2011 errors

Advanced search







PerfectIt consistency checker
Faster Checking, Greater Accuracy

PerfectIt helps deliver error-free documents. It improves consistency, ensures quality and helps to enforce style guides. It’s a powerful tool for pro users, and comes with the assurance of a 30-day money back guarantee.

More info »
Déjà Vu X3
Try it, Love it

Find out why Déjà Vu is today the most flexible, customizable and user-friendly tool on the market. See the brand new features in action: *Completely redesigned user interface *Live Preview *Inline spell checking *Inline

More info »



Forums
  • All of ProZ.com
  • Term search
  • Jobs
  • Forums
  • Multiple search