File used by another process with Studio 2009, cannot create and analyze project
Thread poster: Philippe Morgan de Rivery

Philippe Morgan de Rivery  Identity Verified
France
Local time: 17:27
English to French
May 23, 2012

Hi everybody,

I want to create a project with a large number of documents (mostly Word and 1 PowerPoint) on SDL Trados 2009 SP3, but I can't create the project, I sometimes manage to convert all files but then I can't do the analysis and pretranslation anyway, because the file is used by another process (TEMP... something).

It has done that for quite some time now but my usual technique was just to repeatedly try to create a new project and after a while it would work. However, since here there are many files to translate I doubt this workaround would work, I have already tried several times to recreate a project, but no luck until now.

I know that some people have found a workaround for SDL 2007 (desactivate TM backup) but I don't know where/if I can do that in 2009, and I haven't found another post on the topic addressing the problem for people who have SDL 2009.

I have ignored this problem for too long and I think it's time to come up with a solution.

Thanks everyone for your help.

Philippe


Direct link Reply with quote
 

SDL Community  Identity Verified
United Kingdom
Local time: 17:27
English
Strange... May 23, 2012

Hi Philippe,

I'm not sure whether you mean the file is being used by Studio in another process or that it is just being used by another process. The latter suggests you have the file open in word/powerpoint... or that word/powerpoint didn't close down properly yet so perhaps make sure all instances of word/powerpoint are closed using the task manager.

If it's the former then I need some help to reproduce this because I have not come across it before.

Regards

Paul

[Edited at 2012-05-23 13:01 GMT]

[Edited at 2012-05-23 13:02 GMT]


Direct link Reply with quote
 

Philippe Morgan de Rivery  Identity Verified
France
Local time: 17:27
English to French
TOPIC STARTER
Recreated the error, here is what the error message says May 23, 2012

Hi Paul,

No, Word and Powerpoint were closed and I checked the running processes, no one was related to them.

My files had large pictures in them and I have many files (23 Word files and 1 PowerPoint), it may be due to that. The problem seems a bit similar to this one (except it's with 2009):

http://www.proz.com/forum/sdl_trados_support/69836-file_is_being_used_by_another_process.html

When I start the project and convert files (sometimes I manage to get past this and I get error messages during the analysis step, sometimes it's as soon as I start converting files etc.) I get 1 or several error messages preventing me from completing the analysis (and subsequent pretranslation etc.). When I click on "Task results", I see errors with the following message displayed:

... oh wait. It worked this time. I was trying to reproduce it to tell you the exact error message and it worked.

Well, it was still not working before and I tried maybe 10 times before it did. It often happens to me and it seems that if I try enough it will get through eventually. Usually I only have a few files to translate so it gets through after 2 or 3 attempts, but with so many files it was much more difficult.

OK, I recreated another project just to try to recreate the error and it happened again, the analysis failed. The exact error message is:

"The process cannot access the file 'C:\Users\user\AppData\Local\Temp\tmp93AD.tmp' because it is being used by another process."

After that, it mentions one of my Word files (in sdlxliff format already). However these error messages seem to happen with any file in the folder. I also remember that the file that cannot be accessed is not always "'C:\Users\user\AppData\Local\Temp\tmp93AD.tmp'", it seems to vary each time.


I can now work on my project but please let me know if you find a solution anyway, because this often happens to me and might happen to others as well.

Thank you very much!

Philippe


Direct link Reply with quote
 

John Fossey  Identity Verified
Canada
Local time: 11:27
Member (2008)
French to English
Unlocker May 24, 2012

MS Office programs are particularly notorius for not releasing a lock on a file after using it. Even the Windows operating system does it sometimes. The thread you mentioned refers to the "Unlocker" utility at http://www.proz.com/forum/sdl_trados_support/69836-file_is_being_used_by_another_process-page2.html#1665283 . I probably have to use this little program at least once a day.

This utility will identify which program is holding the lock on the file, and most commonly it's Word (even if no instance of Word is running) or "System", meaning Windows.

[Edited at 2012-05-24 01:16 GMT]


Direct link Reply with quote
 


To report site rules violations or get help, contact a site moderator:


You can also contact site staff by submitting a support request »

File used by another process with Studio 2009, cannot create and analyze project

Advanced search







SDL MultiTerm 2017
Guarantee a unified, consistent and high-quality translation with terminology software by the industry leaders.

SDL MultiTerm 2017 allows translators to create one central location to store and manage multilingual terminology, and with SDL MultiTerm Extract 2017 you can automatically create term lists from your existing documentation to save time.

More info »
memoQ translator pro
Kilgray's memoQ is the world's fastest developing integrated localization & translation environment rendering you more productive and efficient.

With our advanced file filters, unlimited language and advanced file support, memoQ translator pro has been designed for translators and reviewers who work on their own, with other translators or in team-based translation projects.

More info »



Forums
  • All of ProZ.com
  • Term search
  • Jobs
  • Forums
  • Multiple search