Studio 2011 error - Database file is locked - solution?
Thread poster: Heather McCrae

Heather McCrae  Identity Verified
Germany
Local time: 23:39
Member (2012)
German to English
May 25, 2012

I am working on a large job, with 2 TM, each time I open the project, the settings are ok, then as soon as I start translating, an error message appears:

The translation provider xxx could not be opened and has been disabled
The transation memory data file engine returned an error
The database file is locked
Database is locked

If I go into the settings and enable the offending TM a couple of times, it seems to accept this and I can translate again with TUs being added as normal to both TM. But I also have the problem that my custom fields need to be set again and the autosuggest dictionary also needs to be added.

Can anyone explain why??? and how to resolve this issue.

thanks in advance
Heather


Direct link Reply with quote
 
Mirjam Spekking  Identity Verified
Netherlands
Local time: 23:39
English to Dutch
+ ...
No solution but here the same problem! May 26, 2012

I have exactly the same problem here. The 'solution' I have is completely quitting the program and restarting windows.
I run windows on a virtual machine, so at first I thought it had perhaps something to do with that. But since you have it too...

Anyway, restarting it all helps for me, but it is rather time consuming, and I too have to reset all my settings again.

I am also curious to know why this keeps happening. I work with several TMs simultaneously and sometimes I get this message for all of them, and sometimes only for my main TM. I hope there is somebody out there who can help!



Mirjam


Direct link Reply with quote
 
Barbara Rhoton  Identity Verified
United States
Local time: 14:39
English to German
+ ...
Same problem Jun 6, 2012

I have the same problem and there seems to be to no rhyme or reason to it, no discernible pattern at all but is a major inconvenience and bother.

[Edited at 2012-06-06 17:31 GMT]


Direct link Reply with quote
 

John Fossey  Identity Verified
Canada
Local time: 17:39
Member (2008)
French to English
Unlocker Jun 6, 2012

Not sure if this is the cause, but I have occasionally had it happen to me with Studio 2011 databases. Windows sometimes doesn't release the lock on the file when it was last written to.

If this is what's happening, the solution is Unlocker at http://ccollomb.free.fr/unlocker/.

After installing, go to the offending database file and run Unlocker, with the action set as "No action". Strangely, when it's happened to me it has needed to be unlocked a couple of times in the course of a job then doesn't need it any more.

[Edited at 2012-06-06 18:01 GMT]


Direct link Reply with quote
 

Stefanie Sendelbach  Identity Verified
Germany
Local time: 23:39
Member (2003)
English to German
+ ...
Link has moved Jul 19, 2012

Hi John,

Thank you for mentioning Unlocker! I could not download it from the link you gave, but I found it here: http://www.emptyloop.com/unlocker/

Worked like a charm.

Stefanie


Direct link Reply with quote
 

Roberta Beyer  Identity Verified
United States
Local time: 16:39
Member (2011)
French to English
Also having this problem Dec 26, 2013

I have also been having this problem for a very long time. It only occurs with one of the 2 TMs I consistently use for projects from a specific client. The client updates the TM every week and I download the sdltm file. The other TM is my own, and is much smaller. The client's TM is very very large. I do not update the client's TM, I only have it enabled for searching/concordance. Unlocker does not seem to work for me. Neither does restarting Studio or my PC. Are there any other suggestions? Over the last year I have probably spent at least several days' worth of time trying to resolve this problem.

Thank you.


Direct link Reply with quote
 

Natalie  Identity Verified
Poland
Local time: 23:39
Member (2002)
English to Russian
+ ...

Moderator of this forum
Read-only file, probably? Dec 26, 2013

Maybe check if the downloaded TM file isn't read-only?

Direct link Reply with quote
 


To report site rules violations or get help, contact a site moderator:


You can also contact site staff by submitting a support request »

Studio 2011 error - Database file is locked - solution?

Advanced search







TM-Town
Manage your TMs and Terms ... and boost your translation business

Are you ready for something fresh in the industry? TM-Town is a unique new site for you -- the freelance translator -- to store, manage and share translation memories (TMs) and glossaries...and potentially meet new clients on the basis of your prior work.

More info »
Wordfast Pro
Translation Memory Software for Any Platform

Exclusive discount for ProZ.com users! Save over 13% when purchasing Wordfast Pro through ProZ.com. Wordfast is the world's #1 provider of platform-independent Translation Memory software. Consistently ranked the most user-friendly and highest value

More info »



Forums
  • All of ProZ.com
  • Term search
  • Jobs
  • Forums
  • Multiple search