TTX and Studio - Studio generates faulty files
Thread poster: Hans Näslund

Hans Näslund
Sweden
Local time: 14:40
Member (2004)
English to Swedish
+ ...
May 26, 2012

I have problem which seems to be unique, judging from other posts in this forum:

It is supposed to be possible to translate TTX files in Studio – and of course it is, and it is faster and simpler than in TagEditor.

But when I finalise the project, the resulting TTX files are unusable, because the tags are all mixed up compared to the original TTX file. So I have to export the TM, import it into TW, run the original file against the TM and correct the position of the tags – which can be *very* time-consuming and frustrating if there are a lot of tags in the file. This happens each time I get TTX files to translate. At the moment, I am in the middle of such a process.

Why cannot my Studio programme handle the tags in a proper way? Is there any remedy for this?


Direct link Reply with quote
 

Natalie  Identity Verified
Poland
Local time: 14:40
Member (2002)
English to Russian
+ ...

Moderator of this forum
But... May 26, 2012

... it is the translator who is responsible for the correct placement of the tags in the translated text, NOT the software. The tags don't move to new places by themselves...

You should place the tags in appropriate places while you are translating, and also run verification afterwards.


Direct link Reply with quote
 

Hans Näslund
Sweden
Local time: 14:40
Member (2004)
English to Swedish
+ ...
TOPIC STARTER
Yes, of course... May 27, 2012

... but in Studio the tags ARE correctly placed. The tag verification feature in Studio is enabled.

Also, Studio changes the segmentation, which combines to make the generated TTX files unusable.


Direct link Reply with quote
 

Emma Goldsmith  Identity Verified
Spain
Local time: 14:40
Member (2010)
Spanish to English
A couple of questions May 27, 2012

Hans Näslund wrote:

This happens each time I get TTX files to translate.

... Also, Studio changes the segmentation, which combines to make the generated TTX files unusable.

If you are given the TTX file then the segmentation has been done by your client. Studio merely converts it into sdlxliff format.

Have you checked that you have enabled the compatibility option for ttx file types: Treat all inline tags as placeholders (disable smart tag pairing). (Tools>options>file types>ttx)

... but in Studio the tags ARE correctly placed. The tag verification feature in Studio is enabled.



Well, it's possible for the tag verification in Studio to give the OK, but your tags are still misplaced in your target text.

The test would be to open the file in Studio and before you start to translate, save the target. Although the target is still in your source language, are the tags all mixed up? If they're mixed up, then I agree there's a problem. If they look as they should, then you're doing something during the translation process that is spoiling the format.


Direct link Reply with quote
 

Hans Näslund
Sweden
Local time: 14:40
Member (2004)
English to Swedish
+ ...
TOPIC STARTER
Answers May 27, 2012

Yes - the checkbox "Treat all inline tags as placeholders (disable smart tag pairing)" in Options/File Types/TRADOSTag was already checked by default. That did not prevent my problem from appearing.

And yes - following your suggested procedure gave the same result. What happens is that the tags change place in the segment, so if the segment in the original TTX file starts with a tag, in Studio this tag is moved to the next place in the segment where there should be a tag, which of course means that all tags in the segment come in the wrong places. Also, ending tags are omitted.

Even Jerzy Czopik did find this unexplicable (in the Yahoo group TW_users), and suggested that there might be some sort of bug in my installation. Maybe I should reinstall, or at least repair the installation.

Hans


Direct link Reply with quote
 
kimjasper  Identity Verified
Denmark
Local time: 14:40
Member (2006)
English to Danish
+ ...
I have seen the same occasionally May 27, 2012

Also, if I try to run a Translate on such a file in Workbench in order to update a TM, I have received error messages. It seems you have a well-documented case. Wonder whether you could send the ttx to SDL Support and ask them how this looks at their end?

Direct link Reply with quote
 

Jabberwock  Identity Verified
Poland
Local time: 14:40
Member (2004)
English to Polish
Segmentation May 27, 2012

Emma Goldsmith wrote:
If you are given the TTX file then the segmentation has been done by your client. Studio merely converts it into sdlxliff format.


Most ttx files sent by the clients are not segmented. That is, if you just open the file in TagEditor and save it, there is no segmentation present.

In fact, it might be worth trying to presegment the file in TagEditor - that is, to create an empty TM in Workbench and Translate it in Workbench with the option "Segment unknown sentences" set, and then process it in Studio.


Direct link Reply with quote
 

SDL Community  Identity Verified
United Kingdom
Local time: 14:40
English
Segmentation... May 27, 2012

Hi Hans,

I think Jabberwock may be on the right lines here. The fact you state that Studio changed the segmentation suggests this is so because there is no other way Studio would change the segmentation of a TTX.

If you want to share the TTX with me I'll be happy tro take a look at this and your tag problems?

Regards

Paul
pfilkin@sdl.com


Direct link Reply with quote
 

Crisa Magra  Identity Verified
Local time: 15:40
English to Greek
+ ...
Same problem with tags Oct 9, 2012

Hello,

I was wondering whether there are any news on how to resolve this issue.

I am facing the same problem as Hans with Studio 2011. After conversion, my files contain misplaced or faulty or missing tags. Manually fixing the tags in the ttx afterwards is simply impossible as it's highly time-consuming, rendering Studio unusable for most of my files.

Is it a matter of ttx configuration before conversion or is it simply a bug?

Thanks!


Direct link Reply with quote
 

SDL Community  Identity Verified
United Kingdom
Local time: 14:40
English
Preparing the TTX Oct 9, 2012

Crisa Magra wrote:

Is it a matter of ttx configuration before conversion or is it simply a bug?



Hi,

In this case it is possible that the TTX is not fully segmented with Workbench before you start, so Studio finished this off using Studio rules. So to avoid it the suggestion is that you always fully segment the TTX by preparing it with Workbench and checking segment unknown sentences.

Then translate the file in Studio ensuring you have also disabled smart tag pairing in the compatibility settings for the TTX filetype (disabled by default but worth checking).

Regards

Paul


Direct link Reply with quote
 

Crisa Magra  Identity Verified
Local time: 15:40
English to Greek
+ ...
TTX prepared by the client Oct 10, 2012

Hello Paul,

Thank you for your reply.

The TTX files are usually provided by the clients, so I really cannot intervene in the segmentation process. The TTX files are beautifully segmented and tagged, with no missing end tags, e.g. for footnote numbers, but the sdlxliff segmentation is completely faulty and clients have been specifically asking me to continue using my previous trados version -to my disappointment, that is.

I would appreciate any suggestions/thoughts on that.

Crisa


Direct link Reply with quote
 

SDL Community  Identity Verified
United Kingdom
Local time: 14:40
English
Segmentation Oct 10, 2012

Crisa Magra wrote:

Hello Paul,

Thank you for your reply.

The TTX files are usually provided by the clients, so I really cannot intervene in the segmentation process. The TTX files are beautifully segmented and tagged, with no missing end tags, e.g. for footnote numbers, but the sdlxliff segmentation is completely faulty and clients have been specifically asking me to continue using my previous trados version -to my disappointment, that is.

I would appreciate any suggestions/thoughts on that.

Crisa


Hi Crisa,

The sdlxliff segmentation can only occur if the TTX has not been fully segmented. If it has then Studio uses that. So the process your client "should" apply is to check the box "segment unknown sentences" when they prepare the file for you. Takes less than a second and doesn't require them to do any additional work.

If this is still not possible, although I can't think of a good reason why it wouldn't be, then your only sensible option is to get a copy of Workbench and finish the segmentation yourself before adding the file to Studio.

There is one route you could try, but I haven't tested this to see how successful it would be is to use the Workbench segmentation rules on a Studio TM... and then make sure you open the TTX with smart tag pairing disabled to ensure maximum compatibility. This may still not be 100%, would require some testing, but it might be worth a shot if the simple solution to segment the file 100% at the start is not possible.

In case you don't know how to get the Workbench rules into a Studio TM just upgrade a Workbench TM with a Studio TM (an empty one) and use the legacy language resources instead of the default. You can then prepare the TTX in Studio using this upgraded TM, then once it's done remove it from the Project and add back the one you want to update. There is an article about this process, although it was written for something else, that may explain it better: http://goo.gl/kcwxC so just don't reset the segmentation rules at the end as I did in this article.

Of course if your client has customised their segmentation rules then this probably won't help either... better to get them to check that box..!

Regards

Paul


Direct link Reply with quote
 

Crisa Magra  Identity Verified
Local time: 15:40
English to Greek
+ ...
Configuration during file preparation seems to have fixed the problem Oct 12, 2012

SDL Support wrote:

The sdlxliff segmentation can only occur if the TTX has not been fully segmented. If it has then Studio uses that. So the process your client "should" apply is to check the box "segment unknown sentences" when they prepare the file for you. Takes less than a second and doesn't require them to do any additional work.



Hi Paul,

Indeed, I asked the client to do as you suggested and the tags in the sdlxliff files seem to make much more sense now.

I haven't tried the second option yet, as it seems a bit time-consuming and not one I can easily apply on every project I get (unless I face an emergency, that is).

Again, many thanks!

Crisa


Direct link Reply with quote
 


To report site rules violations or get help, contact a site moderator:


You can also contact site staff by submitting a support request »

TTX and Studio - Studio generates faulty files

Advanced search







BaccS – Business Accounting Software
Modern desktop project management for freelance translators

BaccS makes it easy for translators to manage their projects, schedule tasks, create invoices, and view highly customizable reports. User-friendly, ProZ.com integration, community-driven development – a few reasons BaccS is trusted by translators!

More info »
Wordfast Pro
Translation Memory Software for Any Platform

Exclusive discount for ProZ.com users! Save over 13% when purchasing Wordfast Pro through ProZ.com. Wordfast is the world's #1 provider of platform-independent Translation Memory software. Consistently ranked the most user-friendly and highest value

More info »



Forums
  • All of ProZ.com
  • Term search
  • Jobs
  • Forums
  • Multiple search