Error in Studio 2011 "Translation memory not found"
Thread poster: Almudena Ballester

Almudena Ballester  Identity Verified
Spain
Local time: 20:14
German to Spanish
+ ...
Jun 29, 2012

Hi all,

I would appreciate if someone could help me on this issue. I have created several minor projects with their translations memories, worked on them, closed and eventually deleted (or moved to another folder).
Now when I create or open whatever other project, I keep obtaining an error message:

The translation memory 'XXXX' (one of my deleted) could not be found. Click OK to specify its location, or Cancel to disable this translation memory.

Since I don't need those translations memories any more, I click Cancel but it doesn't seem to work, because the error message appears again and again.

Is there possibly a way to get rid of those projects and their memories without creating any sort of conflict with Trados? Why can't those memories been disabled?

Many thanks on advance,


Almudena


Direct link Reply with quote
 

SDL Community  Identity Verified
United Kingdom
Local time: 20:14
English
The problem is... Jun 29, 2012

... that you have moved files in Windows Explorer without telling Studio where you put them, or without telling Studio you don't need them anymore first.

I think, based on your description the likely culprit is your default template that still contains the reference to the files you have moved. So perhaps once you click away the messages you can get into Tools - Options - Language Pairs - All Language Pairs - Translation Memory and .... etc. and then remove the TMs you find listed there.

Another popssible cuplit is your Projects that may still be in the Projects View. If you have a lot of these you could just close Studio, delete the Projects.xml file in the Studio - Projects Folder, and then restart STudio. All projects will be gone from the list but you can then just open up the ones you need and add them back in again.

And another potenmtial source of the problem is having the TMs referenced in the Translation Memories View. So remove them from that location.

Hopefully one of these will help?

I did resolve an issue like this once just by finding all the TMs in the recycle bin and restoring them. Then open Studio and properly disengage the ones you no longer need and then delete or move them.

Regards

Paul


Direct link Reply with quote
 

Almudena Ballester  Identity Verified
Spain
Local time: 20:14
German to Spanish
+ ...
TOPIC STARTER
still not fully solved Jul 2, 2012

Dear Paul,


Many thanks for your help. I'm afraid I still have the problem giving me some headache.

My deleted projects were not in the Projects View, nor the TMs were referenced in the Translation Memory View. I also got into Tools - Options - Language Pairs - All Language Pairs - Translation Memory, but didn't find my deleted TMs listed there.

So I had no option but to re-create the projects and memories in order to get rid of those messages and be able to continue working with other projects - that of course, I don't dare to delete now

Of course it seems to me not being the best option, so if you were so nice and explain me the right way to disengage -and delete- the projects I no longer need, I'd be very grateful.

Still, I don't fully understand why that option in message

Click Cancel to disable this TM

doesn't work at all.

Many thanks again for your help!

Almudena


Direct link Reply with quote
 

Stanislav Pokorny  Identity Verified
Czech Republic
Local time: 20:14
English to Czech
+ ...
Edit the template Jul 2, 2012

Hi Almudena,
I think Paul has a point here: the culprit may indeed be the Project Template.

To resolve this, try the following:
1. Close Studio and browse to the project template you used to create the project you have problems with
2. Create a backup copy of the template (just in case)
3. Open the project template in Notepad
4. Find the MainTranslationProviderItem string
5. Edit the file path for the translation memory to reflect the TM's new location on your HDD
6. Save the project template, launch Studio and check if the problem is gone.


Direct link Reply with quote
 
Robert Brown  Identity Verified
United Kingdom
Local time: 19:14
Member (2012)
German to English
+ ...
Thanks Stanislav Sep 17, 2012

Dear Stanislav

I had exactly the same problem. I edited the default project template and removed the reference to the offending TM and now I no longer get the warning.

Thanks very much for the tip.

@ SDL - to reiterate one of Almudena's points, when we click "cancel" to disable the TM in question it seems it is not disabled, or else only temporarily. It would be really great if the option to disable actually disabled it in the template. If that's not possible then perhaps the error message could be updated to something along the lines of "click cancel to temporarily disable this TM".

In an ideal world people would remove TMs following the procedure that Studio expects from us, but of course we are human and don't always do this. These are the kind of niggles that give Trados a bad name so any work to make it better able to cope with errors would be very welcome.

Regards

Rob


Direct link Reply with quote
 

Borislav Bozhidarov
Local time: 21:14
Bulgarian to English
+ ...
issue solved Feb 4, 2013

I had the same very annoying problem when I moved my TMs from one folder to another. At the start I tried solving it the brutal way - by reinstalling Trados altogether but that didn't work since my settings were preserved.

Then I came upon this post and changed the Projects template removing the problematic TMs. That solved the problem ! Thanks for the help!


Direct link Reply with quote
 
Quattro
United States
Local time: 11:14
Very helpful thread Jan 8, 2014

I had the same problem as originally posted by Almudena Ballester. And Stanislav Pokorny's suggestion to edit the project template solved the problem for me too.

At first I simply changed my two trouble TMs from True to False in the project template, as a precaution, and it worked perfectly. I no longer got any error messages.

But since I wanted to disable the TMs permanently, I removed the two TM references in the template, as Stanislav mentioned, to have a cleaner template.

Thank you all for your help!


Direct link Reply with quote
 

Heather McCrae  Identity Verified
Germany
Local time: 20:14
Member (2012)
German to English
another solution Jan 9, 2014

is to add the deleted/moved TM back into the original project folder. But this is definetly a problem that needs to be fixed by SDL. It should not be necessary to click OK or Cancel x times each time you change to a different file/project. Once click should be enough. Also, after clicking OK umpteen times and selecting the actual TM each time, the problem still occured until I actually moved the TM back into the project settings.

what a pain!


Direct link Reply with quote
 

JoelD  Identity Verified
Local time: 03:14
Japanese to English
Thanks Stanislav Jan 10, 2014

Just what the doctor ordered!

Direct link Reply with quote
 

JoelD  Identity Verified
Local time: 03:14
Japanese to English
You can also edit paths for AutoSuggest Dictionaries and Termbases Jan 11, 2014

Just wanted to add to Stanislav's 6 points, since I was getting errors pertaining to Termbases and Translation Memories.

-------

To resolve this, try the following:
1. Close Studio and browse to the project template you used to create the project you have problems with
2. Create a backup copy of the template (just in case)
3. Open the project template in Notepad
4. Find the MainTranslationProviderItem string
5. Edit the file path for the translation memory to reflect the TM's new location on your HDD
6. Save the project template, launch Studio and check if the problem is gone.

-------

I opened my templates in Notepad and did a search for my full name, which was the user name on my old computer.
Then, I replaced the offending (i.e., outdated) paths for

1) Termbases
2) Autosuggest Dictionaries
3) Translation Memories

With the new paths on my new machine (mostly the same except my user name is now just my first name).

For the record, I didn't receive any errors regarding outdated paths for my AutoSuggest Dictionaries, but Trados clearly could not locate them (e.g., no terms were appearing on the Studio interface).

After adjusted the paths for all three items in all of my project templates, I am sailing smoothly (more or less).


Direct link Reply with quote
 


To report site rules violations or get help, contact a site moderator:


You can also contact site staff by submitting a support request »

Error in Studio 2011 "Translation memory not found"

Advanced search







Déjà Vu X3
Try it, Love it

Find out why Déjà Vu is today the most flexible, customizable and user-friendly tool on the market. See the brand new features in action: *Completely redesigned user interface *Live Preview *Inline spell checking *Inline

More info »
CafeTran Espresso
You've never met a CAT tool this clever!

Translate faster & easier, using a sophisticated CAT tool built by a translator / developer. Accept jobs from clients who use SDL Trados, MemoQ, Wordfast & major CAT tools. Download and start using CafeTran Espresso -- for free

More info »



Forums
  • All of ProZ.com
  • Term search
  • Jobs
  • Forums
  • Multiple search