Special characters displayed incorrectly in exported HTML file
Thread poster: Ilaria Feltre

Ilaria Feltre  Identity Verified
Malta
Local time: 12:19
Member
English to Italian
+ ...
Oct 10, 2012

Hello there!

I've recently upgraded to Studio 2011 and in my exported HTML file special characters are not displayed correctly, which never happened when I was using 2009.

I have an English keyboard and I use ALT+number pad combination to type Italian special characters.

This never caused me any problem before, but now the characters display correctly in Trados, but come up incorrectly in the exported file.

Eg:

- "à" (inserted by typing ALT+0224) appears as "Ã" in the exported file (while it looks fine in Trados)

- "é" (ALT+0233) appears as "é"


Can anyone help, please?


Thank you very much!



[Edited at 2012-10-10 16:32 GMT]


Direct link Reply with quote
 
Joakim Braun  Identity Verified
Sweden
Local time: 12:19
German to Swedish
+ ...
Viewed in... what? Oct 10, 2012

"Comes up incorrectly in the encoded file" is a meaningless statement.
HTML files are text files, and display varies between applications.
What application are you using to view the HTML?

"é" indicates that a Unicode file was written.

Does the HTML file contain Unicode text-encoding meta headers?
If not, browsers may or may not display Unicode characters correctly.

(I suspect that your problem can be fixed by adjusting the "Meta charset tags" settings in the File types->HTML->Writing tab of the Trados project settings. If there still is such a thing in the 2011 version.)

[Bearbeitet am 2012-10-10 12:20 GMT]


Direct link Reply with quote
 

Ilaria Feltre  Identity Verified
Malta
Local time: 12:19
Member
English to Italian
+ ...
TOPIC STARTER
Doesn't work... :( Oct 10, 2012

Joakim Braun wrote:

"Comes up incorrectly in the encoded file" is a meaningless statement.


It is indeed, that's why I never wrote such a thing!

Ok, I should be clearer on the nature of this file...

I've received a Trados package from the client, I translated the HTML file it contained, I've exported the file in Trados Studio 2011 and opened it with Mozilla firefox, where all special characters have been changed into garbled text.

Before delivering to the client, I had to open the file with text pad and manually modify the characters, after which the file displayed correctly in FireFox.

So the problem is during the process of exporting the file, since characters like "à" are perfectly fine both while editing the file in trados and when they are inserted in the file itself manually.

Thanks for the advice, Joakim, I tried your suggestion of modifying the settings of tags (yes, Studio still has it), but to no avail (I tried all 3 options)...

Any other suggestion?

Thanks in advance.

BTW, if it helps... The file does contain a META tag and the charset is UTF-8 according to the tag itself. Hope it makes sense...

[Edited at 2012-10-10 13:10 GMT]


Direct link Reply with quote
 

B D Finch  Identity Verified
France
Local time: 12:19
Member (2006)
French to English
+ ...
Encoding? Oct 10, 2012

Have you tried changing the encoding in Firefox (View menu: Character encoding) or using another browser?

Direct link Reply with quote
 

Ilaria Feltre  Identity Verified
Malta
Local time: 12:19
Member
English to Italian
+ ...
TOPIC STARTER
Problem is when exporting... Oct 10, 2012

B D Finch wrote:

Have you tried changing the encoding in Firefox (View menu: Character encoding) or using another browser?


Hi B D, thank you very much for your suggestion.

The text is garbled even when the file is opened with Textpad (while it isn't in Trados), so the problem occurs when exporting.

Thanks for helping though... Any other advice?

Cheers!


Direct link Reply with quote
 

Cris_Pa  Identity Verified
Chile
Local time: 08:19
English to Spanish
Replace all those characters with html entites Oct 10, 2012

Maybe it's not the solution you are looking for, but at least you will be able to see the characters displayed correctly in your browser.

Direct link Reply with quote
 

Ilaria Feltre  Identity Verified
Malta
Local time: 12:19
Member
English to Italian
+ ...
TOPIC STARTER
Leaves me with the problem when exporting other HTML files... Oct 10, 2012

Cris_Pa wrote:

Maybe it's not the solution you are looking for, but at least you will be able to see the characters displayed correctly in your browser.


Cheers, Cris.

I've modified the exported file with textpad, but it might be tricky for longer projects.

It did help me make sure I could deliver the file on time, but I'd like Trados to do it automatically for the future!

Thanks for your suggestion, though.


Direct link Reply with quote
 
Joakim Braun  Identity Verified
Sweden
Local time: 12:19
German to Swedish
+ ...
Debugging advice Oct 10, 2012

For the IT oriented...

I'd try to reduce the translation to the smallest amount of text that still generates problematic target files. Perhaps a line with accented characters.
Then create a new project and enter that text from scratch and see what is exported. Is the problem still there? If not, the difference is almost certainly due to some difference in the project HTML writing settings.

Also look at the exported HTML files in a hex editor to see what bytes are actually generated.
Perhaps there's a clue there. Is it valid Unicode, for one thing?

(If you're checking files in a text editor, make sure you know what the assumed text encoding is when opening the file. Good text editors have a setting for that.)


Direct link Reply with quote
 

SDL Community  Identity Verified
United Kingdom
Local time: 12:19
English
You could try... Oct 10, 2012

... changing the active document settings. So open the file and check File - Active Document Settings to see what the target is. The default is Auto-select so it is always possible of course that the source files you have are incorrectly encoded or are missing a BOM where it's needed.

Maybe this can help?

Regards

Paul


Direct link Reply with quote
 

Ilaria Feltre  Identity Verified
Malta
Local time: 12:19
Member
English to Italian
+ ...
TOPIC STARTER
Yes! Oct 11, 2012

Joakim Braun wrote:

For the IT oriented...

I'd try to reduce the translation to the smallest amount of text that still generates problematic target files. Perhaps a line with accented characters.
Then create a new project and enter that text from scratch and see what is exported. Is the problem still there? If not, the difference is almost certainly due to some difference in the project HTML writing settings.


That was exactly the problem. What I received was a project package, so the customer's settings must have been defined in a different way.

When I exported the file and opened it with my browser it was fine.

Problem solved, thank you Joakim!


Direct link Reply with quote
 

Ilaria Feltre  Identity Verified
Malta
Local time: 12:19
Member
English to Italian
+ ...
TOPIC STARTER
Thanks! Oct 11, 2012

SDL Support wrote:

... changing the active document settings. So open the file and check File - Active Document Settings to see what the target is. The default is Auto-select so it is always possible of course that the source files you have are incorrectly encoded or are missing a BOM where it's needed.

Maybe this can help?

Regards

Paul


Thanks for the assistance, Paul. The problem is now solved.


Direct link Reply with quote
 


To report site rules violations or get help, contact a site moderator:


You can also contact site staff by submitting a support request »

Special characters displayed incorrectly in exported HTML file

Advanced search







Déjà Vu X3
Try it, Love it

Find out why Déjà Vu is today the most flexible, customizable and user-friendly tool on the market. See the brand new features in action: *Completely redesigned user interface *Live Preview *Inline spell checking *Inline

More info »
LSP.expert
You’re a freelance translator? LSP.expert helps you manage your daily translation jobs. It’s easy, fast and secure.

How about you start tracking translation jobs and sending invoices in minutes? You can also manage your clients and generate reports about your business activities. So you always keep a clear view on your planning, AND you get a free 30 day trial period!

More info »



Forums
  • All of ProZ.com
  • Term search
  • Jobs
  • Forums
  • Multiple search