Studio 2011 SP2R no more "highlight color" shortcut
Thread poster: Daniel Ernwein

Daniel Ernwein  Identity Verified
Local time: 16:32
English to French
Dec 14, 2012

In Studio 2011 SP2, when working on docx files, I used to be able to highlight text using Ctrl+9 and Ctrl+Space to remove the highlighted color, but in the most recent release (SP2R), the keyboard shortcut has disappeared! I found the function again in Format > Insert tag... and HighlightColor/No HighlightColor, but didn't manage to add a shortcut.

Now, the shortcuts Ctrl+5/Ctrl+Space seem to work on doc files.

Please help!


Direct link Reply with quote
 

SDL Community  Identity Verified
United Kingdom
Local time: 22:32
English
Still there... just less accessible than it was Dec 15, 2012

Hi,

If you click on the QuickInsert list here:


Then you'll find the commands in there:


You can select them and apply the highlighting this way.

The reason they disappeared is that the latest CU moved the lesser used commands off the bar to make space for custom shortcuts. There should be an improved handling of these quickinserts in a later release.

Regards

Paul


Direct link Reply with quote
 

Daniel Ernwein  Identity Verified
Local time: 16:32
English to French
TOPIC STARTER
disappointing Dec 16, 2012

Hi Paul,

What you describe is what I found. It is just disappointing to see that the latest update is regressing on this! I hope you will add a shortcut again shortly, or the possibility to add a custom shortcut for those who want it.

Regards,

Daniel


Direct link Reply with quote
 
klaudiaLIWO
Poland
frustrating Jul 3, 2014

Paul, we now have year: 2014 - and I have the same problem which Daniel described in 2012. Is there any way to create "Custom button" which will apply highlight color? I've tried but I can not do this This problem is only with docx. file.

With keyboard shortcut it will be so much easier. Clicking the mouse every time is just frustrating.


Direct link Reply with quote
 
FrancoisP
France
Local time: 22:32
English to French
+ ...
Yes, frustrating Jul 9, 2014

Klaudia, did you really find a hidden way to highlight text in Word files using Trados Studio 2014?

I looked at existing Quick Insert buttons and did not see any highlight option. I also tried to create a custom button using the highlight tags Studio 2014 does handle, but it doesn't work. Instead of creating tags, it simply adds text.


Direct link Reply with quote
 
Kathryne
English to Russian
custom shortcut to highlight text Dec 16, 2014

I have the same problem as Daniel: highlighting text using Ctrl+9 disappeared in the most recent release (SP2R). On my computer I haven't been able to see the screenshots posted as instruction for him on how to create this shortcut. Very frustrating - both. It's the shortcut I use MOST OFTEN. Could anybody please post the same instructions WITH SCREENSHOTS again. Many thanks

Direct link Reply with quote
 

Daniel Ernwein  Identity Verified
Local time: 16:32
English to French
TOPIC STARTER
Submit your ideas Dec 16, 2014

Kathryne, I sent you the answer in a private message.

Anyone interested in having SDL work on this feature again, please submit your ideas to http://ideas.sdltrados.com

You may also vote for the idea I posted a while ago (not exactly the same, but going the same way) here: http://ideas.sdltrados.com/ideas/detail.asp?i=3062
You have to log in to your SDL account to be able to display the message and vote/comment.


Direct link Reply with quote
 

Mads Grøftehauge  Identity Verified
Local time: 22:32
English to Danish
+ ...
Long key sequence for HighlightColor Feb 3, 2015

I miss this possibility too (that's why I'm in this thread).

Note that it IS possible to use a keyboard "shortcut", it just isn't very short:

[select text]
alt
o
i
tab
tab
tab
h
enter

If you have a very customizable keyboard, you might be able to put all that in one button. Maybe create a macro? (I would like to know how to do that).

NOTE: This works in Studio 2011 - I don't have 2014.


Direct link Reply with quote
 

Daniel Ernwein  Identity Verified
Local time: 16:32
English to French
TOPIC STARTER
macro Feb 3, 2015

Mads, you have a good point. The keyboard sequence is different within Studio 2014... It would be
Alt
h
i2
tab
tab
tab
h
Enter

As for creating a macro in order to get this sequence done faster, you may install AutoScript (http://www.autohotkey.com/) and create a script using your sequence, while triggering the script with a customised key or combination of keys.

Here is the script for Studio 2011, following your sequence:

#IfWinNotActive ahk_class ConsoleWindowClass

;press on Win+F2 to run the macro
#F2::
{
Send !oi
Send {TAB}{TAB}{TAB}
Send h
Send {Enter}
}
#IfWinNotActive



And here is the script for Studio 2014, following the updated sequence:

#IfWinNotActive ahk_class ConsoleWindowClass

;press on Win+F2 to run the macro
#F2::
{
Send !hi2
Send {TAB}{TAB}{TAB}
Send h
Send {Enter}
}
#IfWinNotActive


As a side note, #F2 means you are triggering the macro with the keyboard sequence "Windows key+F2", which is usually not used in most configurations.
Please try it and let me know!


Direct link Reply with quote
 

Jussi Rosti  Identity Verified
Finland
Local time: 23:32
Member (2005)
English to Finnish
+ ...
Didn't work for me -> Another solution May 18, 2015

Daniel Ernwein wrote:

Send !hi2


Hi Daniel,

I tried this, but for some strange reason I could not make it to send the prefix Alt. Tried other ways, too (like {LAlt}). Anyway, your solution was helpful, as I put this pattern to MacroExpress, which was happy to send the Alt key, too. Works nicely.


Direct link Reply with quote
 

Daniel Ernwein  Identity Verified
Local time: 16:32
English to French
TOPIC STARTER
Try decomposing the code May 18, 2015

[quote]Jussi Rosti wrote:

Daniel Ernwein wrote:

Send !hi2


Hi Daniel,

I tried this, but for some strange reason I could not make it to send the prefix Alt.


Hi Jussi,

You may try to decompose the code first, and see if the Alt key is properly sent or not. Simply keep the first line of the code to start with (i.e. Send !h, or even Send !), and try. If it doesn’t work, try it manually (see if the following sequence works on your keyboard: press Alt, then enter h then enter i2 then hit tab 3 times, press h and hit Enter).

When you press the Alt key, you should actually see shortcuts displayed under each icon in the ribbon. Just follow the corresponding shortcut to reach the same path as: Home > QuickInsert > Highlight Color > Enter.

As a side note, the highlight function is not enabled with all files! For instance, it works with Word files, but not other formats like html or xml...


Direct link Reply with quote
 


To report site rules violations or get help, contact a site moderator:


You can also contact site staff by submitting a support request »

Studio 2011 SP2R no more "highlight color" shortcut

Advanced search







SDL MultiTerm 2017
Guarantee a unified, consistent and high-quality translation with terminology software by the industry leaders.

SDL MultiTerm 2017 allows translators to create one central location to store and manage multilingual terminology, and with SDL MultiTerm Extract 2017 you can automatically create term lists from your existing documentation to save time.

More info »
Across v6.3
Translation Toolkit and Sales Potential under One Roof

Apart from features that enable you to translate more efficiently, the new Across Translator Edition v6.3 comprises your crossMarket membership. The new online network for Across users assists you in exploring new sales potential and generating revenue.

More info »



Forums
  • All of ProZ.com
  • Term search
  • Jobs
  • Forums
  • Multiple search