Error with bilingual Workbench doc file in Studio 2011 SP2
Thread poster: Maria Grazia Weiner

Maria Grazia Weiner  Identity Verified
United Kingdom
Local time: 01:53
Member (2013)
English to Italian
+ ...
Jan 9, 2013

I have to regularly produce the old bilingual Workbench .doc files for a client. I have both Trados 2007 and Studio 2011 SP2 Freelance Edition.

Until today I never encountered any problems. First I pre-translate the Word 2003 .doc file using the same blank Trados 2007 TM, I then open the generated bilingual Workbench .doc file in Studio 2011 (often within a project but also as a single file), translate it and then finalize or save it as target.

However, today after having added a bilingual Workbench .doc file to a project, the following error message was returned every time I tried to prepare it without TM:
'Internal error. Multiple placeholder tags with the same ID XXX have different tag properties'.

I tried to save the bilingual Workbench into a docx file, but same message appeared. I finally managed to create the sdlxliff file by opening the same bilingual .doc as a single file, using the same Studio 2011 TM

What puzzles me is that afterwards I opened two more bilingual Workbench .doc files - pre-translated in 2007 using the same TM - within the same project and the conversion to the translatable format was completed without errors.

Any ideas why this may have happened? All 3 were Word 2003 files.
Thank you for any suggestions, just in case it happens again.
Grazia


Direct link Reply with quote
 

yllea
Local time: 03:53
English to Estonian
+ ...
Error with bilingual Workbench doc file in Studio 2011 SP2 Jan 9, 2013

Hi Grazia,
Thanks for raising this again. I raised this issue some time ago but haven't found a solution yet. I also encounter exactly the same problem with some bilingual Workbench files and get the same error message. Most of the time it works but sometimes it doesn't.
I would be grateful for any ideas as to why this is happening.
Cheers,
Ülle


Direct link Reply with quote
 

Nora Diaz  Identity Verified
Mexico
Local time: 18:53
Member (2002)
English to Spanish
+ ...
Footnote-related? Jan 9, 2013

I have seen this also from time to time and I have been able to narrow it down to what appears to be a footnote-related problem in the original Word file.

I have had some success deleting the "Page X of Y" portion of the footnote in some files before pre-translating, and then the file is processed correctly by Studio. After the target file is created, I restore the deleted section in the finalized file.

Strangely, though, the problem doesn't happen every time I have a file with a footnote including "Page X of Y", so I suspect some sort of internal document structure issue.


Direct link Reply with quote
 
Scott Spellerberg  Identity Verified
Sweden
Local time: 02:53
Swedish to English
+ ...
Another work-around that has worked for me Jan 23, 2013

Whenever Studio rejects a file has having "bilingual text" (usually from someone using Workbench), I just convert it to an open document format (.odt) translate that in Studio, then re-convert the translation to the original format.

Direct link Reply with quote
 

Nora Diaz  Identity Verified
Mexico
Local time: 18:53
Member (2002)
English to Spanish
+ ...
Issue still present in Studio 2014 Oct 3, 2013

This keeps popping up from time to time and appears to persist in Studio 2014, so I thought I'd update the thread with a blog post with a possible workaround that hopefully others will find useful:

http://noradiaz.blogspot.com/2013/10/multiple-placeholder-tags-with-same-id.html


Direct link Reply with quote
 

Alexandra Beisl  Identity Verified
Germany
Local time: 02:53
English to German
+ ...
Also happening in single file work flow Jan 27, 2014

Hi there. I thought I might update this and let you know that this also happens in the single file work flow in Studio 2014, which was supposed to be able to handle all sorts of docs with footnotes galore. Alas, it is not...

Direct link Reply with quote
 
Torgeir H
Norway
Same error message and a few others also Aug 27, 2014

Hi

I have a legacy bilingual doc file which I needed for PerfectMatching in Studio.

So I basically edited the Word file (as described below), added it to a Studio project, converted to translatable format, noted the error, deleted the file from Studio and repeated the process of deleting another element from the Word file.

Opening the file in Studio generated the "multiple ..." error. id40 in my case.
I removed all pagenumbers in the footer as suggested by Nora. The error persisted.
So I removed all fields (using ^d in the search/replace dialog in Word). Not ideal, since this removes all index entries and cross-references.
Same error message again, but new id (id177) this time. Removed all graphics in Word (using ^g), since this has worked before.
Completely new error message: "sub segments not allowed". Old Trados used segments within segments. So I removed these also (you need to search for \{1\> and \{2\> with wildcards activated to find these).
And bingo! I was able to generate an sdlxliff file with most of the translations from the legacy doc file.

Torgeir


Direct link Reply with quote
 


To report site rules violations or get help, contact a site moderator:


You can also contact site staff by submitting a support request »

Error with bilingual Workbench doc file in Studio 2011 SP2

Advanced search







Across v6.3
Translation Toolkit and Sales Potential under One Roof

Apart from features that enable you to translate more efficiently, the new Across Translator Edition v6.3 comprises your crossMarket membership. The new online network for Across users assists you in exploring new sales potential and generating revenue.

More info »
TM-Town
Manage your TMs and Terms ... and boost your translation business

Are you ready for something fresh in the industry? TM-Town is a unique new site for you -- the freelance translator -- to store, manage and share translation memories (TMs) and glossaries...and potentially meet new clients on the basis of your prior work.

More info »



Forums
  • All of ProZ.com
  • Term search
  • Jobs
  • Forums
  • Multiple search