Cannot add/edit terms in MultiTerm 2011/Windows 8/Java 7 (all 64-bit)
Thread poster: Claudia Krysztofiak

Claudia Krysztofiak  Identity Verified
Germany
Local time: 02:37
English to German
+ ...
Mar 2, 2013

First of all: I am aware that there is an older thread about this problem in MultiTerm 2009 and I read it thoroughly but it did not help.
Since I have different versions of almost every software mentioned in that thread, I decided to start a new one and hope you can help me here.

I have installed SDL Trados Freelance 2011 on a Computer with Windows 8 (64 bit) and the current version of Java.
When I started using MultiTerm 2011 everything ran smoothly at first (apart from the annoying alert, that came up every time I added an entry, but I found the solution to that in SDL's Knowledge Base).

Some days ago, MultiTerm came up with a new behaviour: When I try to add a term, it starts some process and opens a blank page for a new term, but without any entry fields. When I close MultiTerm or this empty page, the program politely tells me, that I will lose any changes, so it seems to do something in the background, but it does not come forward with the required entry fields.

I already tried:
- repairing my SDL installations (Trados and Multiterm)
- Deinstall and Reinstall Java
- Add the line -xmx700 to Java

Deinstalling and Reinstalling Java helped after the first restart. After the second restart everything was back to blank.

The version I use:
- Windows 8 Pro 64-bit mit 8 GB Ram
- Trados 2011 SP2R - 10.4.3056.0
- MultiTerm 2011 SP2 - 9.2.36.1.0
- Java 7-15 (Build 1.7.0_15-b03)

Thanks in advance for every useful advice!icon_smile.gif


 

Lorenzo Bermejo
Local time: 02:37
English to Spanish
+ ...
a possible solution Mar 2, 2013

hi Claudia,
maybe you are using Java 64 bits...
Studio and Multiterm are 32 bits applications, so they need Java 32 bits to work properly.
try uninstalling Java 64 bits and installing Java 32 bits.
hope it helps...
kind regards,
Lorenzo


 

Dominique Pivard  Identity Verified
Local time: 03:37
Finnish to French
32-bit and 64-bit Java can cohabit Mar 2, 2013

Lorenzo Bermejo wrote:
maybe you are using Java 64 bits...
Studio and Multiterm are 32 bits applications, so they need Java 32 bits to work properly.
try uninstalling Java 64 bits and installing Java 32 bits.

For the record, you don't need to uninstall the 64-bit version of Java: both will cohabit without problems.


 

Alexey Ivanov  Identity Verified
Russian Federation
Local time: 03:37
English to Russian
I had the same problem Mar 2, 2013

I also work in Windows 64-bit and had this problem. I don't remember very clearly, but I think i just rolled back to some older versions of Java by simply deleting the latest one and testing Multiterm after that.

Please also note that Multiterm Integration for MS Word does not have a 64-bit version. Moreover, SDL Trados declared that they have no intention of developing it. So, after installing SDL Trados Studio 2011 just delete the Integration for MS Word from your programs list, or else you will have problems with Word files: after opening a new file it will keep informing you about a problem with one of the macros and you willl also have problems with closing it. Actually, it is caused by the Integration for MS Word macro which has only a 32-bit version.

[Edited at 2013-03-02 18:26 GMT]


 

Claudia Krysztofiak  Identity Verified
Germany
Local time: 02:37
English to German
+ ...
TOPIC STARTER
Rollback helps, but is no solution IMHO Mar 2, 2013

Thank you for your swift replies!

Lorenzo, you are right, I am using Java 64 bit, and also Java 32 bit. MultiTerm 2011 should be able to handle this, especially since the release notes refer to 64 bit environments.

Thank you for clarifying, Dominique, that was also my experience (so far)icon_smile.gif.

And thank you for your suggestion, Alexey. A rollback to Java 6 was what I decided to do for now, but I do not regard it as a solution, just a hot fix. But, alas, it works. icon_smile.gif

Apparently I did not search the Knowledge base well enough, though.
I just found another interesting article that seems to cover the problem:

Blank page, script error, or error 'no such method "getEntry"' when editing or adding a term to an existing termbase

Also, I got some feedback from our colleague Tapsa, who was able to fix this problem by fixing some Internet Explorer settings, but was not sure which. This sounds exactly like the case mentioned in the Knowledge Base.

I'll delve deeper into this and let you know of my findings, just in case some other desperate translator will stumble across this thread later on.icon_smile.gif

So not all hope is lost. Have a wonderful evening everyone!


 

Claudia Krysztofiak  Identity Verified
Germany
Local time: 02:37
English to German
+ ...
TOPIC STARTER
Doesn't work Mar 5, 2013

Well, back to step one.
My system worked for 3 days and now it is back to abnormal.

What I did:
- deinstalled Java 7 32-bit
- opened MultiTerm 2011, it installed Java 6 32-bit
- opened an XML-file in Internet explorer. IE asked me, if I wanted to register some java add-ons. I confirmed.
- opened Trados, added new terms to the database, everything great

After a restart Java 7 update was initiated, which was fine with me.
Still, everything went smoothly.

Today, after one day of efficient work, I again had to start wasting my time: Suddenly Trados could no longer open the (old version) MultiTerm Database. Multiterm still could, but I also could no longer edit terms, again.

I then repaired the whole suite, reset the IE-Settings and manually registered the jscript.dll.

No success. All just a waste of time.

(I forgot: Naturally, I rebooted my system between steps, just in case anyone would like to know.)

So I apparently have to stick to an obsolete Java version, to be able to use the SDL Suite the way it should be usable, with all features.

Not very satisfying. If anyone can offer some more support/insight, how to solve this, it would be greatly appreciated.

Have a good time and efficient working hours everybody!icon_smile.gif


 

Gabor Inokai  Identity Verified
Australia
Local time: 11:37
German to English
+ ...
It works on Win7 (64-bit) as described on the SDL KB website May 15, 2013

Hi Claudia,

I joined the forum recently and cannot resist the temptation to share with you and others the fix described in the SDL knowledge base.

It has worked for me on 64-bit Win7 and I don't see any reason why it would not on 64-bit Win8.
---------------------------------------------------------------------------------------------------
http://kb.sdl.com/kb/?ArticleId=4645#tab:homeTab:crumb:7:artId:4645
At the time of writing, there is only one possible workaround.

Go to Control Panel > Programs > Java to open the Java Control Panel.
Open the Security tab.
Set the security level to Medium:
---------------------------------------------------------------------------------------------------
However it's worth pointing out the risks and the reasons behind the change.
Oracle is the owner of Java and it distributes the updates periodically. On 13 Jan 2013 the new update changed the default Java Security Level setting from "Medium" to "High". Changing it back to Medium opens the gate to vulnerabilities as described on their web page:

http://www.oracle.com/technetwork/topics/security/alert-cve-2013-0422-1896849.html

These vulnerabilities may be remotely exploitable without authentication, i.e., they may be exploited over a network without the need for a username and password. To be successfully exploited, an unsuspecting user running an affected release in a browser will need to visit a malicious web page that leverages these vulnerabilities. Successful exploits can impact the availability, integrity, and confidentiality of the user's system.
---------------------------------------------------------------------------------------------------
My recommendations are as follows:
• Before starting up SDL MultiTerm or Trados Studio change the security level to Medium
• Work with SDL as usual, you can edit your termbase in both apps
• Refrain from visiting dubious web sites that may exploit these vulnerabilities
• At the end of your SDL session do not forget to change back the security level to High (minimum recommended)

I hope this helps and saves a lot of time.


 

Yasushi Toyama
Local time: 09:37
Japanese to English
Does Java work in your environment? Nov 25, 2013

Hi,

I also experienced the same problem (Java 1.7.0_25, 1.6.0_24, 1.5.0_10, Multiterm 2011, Windows 8.1 64 bit).

When editing/adding terms in Multiterm, java seemed not to work, because a java icon did not appear in the lower right system tray).

There are a lot of measures against such a case in the internet, look for by keyword "java applet does not work" or so.

In my case, I now solved the problem by deselecting Enable java contents in browser in Security tab in Java control panel.

Hope this helps you.


 

Christine Lee-Roth  Identity Verified
United States
Local time: 17:37
English to Korean
+ ...
Thanks all and especially to Yasushi Dec 5, 2013

Yasushi Toyama wrote:

In my case, I now solved the problem by deselecting Enable java contents in browser in Security tab in Java control panel.

Hope this helps you.


In my case, deselecting Enable Java Contents worked as well while all the other previous attempts failed.
I'm not sure if it's ok with the "Enable J C" being deselected for other computing purposes, but at least for the Multi Term, this works as a solution.

Thanks again Yasushi and Claudia, who initiated this, and everybody else who contributed.


 

Vladimír Hoffman  Identity Verified
Slovakia
Local time: 02:37
Member (2009)
English to Slovak
+ ...
My experience May 11, 2014

After recent update of SDL Trados 2011 (Windows 2007), I, too, begun to experience problems with adding/editing terms in Multiterm 2011/SDL Trados 2011. I tried to modify Java 7 update 25 settings (Security at Medium, unchecked Enable next generation Java), which worked with same problem in January, but to no avail. So, I followed Yasuhi's advice and unchecked Enable Java Content in Java 7 and Multiterm prompted me to download Java 7 update 55. I did so and now it works!

Important note: Enable next generation Java under Java Control Advanced tab must be checked in this case, otherwise addding/editing terms still remains unfunctional!


Yasushi Toyama wrote:

Hi,

I also experienced the same problem (Java 1.7.0_25, 1.6.0_24, 1.5.0_10, Multiterm 2011, Windows 8.1 64 bit).

When editing/adding terms in Multiterm, java seemed not to work, because a java icon did not appear in the lower right system tray).

There are a lot of measures against such a case in the internet, look for by keyword "java applet does not work" or so.

In my case, I now solved the problem by deselecting Enable java contents in browser in Security tab in Java control panel.

Hope this helps you.


 


To report site rules violations or get help, contact a site moderator:


You can also contact site staff by submitting a support request »

Cannot add/edit terms in MultiTerm 2011/Windows 8/Java 7 (all 64-bit)

Advanced search







Anycount & Translation Office 3000
Translation Office 3000

Translation Office 3000 is an advanced accounting tool for freelance translators and small agencies. TO3000 easily and seamlessly integrates with the business life of professional freelance translators.

More info »
PerfectIt consistency checker
Faster Checking, Greater Accuracy

PerfectIt helps deliver error-free documents. It improves consistency, ensures quality and helps to enforce style guides. It’s a powerful tool for pro users, and comes with the assurance of a 30-day money back guarantee.

More info »



Forums
  • All of ProZ.com
  • Term search
  • Jobs
  • Forums
  • Multiple search