Help needed with Tag Editor
Thread poster: Haluk Levent Aka
Haluk Levent Aka
Local time: 23:01
Japanese to Turkish
+ ...
Sep 8, 2004

Hello, I'm translating an asp file in Trados tag editor. File contains text in white color. When tageditor opens the segments for translation it draws a yellow rectengular area around the target segment and a blue rectengular area around the source segment, rendering the white text illegible.

How can I change the color of this rectengular area -or that of the text appearance? Or, is there another way to render the text readable again? It is really pain to read white text over yellow bg.

Thanks & Regards,
Haluk

[Edited at 2004-09-08 21:18]


Direct link Reply with quote
 

Jerzy Czopik  Identity Verified
Germany
Local time: 21:01
Member (2003)
Polish to German
+ ...
Look at this article from Trados KB Sep 8, 2004

http://support.trados.com/view.asp?cntID=829
Possibly this may help

Regards
Jerzy


Direct link Reply with quote
 
Haluk Levent Aka
Local time: 23:01
Japanese to Turkish
+ ...
TOPIC STARTER
Thank you, but ... Sep 8, 2004

Jerzy Czopik wrote:

http://support.trados.com/view.asp?cntID=829
Possibly this may help

Regards
Jerzy


Thank you for this little workaround Jerzy. But this way the global settings of XP is changed. So the change made there will affect all other application windows. Also, the problem I am having is not with white background of document window; but it is with the light (light blue or yellow) color of rectengular areas tegeditor draws around segments.

I solved the issue temporarily by changing the texts in asp to black using Front Page. I will change them back to white when translation is finished.

I thought there must have been a key combination to change color of rectengular area to some other high contrast color (this is possible in Wordfast). But I guess there isn\'t any.

Thank you again.

Best Regards,
Haluk


Direct link Reply with quote
 

Jerzy Czopik  Identity Verified
Germany
Local time: 21:01
Member (2003)
Polish to German
+ ...
I'm sorry, but you are right Sep 8, 2004

AFAIK there is no way to change this setting in Trados.
This workaround changes the settings of Windows indeed, but this is temporarily so - you can change the background colour to lets say blue only for such phrases and turn it back to white after closing such segment. I know, that this is not very convenient, but I did not find anything else.

Regards
Jerzy


Direct link Reply with quote
 

Piotr Bienkowski  Identity Verified
Poland
Local time: 21:01
Member (2005)
English to Polish
+ ...
Some tools mess with source tags Sep 9, 2004

Haluk Aka wrote:

I solved the issue temporarily by changing the texts in asp to black using Front Page.


Hi Haluk,

Correct me if I'm wrong, but I'd be wary of using tools that could change tags in the original file that you don't intend to change. As far as I know, Front Page can be one of such tools.

If you need to change something in the source file, it's best to use tools which do not change the tags of the original file on their own, such as plain text editors. Notetab Pro, and Notetab Light (www.notetab.com) are just two examples, but there are many available for free. The only requirement is that the plain text editor must support the code page the file is saved in.

I think you should tell your client about the problem, because most clients do not like it when the translator tampers with the file in addition to translating.

HTH

Piotr


Direct link Reply with quote
 
Haluk Levent Aka
Local time: 23:01
Japanese to Turkish
+ ...
TOPIC STARTER
Good point Piotr Sep 15, 2004

syntaxpb wrote:

Hi Haluk,

...

I think you should tell your client about the problem, because most clients do not like it when the translator tampers with the file in addition to translating.

HTH

Piotr


Good point and very true. But I\'m the client in this case So it\'s not a problem. But I still believe there should be a way of doing this. I guess this will go in bunch of other reasons \"why I wouldn\'t buy Trados if I knew better\".

Regards,
Haluk


Direct link Reply with quote
 

Ralf Lemster  Identity Verified
Germany
Local time: 21:01
English to German
+ ...
Bit late, but maybe it helps... Oct 7, 2004

Here's a suggestion made on TW_users - it specifically refers to HTML, but maybe it works for you, too:


Try telling TagEditor to ignore the FONT tag when translating HTML
files:

0. Close any open HTML files.
1. Go to Tools - DTD Settings.
2. Select the HTML DTD Settings file.
3. Go to Properties - Elements - Advanced.
4. Tick the "Disable formatting for FONT tags" check box.

Click OK until you are back in TagEditor and reopen the HTML file. The white text should display normally now.


HTH, Ralf

[Edited at 2004-10-07 18:47]

[Edited at 2004-10-07 18:47]


Direct link Reply with quote
 
Haluk Levent Aka
Local time: 23:01
Japanese to Turkish
+ ...
TOPIC STARTER
Thank you Ralf Oct 7, 2004

Ralf Lemster wrote:

Here's a suggestion ...



I'll give it a try.

Best Regards,
Haluk


Direct link Reply with quote
 

PCovs
Denmark
Local time: 21:01
Member (2003)
English to Danish
+ ...
Try changing the "Translated text colours" Oct 9, 2004

...in Workbench.

That would be my suggestion.

"Options" => "Translated text colours"



Direct link Reply with quote
 
Haluk Levent Aka
Local time: 23:01
Japanese to Turkish
+ ...
TOPIC STARTER
How to solve the issue Nov 18, 2004

It appears there is no way to change Tag Editor's preferences and solve this issue and altering the text color in an HTML editor is risky for most files. Here is how I solved the issue:

1) Open the file in a plain text editor (ie. right click and open with Notepad.exe).
2) Check all color codes used in document and pick a color code that is not used (ie. #000001). Than identify the color code that causes you trouble (for me it was #FFFFFF -white).
3) Substitute all #FFFFFF to #000001 (ie. Ctrl-H than Replace All) and save the file (make sure you didn't make any other changes).
4) Edit the file as you normally do.
5) Open the file in a plain text editor and change all references to #000001 to their original color (in this case #FFFFFF).
6) Save the file.

This should do it. But be careful not to alter any other html code.


Direct link Reply with quote
 


To report site rules violations or get help, contact a site moderator:


You can also contact site staff by submitting a support request »

Help needed with Tag Editor

Advanced search







BaccS – Business Accounting Software
Modern desktop project management for freelance translators

BaccS makes it easy for translators to manage their projects, schedule tasks, create invoices, and view highly customizable reports. User-friendly, ProZ.com integration, community-driven development – a few reasons BaccS is trusted by translators!

More info »
Wordfast Pro
Translation Memory Software for Any Platform

Exclusive discount for ProZ.com users! Save over 13% when purchasing Wordfast Pro through ProZ.com. Wordfast is the world's #1 provider of platform-independent Translation Memory software. Consistently ranked the most user-friendly and highest value

More info »



Forums
  • All of ProZ.com
  • Term search
  • Jobs
  • Forums
  • Multiple search