Pages in topic:   [1 2] >
MultiTerm 2011: EditController error message
Thread poster: Axelle Arbonnier

Axelle Arbonnier  Identity Verified
Belgium
Local time: 14:44
German to French
+ ...
Apr 18, 2013

I use Windows 7 and MultiTerm 2011 and for an hour or so a new error message now appears each time I want to add a new term in a glossary :

"Application bloquée par les paramètres de sécurité" (security settings blocked the application)

Nom (name): EditController

"Vos paramètres de sécurité ont bloqué l'exécution de l'application avec une version de JRE non sécurisée ou arrivée à expiration" (your security settings bloked the running of the application with a non-secure or expired JRE version).

Did any one already experience this? Thanks for any help!


 

Patrick Oblander  Identity Verified
United States
Local time: 05:44
Japanese to English
Yes, since updating Java Apr 18, 2013

I started getting the same message yesterday after updating Java. Previously (just last week) I overcame basically the same problem by applying solution three in article 4645 in the SDL Knowledge Base, but that requires making some custom security settings in Java that are no longer available.
Sorry, I haven't a clue how to overcome it now.


 

SDL Community  Identity Verified
United Kingdom
Local time: 14:44
English
KB 4645 Apr 18, 2013

Hi

I am working already on an update of the KB article you mentioned.

The workaround for the moment is to open the Java Control Panel ( START > Control Panel > Programs > Java ) and go to the Security tab.

Lower the level to "Medium".

Selecting the "Do not show this again for this app" box and then click on "Run" stops this message from reappearing the next time that you try to edit or add a term.
But this only applies here within one session of SDL Trados Studio / SDL MultiTerm. After a restart/reopening of SDL MultiTerm or SDL Trados Studio you will again need to confirm the message at least for the first time you want to add/edit a term.

Cheers
Richard Puschmann | Support Engineer | SDL | Language Technologies Division |

Have a problem with our support? Maybe you already can find an answer in our Knowledge Base here: http://kb.sdl.com
Here you find solutions to known issues and many more....
If you want to keep up-2-date with the latest released articles you can also follow us on Twitter here: https://twitter.com/SDLSupport


 

Axelle Arbonnier  Identity Verified
Belgium
Local time: 14:44
German to French
+ ...
TOPIC STARTER
It works! Apr 18, 2013

Many thanks to both of you for your input. It works... at least until Java's next updateicon_smile.gif

 

Patrick Oblander  Identity Verified
United States
Local time: 05:44
Japanese to English
But is it safe? Apr 18, 2013

Hi Richard,
I understand your instructions, but "High" is the "minimum recommended" setting for Java, according to the Java Security Interface. What risks do we run by lowering it to medium?
Patrick Oblander


 

SDL Community  Identity Verified
United Kingdom
Local time: 14:44
English
Java Apr 19, 2013

Hi Patrick

The risk is very low here since you know what you let run.

The message is saying what applet from what application needs to have the permission from you.

So, reading the message is essential here.


Be aware that from the information I found here http://java.com/en/download/help/appsecuritydialogs.xml I understand even if we sign our applets you will still receive a message.

But anyway, at the moment the workaround is the best what can be used. The only thing is that you need to read the message.

Regards
Richard Puschmann | Support Engineer | SDL | Language Technologies Division |

Have a problem with our support? Maybe you already can find an answer in our Knowledge Base here: http://kb.sdl.com
Here you find solutions to known issues and many more....
If you want to keep up-2-date with the latest released articles you can also follow us on Twitter here: https://twitter.com/SDLSupport


 

André Charbonnet
Greece
Local time: 15:44
Greek to French
+ ...
It works Apr 20, 2013

Thank you ! I got the same problem yesterday evening !!!

 

mihaim
Local time: 15:44
English to Romanian
+ ...
It doesn't work for me, though Apr 20, 2013

Hello Richard,

I did just like you instructed. However, in the Security tab of the Java Control Panel (I have Java 6 Update 35), the Security tab does not look at all like you described.

It only has a region called Certificates, a button labeled Certificates... and three buttons labeled OK, Cancel, and Apply.

There's no option on lowering the security level. Could you please help? Thanks!


 

William Padina
Romania
Local time: 15:44
English to Romanian
+ ...
It works Apr 20, 2013

Thank you

 

mihaim
Local time: 15:44
English to Romanian
+ ...
Fixed, it works! Apr 21, 2013

Mihai Manastireanu wrote:

Hello Richard,

I did just like you instructed. However, in the Security tab of the Java Control Panel (I have Java 6 Update 35), the Security tab does not look at all like you described.

It only has a region called Certificates, a button labeled Certificates... and three buttons labeled OK, Cancel, and Apply.

There's no option on lowering the security level. Could you please help? Thanks!


I finally managed, but not before uninstalling previous versions of Java on my computer. So please make a note saying that uninstalling previous Java versions is a prerequisite for the actions described in your KB article.

Thanks again, Richard!


 

Jørgen Ellekjær  Identity Verified
Denmark
Local time: 14:44
English to Danish
Thanks - highly appreciated Apr 22, 2013

I had no problems getting the Java setup changes to work. I even got rid of the annoying security dialog box every time I attempted to make a new entry.

Before I made the recommended changes to the security settings I had removed the older versions of Java.

Best regards
Jørgen Ellekjær


 

Axelle Arbonnier  Identity Verified
Belgium
Local time: 14:44
German to French
+ ...
TOPIC STARTER
New (related?) error message with MultiTerm 2011 Apr 24, 2013

After having managed to solve the problem owing to SDL Support's answer below, Trados now regularly crashes, always as follows: I can enter a large or small amount of new terms and, randomly, without having performed any unusual action, when entering a new term in MultiTerm while using Trados (term base window), I get a first error message saying "Exception inconnue" (i.e., "unknown exception"), but that doesn't prevent Trados to keep running and, then again, after a couple of new successful attempts to enter a new term, I get a new error message, Trados crashes automatically shuts down and the following error message appears on the desktop: "an external component has thrown an exception".

Thank you for any help!
Axelle

[Modifié le 2013-04-24 14:40 GMT]


 

Orsolya Bugar-Buday  Identity Verified
Hungary
Local time: 14:44
Member (2013)
English to Hungarian
+ ...
two versions of Java? May 1, 2013

Axelle,

I had the same problem about a year ago. If I remember well, the problem was that two versions of Java were installed on my comp, and I had to remove the older version.
Now the problem is that the latest Java version is just too much for MultiTerm (I experienced the same problem as the one you started this topic about).... Maybe SDL can sort it out, sooner rather than later?icon_wink.gif

Good luck and happy International Workers' Day to all of us!
Orsolya
Axelle Arbonnier wrote:

After having managed to solve the problem owing to SDL Support's answer below, Trados now regularly crashes, always as follows: I can enter a large or small amount of new terms and, randomly, without having performed any unusual action, when entering a new term in MultiTerm while using Trados (term base window), I get a first error message saying "Exception inconnue" (i.e., "unknown exception"), but that doesn't prevent Trados to keep running and, then again, after a couple of new successful attempts to enter a new term, I get a new error message, Trados crashes automatically shuts down and the following error message appears on the desktop: "an external component has thrown an exception".

Thank you for any help!
Axelle

[Modifié le 2013-04-24 14:40 GMT]


 

Stefan Helwig
Local time: 14:44
English to German
+ ...
Works fine May 5, 2013

Acknowledging the Java message once per application start is a lot better than being shown the error message and not being able to do anything.
It didn't even say which application's security settings blocked the EditController after all...

As regards different versions of Java running simultaneously, I can only say that I never had problems with Trados 8.6 or Studio, everything went fine until Java 7 u21.


 

Claudia Schreiner  Identity Verified
Austria
Local time: 14:44
Member (2009)
English to German
+ ...
same problem - doesn't work yet May 19, 2013

Dear all,

I've had the same problem and deinstalled several older versions of Java, but it still doesn't work.

I'm afraid of deinstalling too much. I still have:

J2SE Runtime Environment 5.0 Update 10
Java (TM) 6 Update 14 (64-bit)
Java (TM) 6 Update 38

I also deinstalled the latest update Java 7 u21. I hope this doesn't cause a problem on my computer.

I don't get the message "EditController" - "Ihre Sicherheitseinstellungen haben die Ausführung einer lokalen Anwendung blockiert" any more, but even after a restart when trying to add terms to the termbank, it doesn't do anything. Do I have to open a termbank window somewhere? Usually it happened automatically. That's why I think the problem hasn't been solved yet.

I'd be really grateful if you could help!

Thank you in advance,
Claudia


 
Pages in topic:   [1 2] >


To report site rules violations or get help, contact a site moderator:


You can also contact site staff by submitting a support request »

MultiTerm 2011: EditController error message

Advanced search







BaccS – Business Accounting Software
Modern desktop project management for freelance translators

BaccS makes it easy for translators to manage their projects, schedule tasks, create invoices, and view highly customizable reports. User-friendly, ProZ.com integration, community-driven development – a few reasons BaccS is trusted by translators!

More info »
memoQ translator pro
Kilgray's memoQ is the world's fastest developing integrated localization & translation environment rendering you more productive and efficient.

With our advanced file filters, unlimited language and advanced file support, memoQ translator pro has been designed for translators and reviewers who work on their own, with other translators or in team-based translation projects.

More info »



Forums
  • All of ProZ.com
  • Term search
  • Jobs
  • Forums
  • Multiple search